summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-28 15:02:38 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-28 15:02:38 +0000
commitfd07d6b0602237d53b80e639b4f0dd9678a40fa3 (patch)
tree6c9a60a525d2f96d16cb98649fc67a37d2eb5d29 /app-admin/apache-tools
parentVersion bump. (diff)
downloadgentoo-2-fd07d6b0602237d53b80e639b4f0dd9678a40fa3.tar.gz
gentoo-2-fd07d6b0602237d53b80e639b4f0dd9678a40fa3.tar.bz2
gentoo-2-fd07d6b0602237d53b80e639b4f0dd9678a40fa3.zip
Bump for #401761
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/apache-tools')
-rw-r--r--app-admin/apache-tools/ChangeLog9
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.22.ebuild89
2 files changed, 96 insertions, 2 deletions
diff --git a/app-admin/apache-tools/ChangeLog b/app-admin/apache-tools/ChangeLog
index 4e9b50b7dda9..736583a05b1f 100644
--- a/app-admin/apache-tools/ChangeLog
+++ b/app-admin/apache-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/apache-tools
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.105 2011/10/14 16:25:46 beandog Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.106 2012/03/28 15:02:38 patrick Exp $
+
+*apache-tools-2.2.22 (28 Mar 2012)
+
+ 28 Mar 2012; Patrick Lauer <patrick@gentoo.org> +apache-tools-2.2.22.ebuild:
+ Bump for #401761
14 Oct 2011; Steve Dibb <beandog@gentoo.org> apache-tools-2.2.14.ebuild,
apache-tools-2.2.15.ebuild, apache-tools-2.2.16.ebuild,
diff --git a/app-admin/apache-tools/apache-tools-2.2.22.ebuild b/app-admin/apache-tools/apache-tools-2.2.22.ebuild
new file mode 100644
index 000000000000..abb7dca66cd3
--- /dev/null
+++ b/app-admin/apache-tools/apache-tools-2.2.22.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.22.ebuild,v 1.1 2012/03/28 15:02:38 patrick Exp $
+
+EAPI="4"
+inherit flag-o-matic eutils
+
+DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
+HOMEPAGE="http://httpd.apache.org/"
+SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="ssl"
+RESTRICT="test"
+
+RDEPEND="=dev-libs/apr-1*
+ =dev-libs/apr-util-1*
+ dev-libs/libpcre
+ ssl? ( dev-libs/openssl )
+ !<www-servers/apache-2.2.4"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+S="${WORKDIR}/httpd-${PV}"
+
+src_prepare() {
+ # Apply these patches:
+ # (1) apache-tools-2.2.20-Makefile.patch:
+ # - fix up the `make install' for support/
+ # - remove envvars from `make install'
+ epatch "${FILESDIR}"/${PN}-2.2.20-Makefile.patch
+}
+
+src_configure() {
+ local myconf=""
+
+ # Instead of filtering --as-needed (bug #128505), append --no-as-needed
+ append-ldflags $(no-as-needed)
+
+ use ssl && myconf+=" --with-ssl=/usr --enable-ssl"
+
+ # econf overwrites the stuff from config.layout, so we have to put them into
+ # our myconf line too
+ econf \
+ --sbindir=/usr/sbin \
+ --with-z=/usr \
+ --with-apr=/usr \
+ --with-apr-util=/usr \
+ --with-pcre=/usr \
+ ${myconf}
+}
+
+src_compile() {
+ cd support || die
+ emake
+}
+
+src_install () {
+ cd support || die
+
+ make DESTDIR="${D}" install
+
+ # install manpages
+ doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm,ab,logresolve}.1 \
+ "${S}"/docs/man/{htcacheclean,rotatelogs}.8
+
+ # Providing compatiblity symlinks for #177697 (which we'll stop to install
+ # at some point).
+ pushd "${D}"/usr/sbin/ >/dev/null
+ for i in *; do
+ dosym /usr/sbin/${i} /usr/sbin/${i}2
+ done
+ popd "${D}"/usr/sbin/ >/dev/null
+
+ # Provide a symlink for ab-ssl
+ if use ssl; then
+ dosym /usr/sbin/ab /usr/sbin/ab-ssl
+ dosym /usr/sbin/ab /usr/sbin/ab2-ssl
+ fi
+
+ # make htpasswd accessible for non-root users
+ dosym /usr/sbin/htpasswd /usr/bin/htpasswd
+ dosym /usr/sbin/htdigest /usr/bin/htdigest
+
+ dodoc "${S}"/CHANGES
+}