summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-01-05 22:39:00 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-01-05 22:39:00 +0000
commit6b1cad3d4374e38b645234f1a108650c48eb1f1b (patch)
treeb4b2281f655d29f1723a5a29fe9b17813ca72c7e /app-admin/augeas
parentSecurity bump - fixes bug 531684. (diff)
downloadgentoo-2-6b1cad3d4374e38b645234f1a108650c48eb1f1b.tar.gz
gentoo-2-6b1cad3d4374e38b645234f1a108650c48eb1f1b.tar.bz2
gentoo-2-6b1cad3d4374e38b645234f1a108650c48eb1f1b.zip
bumping for fix CVE-2012-0786 (CVE-2013-6412) bug 534448
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'app-admin/augeas')
-rw-r--r--app-admin/augeas/ChangeLog9
-rw-r--r--app-admin/augeas/augeas-1.3.0.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/app-admin/augeas/ChangeLog b/app-admin/augeas/ChangeLog
index bec98399eec1..1927601c9f09 100644
--- a/app-admin/augeas/ChangeLog
+++ b/app-admin/augeas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/augeas
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/augeas/ChangeLog,v 1.58 2014/08/15 17:55:19 armin76 Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/augeas/ChangeLog,v 1.59 2015/01/05 22:39:00 prometheanfire Exp $
+
+*augeas-1.3.0 (05 Jan 2015)
+
+ 05 Jan 2015; Matthew Thode <prometheanfire@gentoo.org> +augeas-1.3.0.ebuild:
+ bumping for fix CVE-2012-0786 (CVE-2013-6412) bug 534448
15 Aug 2014; Raúl Porcel <armin76@gentoo.org> augeas-1.1.0.ebuild:
ia64 stable wrt #506464
diff --git a/app-admin/augeas/augeas-1.3.0.ebuild b/app-admin/augeas/augeas-1.3.0.ebuild
new file mode 100644
index 000000000000..2cdb6bbed8e3
--- /dev/null
+++ b/app-admin/augeas/augeas-1.3.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/augeas/augeas-1.3.0.ebuild,v 1.1 2015/01/05 22:39:00 prometheanfire Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="A library for changing configuration files"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="http://download.augeas.net/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="static-libs test"
+
+RDEPEND="
+ dev-libs/libxml2
+ sys-libs/readline"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=app-doc/NaturalDocs-1.40
+ test? ( dev-lang/ruby )"
+
+#PATCHES=(
+# "${FILESDIR}"/${P}-gets.patch
+# "${FILESDIR}"/${P}-test.patch
+# "${FILESDIR}"/${P}-test2.patch
+# "${FILESDIR}"/${P}-libxml2-pkgconfig.patch
+# )
+
+src_prepare() {
+ if [ -f /usr/share/NaturalDocs/Config/Languages.txt ] ; then
+ addwrite /usr/share/NaturalDocs/Config/Languages.txt
+ fi
+ if [ -f /usr/share/NaturalDocs/Config/Topics.txt ] ; then
+ addwrite /usr/share/NaturalDocs/Config/Topics.txt
+ fi
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ # Needs to implemented
+ local myeconfargs=( --without-selinux )
+ autotools-utils_src_configure
+}
+
+AUTOTOOLS_IN_SOURCE_BUILD=1