summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-05-25 17:09:58 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-05-25 17:09:58 +0000
commitb218db98395f9b8d0b6c5b690d77676e708101b4 (patch)
tree8894ca4d936f24c84b63bc4861897702a177efe9 /app-admin/augeas
parentWork around bug #321145. (diff)
downloadgentoo-2-b218db98395f9b8d0b6c5b690d77676e708101b4.tar.gz
gentoo-2-b218db98395f9b8d0b6c5b690d77676e708101b4.tar.bz2
gentoo-2-b218db98395f9b8d0b6c5b690d77676e708101b4.zip
Version bumped.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/augeas')
-rw-r--r--app-admin/augeas/ChangeLog7
-rw-r--r--app-admin/augeas/augeas-0.7.1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/app-admin/augeas/ChangeLog b/app-admin/augeas/ChangeLog
index 717840095659..d7474160b41b 100644
--- a/app-admin/augeas/ChangeLog
+++ b/app-admin/augeas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/augeas
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/augeas/ChangeLog,v 1.14 2010/02/04 11:35:14 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/augeas/ChangeLog,v 1.15 2010/05/25 17:09:58 matsuu Exp $
+
+*augeas-0.7.1 (25 May 2010)
+
+ 25 May 2010; MATSUU Takuto <matsuu@gentoo.org> +augeas-0.7.1.ebuild:
+ Version bumped.
*augeas-0.7.0 (04 Feb 2010)
diff --git a/app-admin/augeas/augeas-0.7.1.ebuild b/app-admin/augeas/augeas-0.7.1.ebuild
new file mode 100644
index 000000000000..8f63d7972ea4
--- /dev/null
+++ b/app-admin/augeas/augeas-0.7.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/augeas/augeas-0.7.1.ebuild,v 1.1 2010/05/25 17:09:58 matsuu Exp $
+
+DESCRIPTION="A library for changing configuration files"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="http://augeas.net/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="sys-libs/readline"
+DEPEND="${RDEPEND}
+ >=app-doc/NaturalDocs-1.40
+ test? ( dev-lang/ruby )"
+
+src_compile() {
+ if [ -f /usr/share/NaturalDocs/Config/Languages.txt ] ; then
+ addwrite /usr/share/NaturalDocs/Config/Languages.txt
+ fi
+ if [ -f /usr/share/NaturalDocs/Config/Topics.txt ] ; then
+ addwrite /usr/share/NaturalDocs/Config/Topics.txt
+ fi
+
+ econf || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc AUTHORS ChangeLog README NEWS
+}