summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-04-28 09:09:52 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-04-28 09:09:52 +0000
commit6b77c804aaf7d92029ef3fd614b2423d63616077 (patch)
tree4f70c98a93fc08806ab4c000ca02eda03cc7e673 /app-admin/dirvish/dirvish-1.2.1.ebuild
parentStable on alpha + ia64. (diff)
downloadgentoo-2-6b77c804aaf7d92029ef3fd614b2423d63616077.tar.gz
gentoo-2-6b77c804aaf7d92029ef3fd614b2423d63616077.tar.bz2
gentoo-2-6b77c804aaf7d92029ef3fd614b2423d63616077.zip
revision bump. Corrected license to OSL-2.0. Added herd app-backup to metadata
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'app-admin/dirvish/dirvish-1.2.1.ebuild')
-rw-r--r--app-admin/dirvish/dirvish-1.2.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/dirvish/dirvish-1.2.1.ebuild b/app-admin/dirvish/dirvish-1.2.1.ebuild
new file mode 100644
index 000000000000..391cf7c49110
--- /dev/null
+++ b/app-admin/dirvish/dirvish-1.2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/dirvish/dirvish-1.2.1.ebuild,v 1.1 2005/04/28 09:09:52 dragonheart Exp $
+
+DESCRIPTION="Dirvish is a fast, disk based, rotating network backup system."
+HOMEPAGE="http://www.dirvish.org/"
+SRC_URI="http://dirvish.org/${P}.tgz"
+
+LICENSE="OSL-2.0"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="app-arch/tar"
+RDEPEND="dev-perl/Time-modules
+ dev-perl/Period
+ >=net-misc/rsync-2.5.7"
+
+src_compile() {
+ for f in dirvish dirvish-runall dirvish-expire dirvish-locate ; do
+ cat > $f <<-EOF
+ #!/usr/bin/perl
+
+ \$CONFDIR = "/etc/dirvish";
+
+ EOF
+ cat $f.pl >> $f
+ cat loadconfig.pl >> $f
+ done
+}
+
+src_install() {
+ dosbin dirvish dirvish-runall dirvish-expire dirvish-locate
+ doman dirvish.8 dirvish-runall.8 dirvish-expire.8 dirvish-locate.8 dirvish.conf.5
+ dohtml FAQ.html INSTALL RELEASE.html TODO.html
+ dodoc CHANGELOG COPYING
+
+ insinto /etc/dirvish; doins ${FILESDIR}/master.conf.example
+}