summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-03-13 21:20:04 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-03-13 21:20:04 +0000
commit335f4c39790405f827bb11971ede949fbdd58037 (patch)
tree02e2d6b5031d8933ed7b11862bfedf65b4f5f0f3 /app-admin/ec2-api-tools
parentadd ArxFatalis-EULA-JoWooD and ArxFatalis-EULA-GOG to EULA license group (diff)
downloadgentoo-2-335f4c39790405f827bb11971ede949fbdd58037.tar.gz
gentoo-2-335f4c39790405f827bb11971ede949fbdd58037.tar.bz2
gentoo-2-335f4c39790405f827bb11971ede949fbdd58037.zip
Non-maintainer commit, version bump to 1.6.0.1.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'app-admin/ec2-api-tools')
-rw-r--r--app-admin/ec2-api-tools/ChangeLog9
-rw-r--r--app-admin/ec2-api-tools/ec2-api-tools-1.6.0.1.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/app-admin/ec2-api-tools/ChangeLog b/app-admin/ec2-api-tools/ChangeLog
index 326e0cdd9c0d..fa363b70b78f 100644
--- a/app-admin/ec2-api-tools/ChangeLog
+++ b/app-admin/ec2-api-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/ec2-api-tools
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ec2-api-tools/ChangeLog,v 1.15 2012/07/29 12:59:43 lxnay Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ec2-api-tools/ChangeLog,v 1.16 2013/03/13 21:20:04 tomwij Exp $
+
+*ec2-api-tools-1.6.0.1 (13 Mar 2013)
+
+ 13 Mar 2013; Tom Wijsman <TomWij@gentoo.org> +ec2-api-tools-1.6.0.1.ebuild:
+ Non-maintainer commit, version bump to 1.6.0.1.
*ec2-api-tools-1.6.0.0 (29 Jul 2012)
diff --git a/app-admin/ec2-api-tools/ec2-api-tools-1.6.0.1.ebuild b/app-admin/ec2-api-tools/ec2-api-tools-1.6.0.1.ebuild
new file mode 100644
index 000000000000..b486ef84385f
--- /dev/null
+++ b/app-admin/ec2-api-tools/ec2-api-tools-1.6.0.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ec2-api-tools/ec2-api-tools-1.6.0.1.ebuild,v 1.1 2013/03/13 21:20:04 tomwij Exp $
+
+EAPI="5"
+
+inherit versionator
+
+DESCRIPTION="These command-line tools serve as the client interface to the Amazon EC2 web service"
+HOMEPAGE="http://developer.amazonwebservices.com/connect/entry.jspa?externalID=351&categoryID=88"
+SRC_URI="http://s3.amazonaws.com/ec2-downloads/${PN}-${PV}.zip"
+
+S=${WORKDIR}/${PN}-${PV}
+
+LICENSE="Amazon"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+DEPEND="app-arch/unzip"
+RDEPEND="virtual/jre"
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}" || die
+ find . -name '*.cmd' -delete || die
+}
+
+src_install() {
+ dodir /opt/${PN}
+ insinto /opt/${PN}/lib
+ doins -r "${S}"/lib/*
+ exeinto /opt/${PN}/bin
+ doexe "${S}"/bin/*
+
+ dodir /etc/env.d
+ cat - > "${T}"/99${PN} <<EOF
+EC2_HOME=/opt/${PN}
+PATH=/opt/${PN}/bin
+ROOTPATH=/opt/${PN}/bin
+EOF
+ doenvd "${T}"/99${PN}
+
+ dodoc THIRDPARTYLICENSE.TXT
+}
+
+pkg_postinst() {
+ ewarn "Remember to run: env-update && source /etc/profile if you plan"
+ ewarn "to use these tools in a shell before logging out (or restarting"
+ ewarn "your login manager)"
+ elog ""
+ elog ""
+ elog "You need to put the following in your ~/.bashrc replacing the"
+ elog "values with the full paths to your key and certificate."
+ elog ""
+ elog " export EC2_PRIVATE_KEY=/path/to/pk-HKZYKTAIG2ECMXYIBH3HXV4ZBZQ55CLO.pem"
+ elog " export EC2_CERT=/path/to/cert-HKZYKTAIG2ECMXYIBH3HXV4ZBZQ55CLO.pem"
+}