summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-02 17:28:57 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-02 17:28:57 +0000
commit36a54e1545973e36e8528b26e10868b759cb3738 (patch)
tree0543b1e3fe25a791f60ab964b65934d09277839a /app-admin/eselect-python
parentMaintainer inactive, hasn't touched the package since early 2008. Herd takes ... (diff)
downloadgentoo-2-36a54e1545973e36e8528b26e10868b759cb3738.tar.gz
gentoo-2-36a54e1545973e36e8528b26e10868b759cb3738.tar.bz2
gentoo-2-36a54e1545973e36e8528b26e10868b759cb3738.zip
Fix building with old versions of sys-libs/glibc.
(Portage version: 14176-svn/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/eselect-python')
-rw-r--r--app-admin/eselect-python/ChangeLog7
-rw-r--r--app-admin/eselect-python/eselect-python-20090824.ebuild5
-rw-r--r--app-admin/eselect-python/files/eselect-python-20090824-old-glibc.patch30
3 files changed, 39 insertions, 3 deletions
diff --git a/app-admin/eselect-python/ChangeLog b/app-admin/eselect-python/ChangeLog
index 7a0c82fc6f41..58ca94765e08 100644
--- a/app-admin/eselect-python/ChangeLog
+++ b/app-admin/eselect-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/eselect-python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/ChangeLog,v 1.40 2009/08/24 21:09:16 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/ChangeLog,v 1.41 2009/09/02 17:28:57 arfrever Exp $
+
+ 02 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ eselect-python-20090824.ebuild,
+ +files/eselect-python-20090824-old-glibc.patch:
+ Fix building with old versions of sys-libs/glibc.
*eselect-python-20090824 (24 Aug 2009)
diff --git a/app-admin/eselect-python/eselect-python-20090824.ebuild b/app-admin/eselect-python/eselect-python-20090824.ebuild
index 89136058121c..de54d2669ee0 100644
--- a/app-admin/eselect-python/eselect-python-20090824.ebuild
+++ b/app-admin/eselect-python/eselect-python-20090824.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/eselect-python-20090824.ebuild,v 1.1 2009/08/24 21:09:16 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/eselect-python-20090824.ebuild,v 1.2 2009/09/02 17:28:57 arfrever Exp $
EAPI="2"
-inherit flag-o-matic
+inherit eutils flag-o-matic
DESCRIPTION="Eselect module for management of multiple Python versions"
HOMEPAGE="http://www.gentoo.org"
@@ -23,6 +23,7 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}/${P}-old-glibc.patch"
./autogen.sh || die "autogen.sh failed"
}
diff --git a/app-admin/eselect-python/files/eselect-python-20090824-old-glibc.patch b/app-admin/eselect-python/files/eselect-python-20090824-old-glibc.patch
new file mode 100644
index 000000000000..522a75841dd1
--- /dev/null
+++ b/app-admin/eselect-python/files/eselect-python-20090824-old-glibc.patch
@@ -0,0 +1,30 @@
+--- configure.ac
++++ configure.ac
+@@ -7,8 +7,26 @@
+ AC_PATH_PROG(INSTALL, install)
+ MKDIR="${MKDIR:-${INSTALL} -d}"
+
++AC_USE_SYSTEM_EXTENSIONS
++
+ # strndup() was introduced in POSIX.1-2008.
+-AC_CHECK_FUNCS([strndup])
++AC_MSG_CHECKING([for strndup])
++old_CFLAGS="${CFLAGS}"
++CFLAGS="${CFLAGS} -Wall -Werror -Wextra"
++AC_LINK_IFELSE(
++[#include <string.h>
++int main()
++{
++ strndup("", 0);
++ return 0;
++}], [have_strndup="1"], [have_strndup="0"])
++if test "${have_strndup}" = "1"; then
++ AC_MSG_RESULT([yes])
++ AC_DEFINE([HAVE_STRNDUP], [1], [Define to 1 if you have the 'strndup' function.])
++else
++ AC_MSG_RESULT([no])
++fi
++CFLAGS="${old_CFLAGS}"
+
+ AC_SUBST([ASFLAGS])
+ AC_SUBST([MKDIR])