summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-01-19 08:52:48 +0000
committerMike Gilbert <floppym@gentoo.org>2014-01-19 08:52:48 +0000
commit6a76bb0ce7346b0d66d586b5ed80fd00c7e99c28 (patch)
treedba02b5615824dc43bfb43725911a788ba33c946 /app-admin/eselect-python
parentFix Changelog (diff)
downloadgentoo-2-6a76bb0ce7346b0d66d586b5ed80fd00c7e99c28.tar.gz
gentoo-2-6a76bb0ce7346b0d66d586b5ed80fd00c7e99c28.tar.bz2
gentoo-2-6a76bb0ce7346b0d66d586b5ed80fd00c7e99c28.zip
Tidy up RDEPEND. Don't call eselect python update when python is not installed, bug 380567.
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'app-admin/eselect-python')
-rw-r--r--app-admin/eselect-python/ChangeLog7
-rw-r--r--app-admin/eselect-python/eselect-python-20140115.ebuild22
-rw-r--r--app-admin/eselect-python/eselect-python-99999999.ebuild22
3 files changed, 26 insertions, 25 deletions
diff --git a/app-admin/eselect-python/ChangeLog b/app-admin/eselect-python/ChangeLog
index 497f14c5c81c..675b415432bf 100644
--- a/app-admin/eselect-python/ChangeLog
+++ b/app-admin/eselect-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/eselect-python
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/ChangeLog,v 1.81 2014/01/19 01:59:20 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/ChangeLog,v 1.82 2014/01/19 08:52:48 floppym Exp $
+
+ 19 Jan 2014; Mike Gilbert <floppym@gentoo.org> eselect-python-20140115.ebuild,
+ eselect-python-99999999.ebuild:
+ Tidy up RDEPEND. Don't call eselect python update when python is not
+ installed, bug 380567.
*eselect-python-20140115 (19 Jan 2014)
diff --git a/app-admin/eselect-python/eselect-python-20140115.ebuild b/app-admin/eselect-python/eselect-python-20140115.ebuild
index 786d7c38a1e8..ae1e3f1c23c2 100644
--- a/app-admin/eselect-python/eselect-python-20140115.ebuild
+++ b/app-admin/eselect-python/eselect-python-20140115.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/eselect-python-20140115.ebuild,v 1.1 2014/01/19 01:59:20 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/eselect-python-20140115.ebuild,v 1.2 2014/01/19 08:52:48 floppym Exp $
# Keep the EAPI low here because everything else depends on it.
# We want to make upgrading simpler.
@@ -22,12 +22,6 @@ SLOT="0"
IUSE=""
RDEPEND=">=app-admin/eselect-1.2.3"
-# Avoid autotool deps for released versions for circ dep issues.
-if [[ ${PV} == "99999999" ]] ; then
- DEPEND="sys-devel/autoconf"
-else
- DEPEND=""
-fi
src_unpack() {
if [[ ${PV} == "99999999" ]] ; then
@@ -45,9 +39,13 @@ src_install() {
}
pkg_postinst() {
- local ret=0
- ebegin "Running 'eselect python update'"
- eselect python update --python2 --if-unset || ret=1
- eselect python update --python3 --if-unset || ret=1
- eend ${ret}
+ if has_version 'dev-lang/python'; then
+ eselect python update --if-unset
+ fi
+ if has_version '=dev-lang/python2*'; then
+ eselect python update --python2 --if-unset
+ fi
+ if has_version '=dev-lang/python3*'; then
+ eselect python update --python3 --if-unset
+ fi
}
diff --git a/app-admin/eselect-python/eselect-python-99999999.ebuild b/app-admin/eselect-python/eselect-python-99999999.ebuild
index ee02f9701e2b..751208bb1a64 100644
--- a/app-admin/eselect-python/eselect-python-99999999.ebuild
+++ b/app-admin/eselect-python/eselect-python-99999999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/eselect-python-99999999.ebuild,v 1.11 2014/01/18 05:30:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/eselect-python-99999999.ebuild,v 1.12 2014/01/19 08:52:48 floppym Exp $
# Keep the EAPI low here because everything else depends on it.
# We want to make upgrading simpler.
@@ -22,12 +22,6 @@ SLOT="0"
IUSE=""
RDEPEND=">=app-admin/eselect-1.2.3"
-# Avoid autotool deps for released versions for circ dep issues.
-if [[ ${PV} == "99999999" ]] ; then
- DEPEND="sys-devel/autoconf"
-else
- DEPEND=""
-fi
src_unpack() {
if [[ ${PV} == "99999999" ]] ; then
@@ -45,9 +39,13 @@ src_install() {
}
pkg_postinst() {
- local ret=0
- ebegin "Running 'eselect python update'"
- eselect python update --python2 --if-unset || ret=1
- eselect python update --python3 --if-unset || ret=1
- eend ${ret}
+ if has_version 'dev-lang/python'; then
+ eselect python update --if-unset
+ fi
+ if has_version '=dev-lang/python2*'; then
+ eselect python update --python2 --if-unset
+ fi
+ if has_version '=dev-lang/python3*'; then
+ eselect python update --python3 --if-unset
+ fi
}