summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2008-12-02 20:11:13 +0000
committerChris PeBenito <pebenito@gentoo.org>2008-12-02 20:11:13 +0000
commit5c670ca1dc4d5334a344f8172cb52ae73ca1947a (patch)
tree67c1c60a0dd24f629c2b7f259244bb0452970ff4 /app-admin/setools/setools-3.3.5.ebuild
parentAdd ocfs/ocfs2 to PRUNEFS #249590 by Oleg Gawriloff. (diff)
downloadgentoo-2-5c670ca1dc4d5334a344f8172cb52ae73ca1947a.tar.gz
gentoo-2-5c670ca1dc4d5334a344f8172cb52ae73ca1947a.tar.bz2
gentoo-2-5c670ca1dc4d5334a344f8172cb52ae73ca1947a.zip
app-admin/setools: New upstream bugfix release for libsepol 2.x additional features.
(Portage version: 2.2_rc16/cvs/Linux 2.6.24-gentoo-r3 x86_64)
Diffstat (limited to 'app-admin/setools/setools-3.3.5.ebuild')
-rw-r--r--app-admin/setools/setools-3.3.5.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-admin/setools/setools-3.3.5.ebuild b/app-admin/setools/setools-3.3.5.ebuild
new file mode 100644
index 000000000000..d7c51842f2da
--- /dev/null
+++ b/app-admin/setools/setools-3.3.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/setools/setools-3.3.5.ebuild,v 1.1 2008/12/02 20:11:13 pebenito Exp $
+
+inherit java-pkg-opt-2
+
+DESCRIPTION="SELinux policy tools"
+HOMEPAGE="http://www.tresys.com/selinux/selinux_policy_tools.shtml"
+SRC_URI="http://oss.tresys.com/projects/setools/chrome/site/dists/${PN}-${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X debug java python"
+
+DEPEND=">=sys-libs/libsepol-1.16.3
+ sys-libs/libselinux
+ sys-devel/bison
+ sys-devel/flex
+ >=dev-db/sqlite-3.2
+ dev-libs/libxml2
+ dev-util/pkgconfig
+ java? (
+ >=dev-lang/swig-1.3.28
+ >=virtual/jdk-1.4
+ )
+ python? (
+ >=dev-lang/python-2.4
+ >=dev-lang/swig-1.3.28
+ )
+ X? (
+ >=dev-lang/tk-8.4.9
+ >=gnome-base/libglade-2.0
+ >=x11-libs/gtk+-2.8
+ )"
+
+RDEPEND=">=sys-libs/libsepol-1.16.3
+ sys-libs/libselinux
+ >=dev-db/sqlite-3.2
+ dev-libs/libxml2
+ java? ( >=virtual/jre-1.4 )
+ python? ( >=dev-lang/python-2.4 )
+ X? (
+ >=dev-lang/tk-8.4.9
+ >=dev-tcltk/bwidget-1.8
+ >=gnome-base/libglade-2.0
+ >=x11-libs/gtk+-2.8
+ )"
+
+src_compile() {
+ econf \
+ --with-java-prefix=${JAVA_HOME} \
+ --disable-selinux-check \
+ --disable-bwidget-check \
+ $(use_enable python swig-python) \
+ $(use_enable java swig-java) \
+ $(use_enable X swig-tcl) \
+ $(use_enable X gui) \
+ $(use_enable debug)
+
+ make || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed."
+}