summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2012-02-12 07:25:11 +0000
committerFabio Erculiani <lxnay@gentoo.org>2012-02-12 07:25:11 +0000
commit83afb546a68575aae89c82805aff709ab297c9cd (patch)
tree66618a5c5dd9243f0ef18167588c7661f4beb916 /app-admin/sulfur
parentversion bump (diff)
downloadgentoo-2-83afb546a68575aae89c82805aff709ab297c9cd.tar.gz
gentoo-2-83afb546a68575aae89c82805aff709ab297c9cd.tar.bz2
gentoo-2-83afb546a68575aae89c82805aff709ab297c9cd.zip
version bump
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/sulfur')
-rw-r--r--app-admin/sulfur/ChangeLog9
-rw-r--r--app-admin/sulfur/sulfur-1.0_rc87.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/app-admin/sulfur/ChangeLog b/app-admin/sulfur/ChangeLog
index c19728460970..1eb069cad8ea 100644
--- a/app-admin/sulfur/ChangeLog
+++ b/app-admin/sulfur/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/sulfur
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sulfur/ChangeLog,v 1.15 2011/12/22 17:52:04 lxnay Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sulfur/ChangeLog,v 1.16 2012/02/12 07:25:11 lxnay Exp $
+
+*sulfur-1.0_rc87 (12 Feb 2012)
+
+ 12 Feb 2012; Fabio Erculiani <lxnay@gentoo.org> +sulfur-1.0_rc87.ebuild:
+ version bump
*sulfur-1.0_rc80 (22 Dec 2011)
diff --git a/app-admin/sulfur/sulfur-1.0_rc87.ebuild b/app-admin/sulfur/sulfur-1.0_rc87.ebuild
new file mode 100644
index 000000000000..028539b817fe
--- /dev/null
+++ b/app-admin/sulfur/sulfur-1.0_rc87.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sulfur/sulfur-1.0_rc87.ebuild,v 1.1 2012/02/12 07:25:11 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils gnome2-utils fdo-mime python
+
+DESCRIPTION="Sulfur, the Entropy Package Manager Store"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+S="${WORKDIR}/entropy-${PV}/sulfur"
+
+RDEPEND="dev-python/pygtk:2
+ ~sys-apps/entropy-${PV}
+ sys-apps/file[python]
+ sys-devel/gettext
+ x11-libs/vte:0[python]
+ x11-misc/xdg-utils"
+DEPEND="sys-devel/gettext"
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" install || die "make install failed"
+ dodir /etc/gconf/schemas
+ insinto /etc/gconf/schemas
+ doins "${S}/misc/entropy-handler.schemas"
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+ gnome2_gconf_savelist
+ gnome2_gconf_install
+ python_mod_optimize "/usr/lib/entropy/${PN}"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/${PN}"
+ gnome2_gconf_savelist
+ gnome2_gconf_uninstall
+}