summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-07-14 23:53:53 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-07-14 23:53:53 +0000
commit31fd9c022e0a87a15a834fd5a52db9ef03617085 (patch)
tree22e09451e312ab49dd037b2d1be8e514c8d4feb8 /app-admin/system-config-lvm/system-config-lvm-1.1.1.ebuild
parentBump for compat with new pam. Stop using pam_timestamp. (diff)
downloadgentoo-2-31fd9c022e0a87a15a834fd5a52db9ef03617085.tar.gz
gentoo-2-31fd9c022e0a87a15a834fd5a52db9ef03617085.tar.bz2
gentoo-2-31fd9c022e0a87a15a834fd5a52db9ef03617085.zip
Bump for compat with new pam. Stop using pam_timestamp. Also whatever upstream bugfixes are included. Testing appreciated, because I don't have an LVM setup right now.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'app-admin/system-config-lvm/system-config-lvm-1.1.1.ebuild')
-rw-r--r--app-admin/system-config-lvm/system-config-lvm-1.1.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-admin/system-config-lvm/system-config-lvm-1.1.1.ebuild b/app-admin/system-config-lvm/system-config-lvm-1.1.1.ebuild
new file mode 100644
index 000000000000..704e94595bb4
--- /dev/null
+++ b/app-admin/system-config-lvm/system-config-lvm-1.1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-lvm/system-config-lvm-1.1.1.ebuild,v 1.1 2007/07/14 23:53:53 dberkholz Exp $
+
+inherit python eutils rpm
+
+# Tag for which Fedora Core version it's from
+FCVER="7"
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="1.0"
+
+DESCRIPTION="A utility for graphically configuring Logical Volumes"
+HOMEPAGE="http://fedora.redhat.com/projects/config-tools/"
+SRC_URI="mirror://fedora/development/source/SRPMS/${P}-${RPMREV}.fc${FCVER}.src.rpm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86 ~amd64"
+IUSE=""
+RDEPEND="=dev-python/gnome-python-2*
+ =dev-python/pygtk-2*
+ dev-python/rhpl
+ dev-lang/python
+ >=sys-fs/lvm2-2.00.20"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/intltool
+ dev-perl/XML-Parser"
+
+src_unpack() {
+ rpm_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ make_desktop_entry /usr/bin/${PN}
+
+ fperms 644 /etc/pam.d/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}