summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrea Barisani <lcars@gentoo.org>2007-03-14 13:37:59 +0000
committerAndrea Barisani <lcars@gentoo.org>2007-03-14 13:37:59 +0000
commite7999b4c8de9d8be3b9ee6fadf44548a9cbf95b2 (patch)
tree4da25f285da290f64bdbe75e1312caf10b831833 /app-admin/tenshi/tenshi-0.7.ebuild
parentStable on amd64, see bug #170791. (diff)
downloadgentoo-2-e7999b4c8de9d8be3b9ee6fadf44548a9cbf95b2.tar.gz
gentoo-2-e7999b4c8de9d8be3b9ee6fadf44548a9cbf95b2.tar.bz2
gentoo-2-e7999b4c8de9d8be3b9ee6fadf44548a9cbf95b2.zip
version bump
(Portage version: 2.1.2-r9)
Diffstat (limited to 'app-admin/tenshi/tenshi-0.7.ebuild')
-rw-r--r--app-admin/tenshi/tenshi-0.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-admin/tenshi/tenshi-0.7.ebuild b/app-admin/tenshi/tenshi-0.7.ebuild
new file mode 100644
index 000000000000..a327bb6eecdc
--- /dev/null
+++ b/app-admin/tenshi/tenshi-0.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tenshi/tenshi-0.7.ebuild,v 1.1 2007/03/14 13:37:59 lcars Exp $
+
+inherit eutils
+
+DESCRIPTION="Log parsing and notification program"
+HOMEPAGE="http://dev.inversepath.com/trac/tenshi"
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ http://dev.inversepath.com/tenshi/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ sys-apps/coreutils"
+
+pkg_setup() {
+ enewgroup tenshi
+ enewuser tenshi -1 -1 /var/lib/tenshi tenshi
+}
+
+src_install() {
+ emake DESTDIR=${D} install
+ fowners tenshi:root /etc/tenshi/tenshi.conf
+ fowners tenshi:root /var/lib/tenshi
+ doman tenshi.8
+ exeinto /etc/init.d
+ newexe tenshi.gentoo-init tenshi
+ keepdir /var/lib/tenshi
+}