summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-01-23 07:55:40 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-01-23 07:55:40 +0000
commitde692912c2020350d4d4f3a81c427d60c2d6633d (patch)
tree9979efbfc50f166e8a37a7c59f171bd254556dee /app-admin/tmpwatch
parentmask hal-device-manager (diff)
downloadgentoo-2-de692912c2020350d4d4f3a81c427d60c2d6633d.tar.gz
gentoo-2-de692912c2020350d4d4f3a81c427d60c2d6633d.tar.bz2
gentoo-2-de692912c2020350d4d4f3a81c427d60c2d6633d.zip
version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'app-admin/tmpwatch')
-rw-r--r--app-admin/tmpwatch/ChangeLog10
-rw-r--r--app-admin/tmpwatch/files/digest-tmpwatch-2.9.12.23
-rw-r--r--app-admin/tmpwatch/tmpwatch-2.9.12.2.ebuild39
3 files changed, 50 insertions, 2 deletions
diff --git a/app-admin/tmpwatch/ChangeLog b/app-admin/tmpwatch/ChangeLog
index 61efabbd033d..53e7a1d8659e 100644
--- a/app-admin/tmpwatch/ChangeLog
+++ b/app-admin/tmpwatch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/tmpwatch
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/tmpwatch/ChangeLog,v 1.61 2007/12/17 06:54:40 opfer Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tmpwatch/ChangeLog,v 1.62 2008/01/23 07:55:39 opfer Exp $
+
+*tmpwatch-2.9.12.2 (23 Jan 2008)
+
+ 23 Jan 2008; Christian Faulhammer <opfer@gentoo.org>
+ +tmpwatch-2.9.12.2.ebuild:
+ version bump
17 Dec 2007; Christian Faulhammer <opfer@gentoo.org>
-tmpwatch-2.9.2.2.ebuild, -tmpwatch-2.9.4.1.ebuild,
diff --git a/app-admin/tmpwatch/files/digest-tmpwatch-2.9.12.2 b/app-admin/tmpwatch/files/digest-tmpwatch-2.9.12.2
new file mode 100644
index 000000000000..4b0a3486f4c9
--- /dev/null
+++ b/app-admin/tmpwatch/files/digest-tmpwatch-2.9.12.2
@@ -0,0 +1,3 @@
+MD5 7abe3fa78e5074b668ec3375cd7a23c1 tmpwatch-2.9.12-2.src.rpm 25066
+RMD160 797399ae176b62a51116d6a4b82c61ec716588c8 tmpwatch-2.9.12-2.src.rpm 25066
+SHA256 29a89b11d74a9f57d5cebae3a26f0d2f96b08b3a7ffe1b33ef3311873aa6927c tmpwatch-2.9.12-2.src.rpm 25066
diff --git a/app-admin/tmpwatch/tmpwatch-2.9.12.2.ebuild b/app-admin/tmpwatch/tmpwatch-2.9.12.2.ebuild
new file mode 100644
index 000000000000..f47c07d7cc6d
--- /dev/null
+++ b/app-admin/tmpwatch/tmpwatch-2.9.12.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tmpwatch/tmpwatch-2.9.12.2.ebuild,v 1.1 2008/01/23 07:55:39 opfer Exp $
+
+inherit rpm versionator
+
+RPM_P="${PN}-$(replace_version_separator 3 '-')"
+MY_P="${RPM_P%-*}"
+
+DESCRIPTION="Utility recursively searches through specified directories and removes files which have not been accessed in a specified period of time"
+HOMEPAGE="http://download.fedora.redhat.com/pub/fedora/linux/development/source/SRPMS/"
+SRC_URI="http://download.fedora.redhat.com/pub/fedora/linux/development/source/SRPMS/${RPM_P}.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ rpm_src_unpack
+
+ cd "${S}"
+ sed -i -e "s:..RPM_OPT_FLAGS.:${CFLAGS}:" \
+ -e "s:^CVS:#CVS:g" Makefile \
+ || die "sed Makefile failed"
+ sed -i 's|/sbin/fuser|/bin/fuser|' tmpwatch.c \
+ || die "sed tmpwatch.c failed"
+ sed -i 's|/sbin|/bin|' tmpwatch.8 || die "sed tmpwatch.8 failed"
+}
+
+src_install() {
+ dosbin tmpwatch || die "dosbin failed"
+ doman tmpwatch.8 || die "doman failed"
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/${PN}.cron" "${PN}" || die 'failed to install cron'
+}