summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2010-05-23 04:33:07 +0000
committerSebastian Pipping <sping@gentoo.org>2010-05-23 04:33:07 +0000
commit165c3fe85561ed16f55bbe1573db98005d013c3b (patch)
tree659cbad6f46b4f029d7db970e8b3a1d53f3267bb /app-admin/webalizer
parentPatch for CVE-2010-1321 - bug #320445. Disable rpath - bug #187201. Installs ... (diff)
downloadgentoo-2-165c3fe85561ed16f55bbe1573db98005d013c3b.tar.gz
gentoo-2-165c3fe85561ed16f55bbe1573db98005d013c3b.tar.bz2
gentoo-2-165c3fe85561ed16f55bbe1573db98005d013c3b.zip
app-admin/webalizer: Integrate GCC 4.4 patch for bug #321053
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'app-admin/webalizer')
-rw-r--r--app-admin/webalizer/ChangeLog6
-rw-r--r--app-admin/webalizer/files/webalizer-2.21.02-gcc-4.4.patch11
-rw-r--r--app-admin/webalizer/webalizer-2.21.02.ebuild6
3 files changed, 21 insertions, 2 deletions
diff --git a/app-admin/webalizer/ChangeLog b/app-admin/webalizer/ChangeLog
index 503ae5ada3bd..7a7d52864dbe 100644
--- a/app-admin/webalizer/ChangeLog
+++ b/app-admin/webalizer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/webalizer
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webalizer/ChangeLog,v 1.77 2010/03/10 17:15:39 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webalizer/ChangeLog,v 1.78 2010/05/23 04:33:07 sping Exp $
+
+ 23 May 2010; Sebastian Pipping <sping@gentoo.org>
+ webalizer-2.21.02.ebuild, +files/webalizer-2.21.02-gcc-4.4.patch:
+ Integrate GCC 4.4 patch for bug #321053
*webalizer-2.21.02 (10 Mar 2010)
diff --git a/app-admin/webalizer/files/webalizer-2.21.02-gcc-4.4.patch b/app-admin/webalizer/files/webalizer-2.21.02-gcc-4.4.patch
new file mode 100644
index 000000000000..2f6549c46c4f
--- /dev/null
+++ b/app-admin/webalizer/files/webalizer-2.21.02-gcc-4.4.patch
@@ -0,0 +1,11 @@
+--- webalizer.c
++++ webalizer.c
+@@ -28,7 +28,7 @@
+ /* Fix broken Zlib 64 bitness */
+ #if _FILE_OFFSET_BITS == 64
+ #ifndef _LARGEFILE64_SOURCE
+-#define _LARGEFILE64_SOURCE = 1
++#define _LARGEFILE64_SOURCE 1
+ #endif
+ #endif
+
diff --git a/app-admin/webalizer/webalizer-2.21.02.ebuild b/app-admin/webalizer/webalizer-2.21.02.ebuild
index 560f8c1d79d3..4e0380397b27 100644
--- a/app-admin/webalizer/webalizer-2.21.02.ebuild
+++ b/app-admin/webalizer/webalizer-2.21.02.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webalizer/webalizer-2.21.02.ebuild,v 1.1 2010/03/10 17:15:39 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webalizer/webalizer-2.21.02.ebuild,v 1.2 2010/05/23 04:33:07 sping Exp $
# uses webapp.eclass to create directories with right permissions
# probably slight overkill but works well
@@ -44,6 +44,10 @@ pkg_setup() {
fi
}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc-4.4.patch
+}
+
src_configure() {
# really dirty hack; necessary due to a really gross ./configure
# basically, it just sets the natural language the program uses