summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2012-12-24 08:29:38 +0000
committerLance Albertson <ramereth@gentoo.org>2012-12-24 08:29:38 +0000
commit0f5e17d980c9c29b77e62bceec00ff8a8f118e21 (patch)
tree2e44bb33f6e5f3c9b11ab0eda3789ce33abafa2b /app-admin
parentVersion bump. (diff)
downloadgentoo-2-0f5e17d980c9c29b77e62bceec00ff8a8f118e21.tar.gz
gentoo-2-0f5e17d980c9c29b77e62bceec00ff8a8f118e21.tar.bz2
gentoo-2-0f5e17d980c9c29b77e62bceec00ff8a8f118e21.zip
Relicense init script to Apache-2.0 (#425868), version bump
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 27F4B742)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/mcollective/ChangeLog8
-rw-r--r--app-admin/mcollective/files/mcollectived.initd6
-rw-r--r--app-admin/mcollective/mcollective-2.2.0.ebuild60
3 files changed, 70 insertions, 4 deletions
diff --git a/app-admin/mcollective/ChangeLog b/app-admin/mcollective/ChangeLog
index 8692cdee83ab..e9be0ea7197a 100644
--- a/app-admin/mcollective/ChangeLog
+++ b/app-admin/mcollective/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/mcollective
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/ChangeLog,v 1.9 2012/08/12 16:33:08 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/ChangeLog,v 1.10 2012/12/24 08:29:38 ramereth Exp $
+
+*mcollective-2.2.0 (24 Dec 2012)
+
+ 24 Dec 2012; Lance Albertson <ramereth@gentoo.org> +mcollective-2.2.0.ebuild,
+ files/mcollectived.initd:
+ Relicense init script to Apache-2.0 (#425868), version bump
12 Aug 2012; Markus Meier <maekke@gentoo.org> mcollective-2.0.0.ebuild:
x86 stable, bug #421981
diff --git a/app-admin/mcollective/files/mcollectived.initd b/app-admin/mcollective/files/mcollectived.initd
index c2f8f85a4c41..5884c4242802 100644
--- a/app-admin/mcollective/files/mcollectived.initd
+++ b/app-admin/mcollective/files/mcollectived.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/files/mcollectived.initd,v 1.1 2011/03/01 02:18:33 ramereth Exp $
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the Apache License, Version 2.0
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/files/mcollectived.initd,v 1.2 2012/12/24 08:29:38 ramereth Exp $
mcollectived="/usr/sbin/mcollectived"
pidfile="/var/run/mcollectived"
diff --git a/app-admin/mcollective/mcollective-2.2.0.ebuild b/app-admin/mcollective/mcollective-2.2.0.ebuild
new file mode 100644
index 000000000000..ba8c573c7175
--- /dev/null
+++ b/app-admin/mcollective/mcollective-2.2.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/mcollective-2.2.0.ebuild,v 1.1 2012/12/24 08:29:38 ramereth Exp $
+
+EAPI="4"
+
+USE_RUBY="ruby18 ree18"
+
+inherit ruby-ng
+
+DESCRIPTION="Framework to build server orchestration or parallel job execution
+systems"
+HOMEPAGE="http://marionette-collective.org/"
+SRC_URI="http://puppetlabs.com/downloads/mcollective/${P}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +client"
+
+DEPEND=""
+RDEPEND="dev-ruby/stomp"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+each_ruby_install() {
+ doruby -r lib/*
+ insinto /usr/share/mcollective
+ doins -r plugins
+ use client && dosbin bin/mc-* bin/mco
+ dosbin bin/mcollectived
+ if use doc ; then
+ dohtml -r website/*
+ insinto /usr/share/doc/${P}/ext
+ doins -r ext/*
+ fi
+ newinitd "${FILESDIR}"/mcollectived.initd mcollectived
+ insinto /etc/mcollective
+ cd etc
+ for cfg in *.dist ; do
+ newins "${cfg}" "${cfg%%.dist}"
+ sed -i -e "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
+ "${D}"/etc/mcollective/${cfg%%.dist}
+ done
+ insinto /etc/mcollective/plugin.d
+}
+
+pkg_postinst() {
+ einfo "Mcollective requires a stomp server installed and functioning before"
+ einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
+ einfo "any other stomp compatible server should work."
+ einfo
+ einfo "It is recommended you read the \'getting started\' guide [2] if this"
+ einfo "is a new installation"
+ einfo
+ einfo "[1] http://activemq.apache.org/"
+ einfo "[2] http://code.google.com/p/mcollective/wiki/GettingStarted"
+}