summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDamon Conway <kabau@gentoo.org>2002-01-04 15:36:56 +0000
committerDamon Conway <kabau@gentoo.org>2002-01-04 15:36:56 +0000
commit48563c92d50a58b399fc4efccf4f899b5fa4b2fb (patch)
treeae59c4ce2338f7af2706295906a0d20246352bb9 /app-admin
parentFixed out of imagedir /etc/gpm creation. Wrong installation for docs and (diff)
downloadgentoo-2-48563c92d50a58b399fc4efccf4f899b5fa4b2fb.tar.gz
gentoo-2-48563c92d50a58b399fc4efccf4f899b5fa4b2fb.tar.bz2
gentoo-2-48563c92d50a58b399fc4efccf4f899b5fa4b2fb.zip
Initial commit of pwgen. It's a nice little password generator.
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/pwgen/files/digest-pwgen-2.011
-rw-r--r--app-admin/pwgen/pwgen-2.01.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/pwgen/files/digest-pwgen-2.01 b/app-admin/pwgen/files/digest-pwgen-2.01
new file mode 100644
index 000000000000..115275b1fb40
--- /dev/null
+++ b/app-admin/pwgen/files/digest-pwgen-2.01
@@ -0,0 +1 @@
+MD5 2ba03d613abb179bae186101eb346610 pwgen-2.01.tar.gz 20480
diff --git a/app-admin/pwgen/pwgen-2.01.ebuild b/app-admin/pwgen/pwgen-2.01.ebuild
new file mode 100644
index 000000000000..c91521eccfdf
--- /dev/null
+++ b/app-admin/pwgen/pwgen-2.01.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Damon Conway <kabau@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-admin/pwgen/pwgen-2.01.ebuild,v 1.1 2002/01/04 15:36:56 kabau Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Password Generator"
+SRC_URI="http://prdownloads.sourceforge.net/pwgen/${P}.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/pwgen/"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ # Fix the Makefile
+ cp Makefile.in Makefile.in.new
+ sed -e 's:$(prefix)/man/man1:$(mandir)/man1:g' Makefile.in.new > Makefile.in
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc/pwgen || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+}