summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-04-11 15:04:16 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-04-11 15:04:16 +0000
commit6e18c414680671de57f5b7603110ccaa2563f835 (patch)
tree553b5387e1494d9ccb4af66d138cff37a64d9248 /app-admin
parentVersion bumepd, bug #362013. Added proxied developer. (diff)
downloadgentoo-2-6e18c414680671de57f5b7603110ccaa2563f835.tar.gz
gentoo-2-6e18c414680671de57f5b7603110ccaa2563f835.tar.bz2
gentoo-2-6e18c414680671de57f5b7603110ccaa2563f835.zip
Version bumped. The ebuild was submitted by William Van Hevelingen, bug #362801. Added new USE flags.
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet/ChangeLog11
-rw-r--r--app-admin/puppet/metadata.xml1
-rw-r--r--app-admin/puppet/puppet-2.6.7.ebuild146
3 files changed, 156 insertions, 2 deletions
diff --git a/app-admin/puppet/ChangeLog b/app-admin/puppet/ChangeLog
index 99ae9241aab4..6aa271a28852 100644
--- a/app-admin/puppet/ChangeLog
+++ b/app-admin/puppet/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/puppet
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.73 2010/12/31 07:49:41 tove Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.74 2011/04/11 15:04:16 matsuu Exp $
+
+*puppet-2.6.7 (11 Apr 2011)
+
+ 11 Apr 2011; MATSUU Takuto <matsuu@gentoo.org> +puppet-2.6.7.ebuild,
+ metadata.xml:
+ Version bumped. The ebuild was submitted by William Van Hevelingen, bug
+ #362801. Added new USE flags.
*puppet-2.6.4 (31 Dec 2010)
diff --git a/app-admin/puppet/metadata.xml b/app-admin/puppet/metadata.xml
index f99ac52f50c8..15736a15726e 100644
--- a/app-admin/puppet/metadata.xml
+++ b/app-admin/puppet/metadata.xml
@@ -20,6 +20,7 @@
</longdescription>
<use>
<flag name='augeas'>Enable augeas support</flag>
+ <flag name='diff'>Enable diff support</flag>
<flag name='rrdtool'>Enable rrdtool support</flag>
<flag name='shadow'>Enable shadow support</flag>
</use>
diff --git a/app-admin/puppet/puppet-2.6.7.ebuild b/app-admin/puppet/puppet-2.6.7.ebuild
new file mode 100644
index 000000000000..6a97d1813fef
--- /dev/null
+++ b/app-admin/puppet/puppet-2.6.7.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-2.6.7.ebuild,v 1.1 2011/04/11 15:04:16 matsuu Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG* README*"
+
+inherit elisp-common eutils ruby-fakegem
+
+DESCRIPTION="A system automation and configuration management software"
+HOMEPAGE="http://puppetlabs.com/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite3 vim-syntax"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+
+ruby_add_rdepend "
+ >=dev-ruby/facter-1.5.1
+ augeas? ( dev-ruby/ruby-augeas )
+ diff? ( dev-ruby/diff-lcs )
+ doc? ( dev-ruby/rdoc )
+ ldap? ( dev-ruby/ruby-ldap )
+ shadow? ( dev-ruby/ruby-shadow )
+ sqlite3? ( dev-ruby/sqlite3-ruby )
+ virtual/ruby-ssl"
+# couchdb? ( dev-ruby/couchrest )
+# mongrel? ( www-servers/mongrel )
+# rack? ( >=dev-ruby/rack-1 )
+# rails? (
+# dev-ruby/rails
+# >=dev-ruby/activerecord-2.1
+# )
+# stomp? ( dev-ruby/stomp )
+
+DEPEND="${DEPEND}
+ emacs? ( virtual/emacs )"
+RDEPEND="${RDEPEND}
+ emacs? ( virtual/emacs )
+ rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
+ selinux? ( sys-libs/libselinux[ruby] )
+ >=app-portage/eix-0.18.0"
+
+SITEFILE="50${PN}-mode-gentoo.el"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/lib/puppet puppet
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use emacs ; then
+ elisp-compile ext/emacs/puppet-mode.el || die "elisp-compile failed"
+ fi
+}
+
+each_fakegem_install() {
+ ${RUBY} install.rb --destdir="${D}" install || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ newinitd "${FILESDIR}"/puppetmaster.init puppetmaster || die
+ doconfd conf/gentoo/conf.d/puppetmaster || die
+ newinitd "${FILESDIR}"/puppet.init puppet || die
+ doconfd conf/gentoo/conf.d/puppet || die
+
+ # Initial configuration files
+ keepdir /etc/puppet/manifests || die
+ keepdir /etc/puppet/modules || die
+ insinto /etc/puppet
+
+ # Bug #338439
+ #doins conf/gentoo/puppet/* || die
+ doins conf/redhat/*.conf || die
+ doins conf/auth.conf || die
+
+ # Location of log and data files
+ keepdir /var/run/puppet || die
+ keepdir /var/log/puppet || die
+ keepdir /var/lib/puppet/ssl || die
+ keepdir /var/lib/puppet/facts || die
+ keepdir /var/lib/puppet/files || die
+ fowners -R puppet:puppet /var/{run,log,lib}/puppet || die
+
+ if use emacs ; then
+ elisp-install ${PN} ext/emacs/puppet-mode.el* || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+
+ if use ldap ; then
+ insinto /etc/openldap/schema; doins ext/ldap/puppet.schema || die
+ fi
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/syntax; doins ext/vim/syntax/puppet.vim || die
+ insinto /usr/share/vim/vimfiles/ftdetect; doins ext/vim/ftdetect/puppet.vim || die
+ fi
+
+ # ext and examples files
+ for f in $(find ext examples -type f) ; do
+ docinto "$(dirname ${f})"; dodoc "${f}" || die
+ done
+ docinto conf; dodoc conf/namespaceauth.conf || die
+}
+
+pkg_postinst() {
+ elog
+ elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
+ elog "cause puppet to hang while installing packages."
+ elog
+ elog "Puppet uses eix to get information about currently installed packages,"
+ elog "so please keep the eix metadata cache updated so puppet is able to properly"
+ elog "handle package installations."
+ elog
+ elog "Currently puppet only supports adding and removing services to the default"
+ elog "runlevel, if you want to add/remove a service from another runlevel you may"
+ elog "do so using symlinking."
+ elog
+
+ if [ \
+ -f "${ROOT}/etc/puppet/puppetd.conf" -o \
+ -f "${ROOT}/etc/puppet/puppetmaster.conf" -o \
+ -f "${ROOT}/etc/puppet/puppetca.conf" \
+ ] ; then
+ elog
+ elog "Please remove deprecated config files."
+ elog " /etc/puppet/puppetca.conf"
+ elog " /etc/puppet/puppetd.conf"
+ elog " /etc/puppet/puppetmasterd.conf"
+ elog
+ fi
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}