summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-03-29 15:09:32 +0000
committerChuck Short <zul@gentoo.org>2004-03-29 15:09:32 +0000
commitc2916e3a087e2a433ec30024e2d4bd7f8723700b (patch)
tree8094f055e5f71a59ea9a324ba514d84039457548 /app-admin
parentClosing #44460. (Manifest recommit) (diff)
downloadgentoo-2-c2916e3a087e2a433ec30024e2d4bd7f8723700b.tar.gz
gentoo-2-c2916e3a087e2a433ec30024e2d4bd7f8723700b.tar.bz2
gentoo-2-c2916e3a087e2a433ec30024e2d4bd7f8723700b.zip
Version bump, closes #46031.
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/aide/ChangeLog9
-rw-r--r--app-admin/aide/Manifest8
-rw-r--r--app-admin/aide/aide-0.10.ebuild58
-rw-r--r--app-admin/aide/files/digest-aide-0.101
4 files changed, 71 insertions, 5 deletions
diff --git a/app-admin/aide/ChangeLog b/app-admin/aide/ChangeLog
index 268715804552..b7faaec66c89 100644
--- a/app-admin/aide/ChangeLog
+++ b/app-admin/aide/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/aide
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/aide/ChangeLog,v 1.16 2003/12/14 12:56:16 mholzer Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/aide/ChangeLog,v 1.17 2004/03/29 15:09:32 zul Exp $
+
+*aide-0.10 (29 Mar 2004)
+
+ 29 Mar 2004; Chuck Short <zul@gentoo.org> aide-0.10.ebuild:
+ Version bump, closes #46031.
14 Dec 2003; Martin Holzer <mholzer@gentoo.org> aide-0.9.ebuild:
more configure options with IUSE. closes #35700
diff --git a/app-admin/aide/Manifest b/app-admin/aide/Manifest
index 3519c256df75..b05ad18e4492 100644
--- a/app-admin/aide/Manifest
+++ b/app-admin/aide/Manifest
@@ -1,6 +1,8 @@
-MD5 40684490769fa25e9cd4b0bb729a61b9 ChangeLog 2239
-MD5 48443443f5603489f3cd4d92e3471e2b aide-0.8.ebuild 1118
MD5 177276db49f8107831eec220600010a5 aide-0.9.ebuild 1367
-MD5 f07734c5b540f7a251d3d8139ef0f75f files/aide-0.9-gentoo.diff 2319
+MD5 4b46b80f7cb4f99d2ec784e6f461dd04 aide-0.10.ebuild 1371
+MD5 48443443f5603489f3cd4d92e3471e2b aide-0.8.ebuild 1118
+MD5 40684490769fa25e9cd4b0bb729a61b9 ChangeLog 2239
MD5 0aaf7c0b95dbe77c4d731564a75306c2 files/digest-aide-0.8 60
MD5 b26d49d6bcafd39178a0da345cb2985d files/digest-aide-0.9 60
+MD5 f07734c5b540f7a251d3d8139ef0f75f files/aide-0.9-gentoo.diff 2319
+MD5 8c599ad3440b5d4a3244875ff0655225 files/digest-aide-0.10 61
diff --git a/app-admin/aide/aide-0.10.ebuild b/app-admin/aide/aide-0.10.ebuild
new file mode 100644
index 000000000000..7b73097dfbc8
--- /dev/null
+++ b/app-admin/aide/aide-0.10.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/aide/aide-0.10.ebuild,v 1.1 2004/03/29 15:09:32 zul Exp $
+
+inherit eutils
+
+DESCRIPTION="AIDE (Advanced Intrusion Detection Environment) is a replacement for Tripwire"
+HOMEPAGE="http://aide.sourceforge.net/"
+SRC_URI="mirror://sourceforge/aide/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE="nls postgres zlib crypt"
+
+DEPEND="app-arch/gzip
+ sys-devel/bison
+ sys-devel/flex
+ app-crypt/mhash
+ crypt? ( dev-libs/libgcrypt )
+ postgres? ( dev-db/postgresql )
+ zlib? ( sys-libs/zlib )"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ # passing --without-psql or --with-psql causes postgres to be enabled ...
+ # it's a broken configure.in file ... so lets just work around it
+ local myconf=""
+ use postgres && myconf="$myconf --with-psql"
+ use crypt && myconf="$myconf --with-gcrypt"
+
+ econf \
+ `use_with zlib` \
+ `use_with nls locale` \
+ --with-mhash \
+ --sysconfdir=/etc/aide \
+ --with-extra-lib=/usr/lib \
+ ${myconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ use nls || rm -rf ${D}/usr/lib/locale
+
+ insinto /etc/aide
+ doins doc/aide.conf
+
+ dodoc AUTHORS NEWS README
+ dohtml doc/manual.html
+}
diff --git a/app-admin/aide/files/digest-aide-0.10 b/app-admin/aide/files/digest-aide-0.10
new file mode 100644
index 000000000000..a875acd4cec5
--- /dev/null
+++ b/app-admin/aide/files/digest-aide-0.10
@@ -0,0 +1 @@
+MD5 39eb7d21064cac7b409c45d038b86cd8 aide-0.10.tar.gz 234184