summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-03-03 16:07:51 +0000
committerPacho Ramos <pacho@gentoo.org>2012-03-03 16:07:51 +0000
commitc7ba436ad1a716d0f6547b308ab06bd9fc49ebc5 (patch)
treeac441184dc485b92ae783e834754dc835da320b1 /app-admin
parentUse correct udev rules.d directory; /lib/udev/rules.d (diff)
downloadgentoo-2-c7ba436ad1a716d0f6547b308ab06bd9fc49ebc5.tar.gz
gentoo-2-c7ba436ad1a716d0f6547b308ab06bd9fc49ebc5.tar.bz2
gentoo-2-c7ba436ad1a716d0f6547b308ab06bd9fc49ebc5.zip
Fix dirhandle errors, bug #343913 by Jesús Guerrero and Ian Delaney.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/durep/ChangeLog10
-rw-r--r--app-admin/durep/durep-0.9-r3.ebuild31
-rw-r--r--app-admin/durep/files/durep-0.9-dirhandle.patch31
3 files changed, 70 insertions, 2 deletions
diff --git a/app-admin/durep/ChangeLog b/app-admin/durep/ChangeLog
index 78e05a1e3aca..a8bdeee9d1a3 100644
--- a/app-admin/durep/ChangeLog
+++ b/app-admin/durep/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/durep
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/durep/ChangeLog,v 1.8 2010/11/04 17:23:35 jer Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/durep/ChangeLog,v 1.9 2012/03/03 16:07:50 pacho Exp $
+
+*durep-0.9-r3 (03 Mar 2012)
+
+ 03 Mar 2012; Pacho Ramos <pacho@gentoo.org> +durep-0.9-r3.ebuild,
+ +files/durep-0.9-dirhandle.patch:
+ Fix dirhandle errors, bug #343913 by Jesús Guerrero and Ian Delaney.
04 Nov 2010; Jeroen Roovers <jer@gentoo.org> metadata.xml:
Add maintainer-needed@.
diff --git a/app-admin/durep/durep-0.9-r3.ebuild b/app-admin/durep/durep-0.9-r3.ebuild
new file mode 100644
index 000000000000..9e57553b19b9
--- /dev/null
+++ b/app-admin/durep/durep-0.9-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/durep/durep-0.9-r3.ebuild,v 1.1 2012/03/03 16:07:50 pacho Exp $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="A perl script designed for monitoring disk usage in a more visual way than du."
+HOMEPAGE="http://gentoo.org"
+SRC_URI="http://www.hibernaculum.net/download/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ dev-perl/MLDBM"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gigabyte.patch
+ epatch "${FILESDIR}"/${P}-color-output.patch
+ epatch "${FILESDIR}"/${P}-dirhandle.patch
+}
+
+src_install() {
+ dobin durep
+ doman durep.1
+ dodoc BUGS CHANGES README THANKS
+ dohtml -A cgi *.cgi *.css *.png
+}
diff --git a/app-admin/durep/files/durep-0.9-dirhandle.patch b/app-admin/durep/files/durep-0.9-dirhandle.patch
new file mode 100644
index 000000000000..ee2930622370
--- /dev/null
+++ b/app-admin/durep/files/durep-0.9-dirhandle.patch
@@ -0,0 +1,31 @@
+--- durep 2007-09-08 11:44:05.000000000 -0500
++++ durep.new 2008-12-15 10:04:14.907825184 -0600
+@@ -175,6 +175,7 @@
+ my $coalesced_size = 0;
+ my $node = {};
+ my $temp;
++ my $dirhandle;
+
+ $node->{ID} = $next_id++;
+ if(defined $parent) {
+@@ -196,9 +197,9 @@
+
+ $node->{TYPE} &= $TYPE_COLLAPSED unless $store;
+
+- opendir(DIR, $dir) or warn "Unable to open dir '$dir': $!\n" and return $node;
++ opendir($dirhandle, $dir) or warn "Unable to open dir '$dir': $!\n" and return $node;
+
+- foreach(readdir(DIR)) {
++ foreach(readdir($dirhandle)) {
+ @stats = lstat "$dir/$_" or warn "Unable to lstat '$dir/$_': $!\n" and next;
+
+ $node->{MTIME} = $stats[9] if($_ eq ".");
+@@ -247,7 +248,7 @@
+ $file_count++;
+ $node->{FCOUNT}++;
+ }
+- closedir(DIR);
++ closedir($dirhandle);
+
+ if($coalesced_count) {
+ if($store) {