summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2005-01-01 22:12:53 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2005-01-01 22:12:53 +0000
commit707ff6d8be86e160429076aa118ec5863738d226 (patch)
treec4b2dae8af7da45ee618be0b4c42cb0c38c383d5 /app-arch/arj
parentVersion bump. Bug #76164. (Manifest recommit) (diff)
downloadgentoo-2-707ff6d8be86e160429076aa118ec5863738d226.tar.gz
gentoo-2-707ff6d8be86e160429076aa118ec5863738d226.tar.bz2
gentoo-2-707ff6d8be86e160429076aa118ec5863738d226.zip
Closing #52311.
Diffstat (limited to 'app-arch/arj')
-rw-r--r--app-arch/arj/ChangeLog6
-rw-r--r--app-arch/arj/arj-3.10.21.ebuild33
2 files changed, 36 insertions, 3 deletions
diff --git a/app-arch/arj/ChangeLog b/app-arch/arj/ChangeLog
index 7d59f1bc01d3..49040ff7a04e 100644
--- a/app-arch/arj/ChangeLog
+++ b/app-arch/arj/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/arj
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/arj/ChangeLog,v 1.13 2005/01/01 11:41:07 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/arj/ChangeLog,v 1.14 2005/01/01 22:12:53 aliz Exp $
+
+ 01 Jan 2005; Daniel Ahlberg <aliz@gentoo.org> arj-3.10.21.ebuild:
+ Borrowed some gcc checking code from openoffice to automatically use gcc-3.3
+ when compiling arj, should close #52311.
15 Nov 2004; Gustavo Zacarias <gustavoz@gentoo.org> arj-3.10g.ebuild:
Stable on sparc
diff --git a/app-arch/arj/arj-3.10.21.ebuild b/app-arch/arj/arj-3.10.21.ebuild
index 4f0d2bda3d16..fca1d6b4f781 100644
--- a/app-arch/arj/arj-3.10.21.ebuild
+++ b/app-arch/arj/arj-3.10.21.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/arj/arj-3.10.21.ebuild,v 1.3 2005/01/01 11:41:07 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/arj/arj-3.10.21.ebuild,v 1.4 2005/01/01 22:12:53 aliz Exp $
-inherit gnuconfig eutils
+inherit gnuconfig eutils gcc
DESCRIPTION="Utility for opening arj archives"
HOMEPAGE="http://arj.sourceforge.net/"
@@ -17,6 +17,35 @@ RESTRICT="nostrip"
DEPEND="virtual/libc"
src_compile() {
+ if [ -x /usr/sbin/gcc-config ]
+ then
+ # Do we have a gcc that use the new layout and gcc-config ?
+ if /usr/sbin/gcc-config --get-current-profile &> /dev/null
+ then
+ export GCC_PROFILE="$(/usr/sbin/gcc-config --get-current-profile)"
+
+ # Just recheck gcc version ...
+ if [ "$(gcc-version)" != "3.2" ] && [ "$(gcc-version)" != "3.3" ]
+ then
+ # See if we can get a gcc profile we know is proper ...
+ if /usr/sbin/gcc-config --get-bin-path ${CHOST}-3.3.4 &> /dev/null
+ then
+ export PATH="$(/usr/sbin/gcc-config --get-bin-path ${CHOST}-3.3.4):${PATH}"
+ export GCC_PROFILE="${CHOST}-3.3.4"
+ else
+ eerror "This build needs gcc-3.2 or gcc-3.3!"
+ eerror
+ eerror "Use gcc-config to change your gcc profile:"
+ eerror
+ eerror " # gcc-config $CHOST-3.3.4"
+ eerror
+ eerror "or whatever gcc version is relevant."
+ die
+ fi
+ fi
+ fi
+ fi
+
gnuconfig_update
cd ${S}/gnu