summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-05-23 11:39:22 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-05-23 11:39:22 +0000
commit16bd327d29131002f0a7eea4e29e519449a9af13 (patch)
tree99c7941a046fffb6bedcf935028a5515d7e61045 /app-arch/bsdtar
parent Remove inappropriate patch. (diff)
downloadgentoo-2-16bd327d29131002f0a7eea4e29e519449a9af13.tar.gz
gentoo-2-16bd327d29131002f0a7eea4e29e519449a9af13.tar.bz2
gentoo-2-16bd327d29131002f0a7eea4e29e519449a9af13.zip
Remove bugged bsdtar versions.
(Portage version: 2.1.2.7)
Diffstat (limited to 'app-arch/bsdtar')
-rw-r--r--app-arch/bsdtar/ChangeLog6
-rw-r--r--app-arch/bsdtar/bsdtar-2.1.10.ebuild82
-rw-r--r--app-arch/bsdtar/bsdtar-2.1.9.ebuild82
-rw-r--r--app-arch/bsdtar/files/digest-bsdtar-2.1.103
-rw-r--r--app-arch/bsdtar/files/digest-bsdtar-2.1.93
5 files changed, 5 insertions, 171 deletions
diff --git a/app-arch/bsdtar/ChangeLog b/app-arch/bsdtar/ChangeLog
index 35df6d2bd590..48bca3076870 100644
--- a/app-arch/bsdtar/ChangeLog
+++ b/app-arch/bsdtar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/bsdtar
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/ChangeLog,v 1.66 2007/05/17 13:56:32 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/ChangeLog,v 1.67 2007/05/23 11:39:22 drizzt Exp $
+
+ 23 May 2007; Timothy Redaelli <drizzt@gentoo.org> -bsdtar-2.1.9.ebuild,
+ -bsdtar-2.1.10.ebuild:
+ Remove bugged bsdtar versions.
*bsdtar-2.2.2 (17 May 2007)
diff --git a/app-arch/bsdtar/bsdtar-2.1.10.ebuild b/app-arch/bsdtar/bsdtar-2.1.10.ebuild
deleted file mode 100644
index a96199064734..000000000000
--- a/app-arch/bsdtar/bsdtar-2.1.10.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/bsdtar-2.1.10.ebuild,v 1.1 2007/05/03 11:29:36 drizzt Exp $
-
-inherit eutils autotools toolchain-funcs flag-o-matic
-
-MY_P="libarchive-${PV/_beta/b}"
-
-DESCRIPTION="BSD tar command"
-HOMEPAGE="http://people.freebsd.org/~kientzle/libarchive/"
-SRC_URI="http://people.freebsd.org/~kientzle/libarchive/src/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="build static acl xattr"
-
-RDEPEND="!dev-libs/libarchive
- kernel_linux? (
- acl? ( sys-apps/acl )
- xattr? ( sys-apps/attr )
- )
- !static? ( !build? (
- app-arch/bzip2
- sys-libs/zlib ) )"
-DEPEND="${RDEPEND}
- kernel_linux? ( sys-fs/e2fsprogs
- virtual/os-headers )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/libarchive-2.1.9-static.patch
- epatch "${FILESDIR}"/libarchive-2.1.5-acl.patch
-
- eautoreconf
- epunt_cxx
-}
-
-src_compile() {
- local myconf
-
- if use static || use build ; then
- myconf="${myconf} --enable-static-bsdtar"
- else
- myconf="${myconf} --disable-static-bsdtar"
- fi
-
- # Upstream doesn't seem to care to fix the problems
- # and I don't want to continue running after them.
- append-flags -fno-strict-aliasing
-
- econf \
- --bindir=/bin \
- $(use_enable acl) \
- $(use_enable xattr) \
- ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
-
- # Create tar symlink for FreeBSD
- if [[ ${CHOST} == *-freebsd* ]]; then
- dosym bsdtar /bin/tar
- dosym bsdtar.1 /usr/share/man/man1/tar.1
- fi
-
- if use build; then
- rm -rf "${D}"/usr
- rm -rf "${D}"/lib/*.so*
- return 0
- fi
-
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
- gen_usr_ldscript libarchive.so
-}
diff --git a/app-arch/bsdtar/bsdtar-2.1.9.ebuild b/app-arch/bsdtar/bsdtar-2.1.9.ebuild
deleted file mode 100644
index d52b798ecdc4..000000000000
--- a/app-arch/bsdtar/bsdtar-2.1.9.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bsdtar/bsdtar-2.1.9.ebuild,v 1.1 2007/04/26 20:59:09 drizzt Exp $
-
-inherit eutils autotools toolchain-funcs flag-o-matic
-
-MY_P="libarchive-${PV/_beta/b}"
-
-DESCRIPTION="BSD tar command"
-HOMEPAGE="http://people.freebsd.org/~kientzle/libarchive/"
-SRC_URI="http://people.freebsd.org/~kientzle/libarchive/src/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="build static acl xattr"
-
-RDEPEND="!dev-libs/libarchive
- kernel_linux? (
- acl? ( sys-apps/acl )
- xattr? ( sys-apps/attr )
- )
- !static? ( !build? (
- app-arch/bzip2
- sys-libs/zlib ) )"
-DEPEND="${RDEPEND}
- kernel_linux? ( sys-fs/e2fsprogs
- virtual/os-headers )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/libarchive-2.1.9-static.patch
- epatch "${FILESDIR}"/libarchive-2.1.5-acl.patch
-
- eautoreconf
- epunt_cxx
-}
-
-src_compile() {
- local myconf
-
- if use static || use build ; then
- myconf="${myconf} --enable-static-bsdtar"
- else
- myconf="${myconf} --disable-static-bsdtar"
- fi
-
- # Upstream doesn't seem to care to fix the problems
- # and I don't want to continue running after them.
- append-flags -fno-strict-aliasing
-
- econf \
- --bindir=/bin \
- $(use_enable acl) \
- $(use_enable xattr) \
- ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
-
- # Create tar symlink for FreeBSD
- if [[ ${CHOST} == *-freebsd* ]]; then
- dosym bsdtar /bin/tar
- dosym bsdtar.1 /usr/share/man/man1/tar.1
- fi
-
- if use build; then
- rm -rf "${D}"/usr
- rm -rf "${D}"/lib/*.so*
- return 0
- fi
-
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
- gen_usr_ldscript libarchive.so
-}
diff --git a/app-arch/bsdtar/files/digest-bsdtar-2.1.10 b/app-arch/bsdtar/files/digest-bsdtar-2.1.10
deleted file mode 100644
index 480fccf49a39..000000000000
--- a/app-arch/bsdtar/files/digest-bsdtar-2.1.10
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 4c8d9ed796928b9442e1765834ea930c libarchive-2.1.10.tar.gz 613805
-RMD160 c75070ee3042a235ac19a1fef32816877c894d10 libarchive-2.1.10.tar.gz 613805
-SHA256 08a4f6b7defbb102b301be9fd3072692552333413c4fd92c0ca6f2c327953446 libarchive-2.1.10.tar.gz 613805
diff --git a/app-arch/bsdtar/files/digest-bsdtar-2.1.9 b/app-arch/bsdtar/files/digest-bsdtar-2.1.9
deleted file mode 100644
index 3345a5fe4cb7..000000000000
--- a/app-arch/bsdtar/files/digest-bsdtar-2.1.9
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 de9b2e9faed17dcfe2066e4b1dfbfdb3 libarchive-2.1.9.tar.gz 614004
-RMD160 63726482e805508df6c40d627e08f558a6d1e3ac libarchive-2.1.9.tar.gz 614004
-SHA256 0748bf8bc06d7ab20fb3046f9f057a0d00d26c00fda416b9f911de06238663ef libarchive-2.1.9.tar.gz 614004