summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-08-04 23:32:44 +0000
committerMax Kalika <max@gentoo.org>2003-08-04 23:32:44 +0000
commit1b2d88b2d8a2b9c1938c699312156e360840a903 (patch)
tree1af2ce0902b2676a260a4e6db8735bf570da9e94 /app-arch/flexbackup
parentadded metadata.xml (diff)
downloadgentoo-2-1b2d88b2d8a2b9c1938c699312156e360840a903.tar.gz
gentoo-2-1b2d88b2d8a2b9c1938c699312156e360840a903.tar.bz2
gentoo-2-1b2d88b2d8a2b9c1938c699312156e360840a903.zip
New flexbackup ebuild.
Diffstat (limited to 'app-arch/flexbackup')
-rw-r--r--app-arch/flexbackup/ChangeLog9
-rw-r--r--app-arch/flexbackup/Manifest4
-rw-r--r--app-arch/flexbackup/files/digest-flexbackup-1.2.0-r11
-rw-r--r--app-arch/flexbackup/flexbackup-1.2.0-r1.ebuild46
4 files changed, 58 insertions, 2 deletions
diff --git a/app-arch/flexbackup/ChangeLog b/app-arch/flexbackup/ChangeLog
index 87028385337e..f30a791eeb41 100644
--- a/app-arch/flexbackup/ChangeLog
+++ b/app-arch/flexbackup/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-arch/flexbackup
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/flexbackup/ChangeLog,v 1.7 2003/07/23 16:10:17 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/flexbackup/ChangeLog,v 1.8 2003/08/04 23:32:42 max Exp $
+
+*flexbackup-1.2.0-r1 (04 Aug 2003)
+
+ 04 Aug 2003; Max Kalika <max@gentoo.org> flexbackup-1.2.0-r1.ebuild:
+ Major cleanup. Drop depend on dump and afio. Drop Makefile patch -- installs
+ fine passing CONFFILE= and BINPATH= to einstall(). Drop unneeded src_unpack().
+ Other fixes.
24 Jul 2003; Martin Holzer <mholzer@gentoo.org> flexbackup-1.2.0.ebuild:
Marked as stable on x86
diff --git a/app-arch/flexbackup/Manifest b/app-arch/flexbackup/Manifest
index c4e8eda918f1..9dbc6a01778e 100644
--- a/app-arch/flexbackup/Manifest
+++ b/app-arch/flexbackup/Manifest
@@ -1,4 +1,6 @@
-MD5 1338cc8c9e015fa944ea8d0a5482eaea ChangeLog 1218
+MD5 38641b80bf932fb4a8e573d6a5ef8fb7 flexbackup-1.2.0-r1.ebuild 1151
MD5 7c3bed6e1dc0cff84656df175639a932 flexbackup-1.2.0.ebuild 1003
+MD5 94afee39bd65f917020631d3e636d6a7 ChangeLog 1497
+MD5 b0c86b38bbe5091e6f24dcb361170543 files/digest-flexbackup-1.2.0-r1 67
MD5 14858ea6950835f29fa80e2921940b3b files/Makefile-gentoo.diff 397
MD5 b0c86b38bbe5091e6f24dcb361170543 files/digest-flexbackup-1.2.0 67
diff --git a/app-arch/flexbackup/files/digest-flexbackup-1.2.0-r1 b/app-arch/flexbackup/files/digest-flexbackup-1.2.0-r1
new file mode 100644
index 000000000000..da5bb7944a12
--- /dev/null
+++ b/app-arch/flexbackup/files/digest-flexbackup-1.2.0-r1
@@ -0,0 +1 @@
+MD5 a5e57e7070ad3da1b5a9e0aed2aeda83 flexbackup-1.2.0.tar.gz 73170
diff --git a/app-arch/flexbackup/flexbackup-1.2.0-r1.ebuild b/app-arch/flexbackup/flexbackup-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..20d34a3cab82
--- /dev/null
+++ b/app-arch/flexbackup/flexbackup-1.2.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License
+# $Header: /var/cvsroot/gentoo-x86/app-arch/flexbackup/flexbackup-1.2.0-r1.ebuild,v 1.1 2003/08/04 23:32:42 max Exp $
+
+IUSE=""
+DESCRIPTION="Flexible backup script using perl."
+HOMEPAGE="http://flexbackup.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+RDEPEND="dev-lang/perl
+ sys-apps/findutils
+ sys-apps/tar
+ app-arch/mt-st"
+
+src_compile() {
+
+ emake BINPATH="/usr/bin" || die "compile problem"
+
+}
+
+src_install() {
+
+ dodir /etc /usr/bin
+ einstall CONFFILE="${D}/etc/flexbackup.conf" BINPATH="${D}/usr/bin"
+
+ dosed '/^$type = /s:afio:tar:' /etc/flexbackup.conf
+ dosed '/^$buffer = /s:buffer:false:' /etc/flexbackup.conf
+
+ dodoc CHANGES COPYING CREDITS INSTALL README TODO
+ dohtml faq.html
+
+}
+
+pkg_postinst() {
+
+ einfo "Please edit your /etc/flexbackup.conf file to suit your"
+ einfo "needs. If you are using devfs, the tape device should"
+ einfo "be set to /dev/tapes/tape0/mtn. If you need to use any"
+ einfo "archiver other than tar, please emerge it separately."
+ echo
+
+}