summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-04-02 09:49:55 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-04-02 09:49:55 +0000
commit27f365ccc8bc64e681290daa3eaf8932c7867906 (patch)
tree81b27b25dc45fbbbc71516835d942caa63dd10a2 /app-arch/gtk-splitter
parentDrop prime masking (diff)
downloadgentoo-2-27f365ccc8bc64e681290daa3eaf8932c7867906.tar.gz
gentoo-2-27f365ccc8bc64e681290daa3eaf8932c7867906.tar.bz2
gentoo-2-27f365ccc8bc64e681290daa3eaf8932c7867906.zip
[QA] Revision bump to 2.2.1-r1. EAPI 5 and other QA fixes.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'app-arch/gtk-splitter')
-rw-r--r--app-arch/gtk-splitter/ChangeLog11
-rw-r--r--app-arch/gtk-splitter/files/gtk-splitter-2.2.1-r1-desktop-QA-fixes.patch13
-rw-r--r--app-arch/gtk-splitter/gtk-splitter-2.2.1-r1.ebuild41
3 files changed, 63 insertions, 2 deletions
diff --git a/app-arch/gtk-splitter/ChangeLog b/app-arch/gtk-splitter/ChangeLog
index b3f3551756de..c5fd854b3b40 100644
--- a/app-arch/gtk-splitter/ChangeLog
+++ b/app-arch/gtk-splitter/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-arch/gtk-splitter
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gtk-splitter/ChangeLog,v 1.16 2012/05/03 01:58:54 jdhore Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gtk-splitter/ChangeLog,v 1.17 2014/04/02 09:49:55 tomwij Exp $
+
+*gtk-splitter-2.2.1-r1 (02 Apr 2014)
+
+ 02 Apr 2014; Tom Wijsman <TomWij@gentoo.org>
+ +files/gtk-splitter-2.2.1-r1-desktop-QA-fixes.patch,
+ +gtk-splitter-2.2.1-r1.ebuild:
+ [QA] Revision bump to 2.2.1-r1. EAPI 5 and other QA fixes.
03 May 2012; Jeff Horelick <jdhore@gentoo.org> gtk-splitter-2.2.1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/app-arch/gtk-splitter/files/gtk-splitter-2.2.1-r1-desktop-QA-fixes.patch b/app-arch/gtk-splitter/files/gtk-splitter-2.2.1-r1-desktop-QA-fixes.patch
new file mode 100644
index 000000000000..32fd447c9019
--- /dev/null
+++ b/app-arch/gtk-splitter/files/gtk-splitter-2.2.1-r1-desktop-QA-fixes.patch
@@ -0,0 +1,13 @@
+--- a/gtk-splitter.desktop
++++ b/gtk-splitter.desktop
+@@ -3,8 +3,8 @@
+ Name=File Splitter
+ Comment=GTK+ File Splitter
+ Exec=gtk-splitter %F
+-Icon=gtk-splitter.png
++Icon=/usr/share/pixmaps/gtk-splitter.png
+ Terminal=false
+ Type=Application
+-Categories=GNOME;Application;Utility;
++Categories=GNOME;Utility;
+ StartupNotify=true
diff --git a/app-arch/gtk-splitter/gtk-splitter-2.2.1-r1.ebuild b/app-arch/gtk-splitter/gtk-splitter-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..d2ff34dde38f
--- /dev/null
+++ b/app-arch/gtk-splitter/gtk-splitter-2.2.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gtk-splitter/gtk-splitter-2.2.1-r1.ebuild,v 1.1 2014/04/02 09:49:55 tomwij Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Split files into smaller pieces and combine them back together."
+HOMEPAGE="http://gtk-splitter.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt"
+
+RDEPEND="x11-libs/gtk+:2
+ virtual/libintl:0
+ crypt? ( >=app-crypt/mhash-0.8:0 )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig:*"
+
+src_prepare() {
+ epatch "${FILESDIR}/"${P}-r1-desktop-QA-fixes.patch
+}
+
+src_compile() {
+ default
+
+ if ! use crypt ; then
+ # configure script only autodetects
+ sed -i -e 's:-lmhash::' -e 's:-DHAVE_LIBMHASH=1::' src/Makefile || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install
+}