summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-02 13:42:32 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-02 13:42:32 +0000
commitb7a3baab86dc2c80f1d08721a514dabdbdf519c5 (patch)
tree2d68ef56eebafad534b4a75df40889366b091b7c /app-arch/gzip
parentAdd need-kde call to be sure that $KDEDIR is set. Removed dependency over kde... (diff)
downloadgentoo-2-b7a3baab86dc2c80f1d08721a514dabdbdf519c5.tar.gz
gentoo-2-b7a3baab86dc2c80f1d08721a514dabdbdf519c5.tar.bz2
gentoo-2-b7a3baab86dc2c80f1d08721a514dabdbdf519c5.zip
old
Diffstat (limited to 'app-arch/gzip')
-rw-r--r--app-arch/gzip/files/digest-gzip-1.3.5-r52
-rw-r--r--app-arch/gzip/files/digest-gzip-1.3.5-r61
-rw-r--r--app-arch/gzip/gzip-1.3.5-r5.ebuild80
-rw-r--r--app-arch/gzip/gzip-1.3.5-r6.ebuild85
4 files changed, 0 insertions, 168 deletions
diff --git a/app-arch/gzip/files/digest-gzip-1.3.5-r5 b/app-arch/gzip/files/digest-gzip-1.3.5-r5
deleted file mode 100644
index d3f3f0de377e..000000000000
--- a/app-arch/gzip/files/digest-gzip-1.3.5-r5
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 3d6c191dfd2bf307014b421c12dc8469 gzip-1.3.5.tar.gz 331550
-MD5 63d6cf343da210a3740aef2ed583f85d gzip-1.3.5-deb.patch.bz2 9136
diff --git a/app-arch/gzip/files/digest-gzip-1.3.5-r6 b/app-arch/gzip/files/digest-gzip-1.3.5-r6
deleted file mode 100644
index 07db7e681363..000000000000
--- a/app-arch/gzip/files/digest-gzip-1.3.5-r6
+++ /dev/null
@@ -1 +0,0 @@
-MD5 3d6c191dfd2bf307014b421c12dc8469 gzip-1.3.5.tar.gz 331550
diff --git a/app-arch/gzip/gzip-1.3.5-r5.ebuild b/app-arch/gzip/gzip-1.3.5-r5.ebuild
deleted file mode 100644
index 685fb50d8e3b..000000000000
--- a/app-arch/gzip/gzip-1.3.5-r5.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.3.5-r5.ebuild,v 1.3 2005/05/03 13:51:04 vapier Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Standard GNU compressor"
-HOMEPAGE="http://www.gnu.org/software/gzip/gzip.html"
-SRC_URI="mirror://gentoo/${P}.tar.gz
- mirror://gentoo/${P}-deb.patch.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls build static pic"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-PROVIDE="virtual/gzip"
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd ${S}
- epatch ${DISTDIR}/${P}-deb.patch.bz2
- epatch ${FILESDIR}/gzip-1.3.5-znew-tempfile-2.patch
-}
-
-src_compile() {
- use static && append-flags -static
- # avoid text relocation in gzip
- use pic && export DEFS="NO_ASM"
- econf --exec-prefix=/ $(use_enable nls) || die
- emake || die
-}
-
-src_install() {
- dodir /usr/bin /usr/share/man/man1
- make prefix=${D}/usr \
- exec_prefix=${D}/ \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die
-
- cd ${D}/bin
-
- for i in gzexe zforce zgrep zmore znew zcmp
- do
- sed -i -e "s:${D}::" ${i} || die
- chmod 755 ${i}
- done
-
- # No need to waste space -- these guys should be links
- # gzcat is equivilant to zcat, but historically zcat
- # was a link to compress.
- rm -f gunzip zcat zcmp zegrep zfgrep
- dosym gzip /bin/gunzip
- dosym gzip /bin/gzcat
- dosym gzip /bin/zcat
- dosym zdiff /bin/zcmp
- dosym zgrep /bin/zegrep
- dosym zgrep /bin/zfgrep
-
- if ! use build
- then
- cd ${D}/usr/share/man/man1
- rm -f gunzip.* zcmp.* zcat.*
- ln -s gzip.1.gz gunzip.1.gz
- ln -s zdiff.1.gz zcmp.1.gz
- ln -s gzip.1.gz zcat.1.gz
- ln -s gzip.1.gz gzcat.1.gz
- cd ${S}
- rm -rf ${D}/usr/man ${D}/usr/lib
- dodoc ChangeLog NEWS README THANKS TODO
- docinto txt
- dodoc algorithm.doc gzip.doc
- else
- rm -rf ${D}/usr
- fi
-}
diff --git a/app-arch/gzip/gzip-1.3.5-r6.ebuild b/app-arch/gzip/gzip-1.3.5-r6.ebuild
deleted file mode 100644
index 8a75b1aeb05d..000000000000
--- a/app-arch/gzip/gzip-1.3.5-r6.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.3.5-r6.ebuild,v 1.10 2005/05/06 17:34:55 spb Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Standard GNU compressor"
-HOMEPAGE="http://www.gnu.org/software/gzip/gzip.html"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls build static pic"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-PROVIDE="virtual/gzip"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-debian.patch
- epatch "${FILESDIR}"/${P}-znew-tempfile-2.patch
- epatch "${FILESDIR}"/${P}-gunzip-dir.patch
- epatch "${FILESDIR}"/${P}-asm-execstack.patch
- epatch "${FILESDIR}"/${P}-gzip-perm.patch
- epatch "${FILESDIR}"/${P}-infodir.patch
- epatch "${FILESDIR}"/${P}-rsync.patch
- epatch "${FILESDIR}"/${P}-zgrep-sed.patch
-}
-
-src_compile() {
- use static && append-flags -static
- # avoid text relocation in gzip
- use pic && export DEFS="NO_ASM"
- econf --exec-prefix=/ $(use_enable nls) || die
- emake || die
-}
-
-src_install() {
- dodir /usr/bin /usr/share/man/man1
- make prefix=${D}/usr \
- exec_prefix=${D}/ \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die
-
- cd ${D}/bin
-
- for i in gzexe zforce zgrep zmore znew zcmp
- do
- sed -i -e "s:${D}::" ${i} || die
- chmod 755 ${i}
- done
-
- # No need to waste space -- these guys should be links
- # gzcat is equivilant to zcat, but historically zcat
- # was a link to compress.
- rm -f gunzip zcat zcmp zegrep zfgrep
- dosym gzip /bin/gunzip
- dosym gzip /bin/gzcat
- dosym gzip /bin/zcat
- dosym zdiff /bin/zcmp
- dosym zgrep /bin/zegrep
- dosym zgrep /bin/zfgrep
-
- if ! use build
- then
- cd ${D}/usr/share/man/man1
- rm -f gunzip.* zcmp.* zcat.*
- ln -s gzip.1.gz gunzip.1.gz
- ln -s zdiff.1.gz zcmp.1.gz
- ln -s gzip.1.gz zcat.1.gz
- ln -s gzip.1.gz gzcat.1.gz
- cd ${S}
- rm -rf ${D}/usr/man ${D}/usr/lib
- dodoc ChangeLog NEWS README THANKS TODO
- docinto txt
- dodoc algorithm.doc gzip.doc
- else
- rm -rf ${D}/usr
- fi
-}