summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-08-06 06:39:25 +0000
committerJustin Lecher <jlec@gentoo.org>2012-08-06 06:39:25 +0000
commit7accf2075ce77a591468bc4f9f53b117c7907c31 (patch)
treea9c31a624dd1051414ae979abca16bc1b3c50b67 /app-arch/lbzip2
parentFix quoting of the compiler name. Missing SLOT dependency of openssl for head... (diff)
downloadgentoo-2-7accf2075ce77a591468bc4f9f53b117c7907c31.tar.gz
gentoo-2-7accf2075ce77a591468bc4f9f53b117c7907c31.tar.bz2
gentoo-2-7accf2075ce77a591468bc4f9f53b117c7907c31.zip
app-arch/lbzip2: Version Bump
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/lbzip2')
-rw-r--r--app-arch/lbzip2/ChangeLog8
-rw-r--r--app-arch/lbzip2/files/lbzip2-2.2-s_isreg.patch16
-rw-r--r--app-arch/lbzip2/lbzip2-2.2.ebuild32
3 files changed, 55 insertions, 1 deletions
diff --git a/app-arch/lbzip2/ChangeLog b/app-arch/lbzip2/ChangeLog
index 4fac47eb2341..5cec41ec5710 100644
--- a/app-arch/lbzip2/ChangeLog
+++ b/app-arch/lbzip2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/lbzip2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/ChangeLog,v 1.31 2012/02/14 21:25:31 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/ChangeLog,v 1.32 2012/08/06 06:39:25 jlec Exp $
+
+*lbzip2-2.2 (06 Aug 2012)
+
+ 06 Aug 2012; Justin Lecher <jlec@gentoo.org> +lbzip2-2.2.ebuild,
+ +files/lbzip2-2.2-s_isreg.patch:
+ Version Bump
14 Feb 2012; Jeroen Roovers <jer@gentoo.org> lbzip2-0.23-r2.ebuild:
Stable for HPPA (bug #370685).
diff --git a/app-arch/lbzip2/files/lbzip2-2.2-s_isreg.patch b/app-arch/lbzip2/files/lbzip2-2.2-s_isreg.patch
new file mode 100644
index 000000000000..c67b134b5795
--- /dev/null
+++ b/app-arch/lbzip2/files/lbzip2-2.2-s_isreg.patch
@@ -0,0 +1,16 @@
+ src/main.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/main.c b/src/main.c
+index f030fd5..5f8290e 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -702,7 +702,7 @@ input_init(const struct arg *operand, struct stat *sbuf)
+ return -1;
+ }
+
+- if (!S_ISREG(sbuf->st_mode)) {
++ if (!decompress && !S_ISREG(sbuf->st_mode)) {
+ warn("skipping \"%s\": not a regular file", operand->val);
+ return -1;
+ }
diff --git a/app-arch/lbzip2/lbzip2-2.2.ebuild b/app-arch/lbzip2/lbzip2-2.2.ebuild
new file mode 100644
index 000000000000..f9f20beb8238
--- /dev/null
+++ b/app-arch/lbzip2/lbzip2-2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/lbzip2-2.2.ebuild,v 1.1 2012/08/06 06:39:25 jlec Exp $
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="Parallel bzip2 utility"
+HOMEPAGE="https://github.com/kjn/lbzip2/"
+SRC_URI="mirror://github/kjn/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug symlink"
+
+PATCHES=( "${FILESDIR}"/${P}-s_isreg.patch )
+
+src_configure() {
+ local myeconfargs=(
+ --disable-silent-rules
+ $(use_enable debug tracing)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ use symlink && dosym ${PN} /usr/bin/bzip2
+}