summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2005-10-30 20:14:52 +0000
committerFabian Groffen <grobian@gentoo.org>2005-10-30 20:14:52 +0000
commitcd5c70b23032113bbadb3552c5dd5f8315b41ab5 (patch)
tree644ac327bd493c6026cfdd285f149e086a457267 /app-arch/lha/files
parentMarked Stable on amd64. See bug #109889. (diff)
downloadgentoo-2-cd5c70b23032113bbadb3552c5dd5f8315b41ab5.tar.gz
gentoo-2-cd5c70b23032113bbadb3552c5dd5f8315b41ab5.tar.bz2
gentoo-2-cd5c70b23032113bbadb3552c5dd5f8315b41ab5.zip
Fixed compilation and install issues on OSX. There is no malloc.h and /usr/bin/install doesn't understand -D.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'app-arch/lha/files')
-rw-r--r--app-arch/lha/files/lha-114i-build.patch10
-rw-r--r--app-arch/lha/files/lha-114i-malloc.patch4
2 files changed, 9 insertions, 5 deletions
diff --git a/app-arch/lha/files/lha-114i-build.patch b/app-arch/lha/files/lha-114i-build.patch
index 23d241ff73ed..29895b329fe3 100644
--- a/app-arch/lha/files/lha-114i-build.patch
+++ b/app-arch/lha/files/lha-114i-build.patch
@@ -31,20 +31,22 @@
'OPTIMIZE=$(OPTIMIZE)' 'MACHINE=$(MACHINE)'
--- man/Makefile
+++ man/Makefile
-@@ -11,7 +11,7 @@
+@@ -11,7 +11,8 @@
$(NROFF) -man lha.n > lha.man
install:
- $(INSTALL) $(INSTALLMAN) lha.n $(MANDIR)/man$(MANSECT)/lha.$(MANSECT)
-+ $(INSTALL) -D $(INSTALLMAN) lha.n $(DESTDIR)$(MANDIR)/man$(MANSECT)/lha.$(MANSECT)
++ mkdir -p `dirname $(DESTDIR)$(MANDIR)/man$(MANSECT)/lha.$(MANSECT)`
++ $(INSTALL) $(INSTALLMAN) lha.n $(DESTDIR)$(MANDIR)/man$(MANSECT)/lha.$(MANSECT)
clean:
rm -f *~
--- src/Makefile
+++ src/Makefile
-@@ -49,4 +49,4 @@
+@@ -49,4 +49,5 @@
rm -f core *.o lha.tar lha.tar.Z *~ \#* *.orig
install:
++ mkdir -p `dirname $(DESTDIR)$(BINDIR)/lha`
++ $(INSTALL) $(INSTALLBIN) lha $(DESTDIR)$(BINDIR)/lha
- $(INSTALL) $(INSTALLBIN) lha $(BINDIR)/lha
-+ $(INSTALL) -D $(INSTALLBIN) lha $(DESTDIR)$(BINDIR)/lha
diff --git a/app-arch/lha/files/lha-114i-malloc.patch b/app-arch/lha/files/lha-114i-malloc.patch
index 9f4499aecaff..8c9d968a9d58 100644
--- a/app-arch/lha/files/lha-114i-malloc.patch
+++ b/app-arch/lha/files/lha-114i-malloc.patch
@@ -1,10 +1,12 @@
--- lha-114i/src/lha.h
+++ lha-114i/src/lha.h
-@@ -16,6 +16,7 @@
+@@ -16,6 +16,9 @@
#include <sys/types.h>
#include <sys/file.h>
#include <sys/stat.h>
++#ifndef __APPLE__
+#include <malloc.h>
++#endif
#include <signal.h>