summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-10-21 13:44:11 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-10-21 13:44:11 +0000
commit13f1cf30473448d989401703db1e9fbfc4733a69 (patch)
tree97d775854bb2e1f8ab93a963974e643aaeef8af6 /app-arch/lziprecover
parentMarked ~x64-macos, bug #486818 (diff)
downloadgentoo-2-13f1cf30473448d989401703db1e9fbfc4733a69.tar.gz
gentoo-2-13f1cf30473448d989401703db1e9fbfc4733a69.tar.bz2
gentoo-2-13f1cf30473448d989401703db1e9fbfc4733a69.zip
Initial commit
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'app-arch/lziprecover')
-rw-r--r--app-arch/lziprecover/ChangeLog10
-rw-r--r--app-arch/lziprecover/Manifest4
-rw-r--r--app-arch/lziprecover/lziprecover-1.15.ebuild25
-rw-r--r--app-arch/lziprecover/metadata.xml47
4 files changed, 86 insertions, 0 deletions
diff --git a/app-arch/lziprecover/ChangeLog b/app-arch/lziprecover/ChangeLog
new file mode 100644
index 000000000000..95e02df8c24f
--- /dev/null
+++ b/app-arch/lziprecover/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-arch/lziprecover
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lziprecover/ChangeLog,v 1.1 2013/10/21 13:44:11 polynomial-c Exp $
+
+*lziprecover-1.15 (21 Oct 2013)
+
+ 21 Oct 2013; Lars Wendler <polynomial-c@gentoo.org> +lziprecover-1.15.ebuild,
+ +metadata.xml:
+ Initial commit.
+
diff --git a/app-arch/lziprecover/Manifest b/app-arch/lziprecover/Manifest
new file mode 100644
index 000000000000..5db6284a4826
--- /dev/null
+++ b/app-arch/lziprecover/Manifest
@@ -0,0 +1,4 @@
+DIST lziprecover-1.15.tar.gz 82763 SHA256 2adf0dfc77a0b2f93257d9f3f1171fc11121b43da55fa53715459b7fa93f1661 SHA512 407d836ca76de3ef393979cefb23fa86dc9a6af50f0733eb2f31e0b4404582b03e0e5429c537d8aed69e2ae12855e282afc0926cd9064b0cb5ce4fac702c7552 WHIRLPOOL b552cc9320b46630a14fb5010593acaf852449ca4c99685959340618877da59d9f662d441a36e5cd04358b598a1d21b1c8c81f2eff029a96bd469b04a62ed4ac
+EBUILD lziprecover-1.15.ebuild 655 SHA256 4c5aba761bd829706c9020ab157247bd8906ccd37639a462b5dad004e1cbf341 SHA512 8dc2b3af655edd2f519102b40b63e1133ec600cb9a2ed65a565087df719f87a362e099e77d142b5137248ef7d6332f5d374f468fbab1fd1f784e2c312ca97639 WHIRLPOOL dbd808ce0d212f2ee22fe8256eca07a46b19ed372fbad95086248012f923e354fd0a10f729d2b2ba2053728761296d6a12bc235d38cf5cf6efb6f95db82d4c66
+MISC ChangeLog 270 SHA256 b34f93013ce2c6af76d1fa42f9cc1e861e3c20daa2dade054728870a50640e20 SHA512 b59c3e0c6802fc835b46fb0f0635885cd7fc66fcb97d3e90a497e67b5d3b0c9b4cee567d222e8157d6e29bc4c4be7bd19e365bfa8153fc4297a704f552cac59c WHIRLPOOL 4558a2f4b0c2977e0dd60fea411109c0eafd0b1520e9ded924082c6ce6aec172773e979400aa862b71ba7cfcb8c8f0220222ee644376788ed64ce7aeb4b66ff7
+MISC metadata.xml 2585 SHA256 140dad171dfd3b87ee3f3195909ca6971bac6641e6ebc48c62793660bbbc1219 SHA512 06eb1a67a9e60917f90a389e0fda67bbac00dd97713a4cb0bb1cf8c675229e586eaad88e835749005b101742e1792b608eeb01cb049895a92c27e22c005d2643 WHIRLPOOL e41718a7bec05da7e6fbecb7d6fc218eaa684bbea243ae78e0aa07c76ecce181c374133813fc89a026ea38db15cf5038c54d83535c22386b9994269bcc1b99b4
diff --git a/app-arch/lziprecover/lziprecover-1.15.ebuild b/app-arch/lziprecover/lziprecover-1.15.ebuild
new file mode 100644
index 000000000000..4d1b76110e03
--- /dev/null
+++ b/app-arch/lziprecover/lziprecover-1.15.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lziprecover/lziprecover-1.15.ebuild,v 1.1 2013/10/21 13:44:11 polynomial-c Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lziprecover is a data recovery tool and decompressor for files in the lzip compressed data format."
+HOMEPAGE="http://www.nongnu.org/lzip/lziprecover.html"
+SRC_URI="http://download.savannah.gnu.org/releases-noredirect/lzip/${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_configure() {
+ # not autotools-based
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || die
+}
diff --git a/app-arch/lziprecover/metadata.xml b/app-arch/lziprecover/metadata.xml
new file mode 100644
index 000000000000..eb4dc77430b4
--- /dev/null
+++ b/app-arch/lziprecover/metadata.xml
@@ -0,0 +1,47 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <longdescription lang="en">
+ Lziprecover is a data recovery tool and decompressor for files in the lzip
+ compressed data format (.lz), able to repair slightly damaged files,
+ recover badly damaged files from two or more copies, extract data from
+ damaged files, decompress files and test integrity of files.
+ The lzip file format is designed for long-term data archiving. It is clean,
+ provides very safe 4 factor integrity checking, and is backed by the
+ recovery capabilities of lziprecover.
+ Lziprecover is able to recover or decompress files produced by any of the
+ compressors in the lzip family; lzip, plzip, minilzip/lzlib, clzip and
+ pdlzip.
+ Lziprecover makes lzip files resistant to bit-flip (one of the most common
+ forms of data corruption), and can safely merge multiple damaged backup
+ copies.
+ If the cause of file corruption is damaged media, the combination GNU
+ ddrescue + lziprecover is the best option for recovering data from multiple
+ damaged copies.
+ If a file is too damaged for lziprecover to repair it, all the recoverable
+ data in all members of the file can be extracted with the '-D' option.
+ Lziprecover is able to efficiently extract a range of bytes from a
+ multi-member file, because it only decompresses the members containing the
+ desired data.
+ Lziprecover can print correct total file sizes and ratios even for
+ multi-member files.
+ When recovering data, lziprecover takes as arguments the names of the
+ damaged files and writes zero or more recovered files depending on the
+ operation selected and whether the recovery succeeded or not. The damaged
+ files themselves are never modified.
+ When decompressing or testing file integrity, lziprecover behaves like lzip
+ or lunzip.
+ To give you an idea of its possibilities, when merging two copies, each of
+ them with one damaged area affecting 1 percent of the copy, the probability
+ of obtaining a correct file is about 98 percent. With three such copies the
+ probability rises to 99.97 percent. For large files (a few MB) with small
+ errors (one sector damaged per copy), the probability approaches 100 percent
+ even with only two copies.
+ Lziprecover is not a replacement for regular backups, but a last line of
+ defense for the case where the backups are also damaged.
+ </longdescription>
+</pkgmetadata>