summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-07-20 22:50:15 +0000
committerHanno Böck <hanno@gentoo.org>2008-07-20 22:50:15 +0000
commitb5e6028a4255ae1e2a064f8aa3afc0fcafc93e29 (patch)
tree0e09baf13a95193de548a6a2fca5e6f7fdf73c0d /app-arch/p7zip
parentfix bug 231288 (diff)
downloadgentoo-2-b5e6028a4255ae1e2a064f8aa3afc0fcafc93e29.tar.gz
gentoo-2-b5e6028a4255ae1e2a064f8aa3afc0fcafc93e29.tar.bz2
gentoo-2-b5e6028a4255ae1e2a064f8aa3afc0fcafc93e29.zip
p7zip bump
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-git6 i686)
Diffstat (limited to 'app-arch/p7zip')
-rw-r--r--app-arch/p7zip/ChangeLog7
-rw-r--r--app-arch/p7zip/p7zip-4.58.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/app-arch/p7zip/ChangeLog b/app-arch/p7zip/ChangeLog
index 3f63fb96a6ca..37b4a749532f 100644
--- a/app-arch/p7zip/ChangeLog
+++ b/app-arch/p7zip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/p7zip
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/ChangeLog,v 1.95 2008/03/21 11:23:03 radek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/ChangeLog,v 1.96 2008/07/20 22:50:15 hanno Exp $
+
+*p7zip-4.58 (20 Jul 2008)
+
+ 20 Jul 2008; Hanno Boeck <hanno@gentoo.org> +p7zip-4.58.ebuild:
+ Version bump.
21 Mar 2008; Radoslaw Stachowiak <radek@gentoo.org>
-files/p7zip-4.55-open_lzma_alone.patch, -p7zip-4.55-r1.ebuild:
diff --git a/app-arch/p7zip/p7zip-4.58.ebuild b/app-arch/p7zip/p7zip-4.58.ebuild
new file mode 100644
index 000000000000..bd80162a1a3d
--- /dev/null
+++ b/app-arch/p7zip/p7zip-4.58.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/p7zip-4.58.ebuild,v 1.1 2008/07/20 22:50:15 hanno Exp $
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="Port of 7-Zip archiver for Unix"
+HOMEPAGE="http://p7zip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}_src_all.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="static doc"
+
+DEPEND=""
+
+S=${WORKDIR}/${PN}_${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^CXX=/s:g++:$(tc-getCXX):" \
+ -e "/^CC=/s:gcc:$(tc-getCC):" \
+ -e "s:OPTFLAGS=-O:OPTFLAGS=${CXXFLAGS}:" \
+ -e 's:-s ::' \
+ -e '/Rar/d' \
+ makefile* || die "changing makefiles"
+
+ if use amd64; then
+ ewarn "Using suboptimal -fPIC upstream makefile due to amd64 being detected. See #126722"
+ cp -f makefile.linux_amd64 makefile.machine
+ elif [[ ${CHOST} == *-darwin* ]] ; then
+ # Mac OS X needs this special makefile, because it has a non-GNU linker
+ cp -f makefile.macosx makefile.machine
+ elif use x86-fbsd; then
+ # FreeBSD needs this special makefile, because it hasn't -ldl
+ sed -e 's/-lc_r/-pthread/' makefile.freebsd > makefile.machine
+ fi
+ use static && sed -i -e '/^LOCAL_LIBS=/s/LOCAL_LIBS=/&-static /' makefile.machine
+
+ # patching to not included nonfree RAR decompression code is higher a sed call
+ # But we're removing nonfree code just in case sed wasnt enough
+ rm -rf CPP/7zip/Compress/Rar
+}
+
+src_compile() {
+ emake all3 || die "compilation error"
+}
+
+src_install() {
+ # this wrappers can not be symlinks, p7zip should be called with full path
+ make_wrapper 7zr "/usr/lib/${PN}/7zr"
+ make_wrapper 7za "/usr/lib/${PN}/7za"
+ make_wrapper 7z "/usr/lib/${PN}/7z"
+
+ dobin "${FILESDIR}/p7zip" || die
+
+ # gzip introduced in 4.42, so beware :)
+ # mv needed just as rename, because dobin installs using old name
+ mv contrib/gzip-like_CLI_wrapper_for_7z/p7zip contrib/gzip-like_CLI_wrapper_for_7z/7zg || die
+ dobin contrib/gzip-like_CLI_wrapper_for_7z/7zg || die
+
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe bin/7z bin/7za bin/7zr bin/7zCon.sfx || die "doexe bins"
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe bin/*.so || die "doexe *.so files"
+
+ doman man1/7z.1 man1/7za.1 man1/7zr.1
+ dodoc ChangeLog README TODO
+
+ if use doc ; then
+ dodoc DOCS/*.txt
+ dohtml -r DOCS/MANUAL/*
+ fi
+
+ einfo "Please be aware that rar support was removed (it's nonfree)"
+ einfo "You can use app-arch/rar for rar support"
+}