summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-12-04 06:07:15 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-12-04 06:07:15 +0000
commit8508729d090628e8dec431a0a2730a3d5110c830 (patch)
treed1d464c76fa671f61c29372b37d4f6b9a5699c06 /app-arch/pax/pax-3.3.4.ebuild
parentnew package for pax (diff)
downloadgentoo-2-8508729d090628e8dec431a0a2730a3d5110c830.tar.gz
gentoo-2-8508729d090628e8dec431a0a2730a3d5110c830.tar.bz2
gentoo-2-8508729d090628e8dec431a0a2730a3d5110c830.zip
new package for pax
Diffstat (limited to 'app-arch/pax/pax-3.3.4.ebuild')
-rw-r--r--app-arch/pax/pax-3.3.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-arch/pax/pax-3.3.4.ebuild b/app-arch/pax/pax-3.3.4.ebuild
new file mode 100644
index 000000000000..8a120e53d77f
--- /dev/null
+++ b/app-arch/pax/pax-3.3.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+inherit rpm
+
+MY_PS=${P%.*}-${PV##*.}ras
+MY_P=${P%.*}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="pax (Portable Archive eXchange is the POSIX standard archive tool."
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/src/bin/pax/"
+SRC_URI="ftp://rpmfind.net/linux/contrib/libc6/SRPMS/${MY_PS}.src.rpm"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm ~amd64 ~ia64"
+
+DEPEND="virtual/glibc
+ app-arch/rpm2targz"
+
+src_unpack() {
+ rpm_src_unpack
+ cd ${MY_P}
+ epatch ${WORKDIR}/pax-3.3-gcc.patch
+ epatch ${WORKDIR}/pax-3.3-modifyWarn.patch
+ epatch ${WORKDIR}/pax-3.3-doc.patch
+ epatch ${WORKDIR}/pax-3.3-bzip2.patch
+}
+
+src_compile () {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ dobin src/pax
+ doman src/pax.1
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}