summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-12-30 01:12:48 +0000
committerMike Frysinger <vapier@gentoo.org>2006-12-30 01:12:48 +0000
commitc33d927e0cafec553bfdbcd6ef8083abe0b7ab98 (patch)
tree07430891c9f00952234b07ce1154e80eb592f4c0 /app-arch/tar
parentInitial import. (diff)
downloadgentoo-2-c33d927e0cafec553bfdbcd6ef8083abe0b7ab98.tar.gz
gentoo-2-c33d927e0cafec553bfdbcd6ef8083abe0b7ab98.tar.bz2
gentoo-2-c33d927e0cafec553bfdbcd6ef8083abe0b7ab98.zip
Take a page from Debian and make /etc/rmt a shell script so people know why this cruft exists #159429 by Rafal Rzepecki.
(Portage version: 2.1.2_rc4-r2)
Diffstat (limited to 'app-arch/tar')
-rw-r--r--app-arch/tar/ChangeLog7
-rw-r--r--app-arch/tar/files/rmt8
-rw-r--r--app-arch/tar/tar-1.16.1.ebuild10
3 files changed, 20 insertions, 5 deletions
diff --git a/app-arch/tar/ChangeLog b/app-arch/tar/ChangeLog
index 14d430b458ac..acc0b0385499 100644
--- a/app-arch/tar/ChangeLog
+++ b/app-arch/tar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/tar
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/ChangeLog,v 1.82 2006/12/10 01:42:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/ChangeLog,v 1.83 2006/12/30 01:12:48 vapier Exp $
+
+ 30 Dec 2006; Mike Frysinger <vapier@gentoo.org> +files/rmt,
+ tar-1.16.1.ebuild:
+ Take a page from Debian and make /etc/rmt a shell script so people know why
+ this cruft exists #159429 by Rafal Rzepecki.
*tar-1.16.1 (10 Dec 2006)
diff --git a/app-arch/tar/files/rmt b/app-arch/tar/files/rmt
new file mode 100644
index 000000000000..8fbca89fe52f
--- /dev/null
+++ b/app-arch/tar/files/rmt
@@ -0,0 +1,8 @@
+#!/bin/sh
+#
+# This is not a mistake. This shell script (/etc/rmt) has been provided
+# for compatibility with other Unix-like systems, some of which have
+# utilities that expect to find (and execute) rmt in the /etc directory
+# on remote systems.
+#
+exec /usr/bin/rmt "$@"
diff --git a/app-arch/tar/tar-1.16.1.ebuild b/app-arch/tar/tar-1.16.1.ebuild
index 10f01bdd2db2..c40e4c0a6891 100644
--- a/app-arch/tar/tar-1.16.1.ebuild
+++ b/app-arch/tar/tar-1.16.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.16.1.ebuild,v 1.1 2006/12/10 01:42:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.16.1.ebuild,v 1.2 2006/12/30 01:12:48 vapier Exp $
inherit flag-o-matic eutils
@@ -52,9 +52,11 @@ src_install() {
emake DESTDIR="${D}" install || die "make install failed"
- # a nasty yet required symlink
- dodir /etc
- dosym /usr/sbin/${p}rmt /etc/${p}rmt
+ if [[ -z ${p} ]] ; then
+ # a nasty yet required piece of baggage
+ exeinto /etc
+ doexe "${FILESDIR}"/rmt || die
+ fi
dodoc AUTHORS ChangeLog* NEWS README* PORTS THANKS
newman "${FILESDIR}"/tar.1 ${p}tar.1