summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandy Westcott <brandy@gentoo.org>2003-11-01 05:44:07 +0000
committerBrandy Westcott <brandy@gentoo.org>2003-11-01 05:44:07 +0000
commit9542ec09f8cf9ae30669af89d59c429d5fbd7f4a (patch)
tree42903eb7d10859ee5714139a049af584e865c25e /app-arch/upx-ucl/upx-ucl-1.24.ebuild
parentAdd the proper comment for bug #32140. Move the gcc-config stuff (diff)
downloadgentoo-2-9542ec09f8cf9ae30669af89d59c429d5fbd7f4a.tar.gz
gentoo-2-9542ec09f8cf9ae30669af89d59c429d5fbd7f4a.tar.bz2
gentoo-2-9542ec09f8cf9ae30669af89d59c429d5fbd7f4a.zip
Initial import. Closes bug #31493
Diffstat (limited to 'app-arch/upx-ucl/upx-ucl-1.24.ebuild')
-rw-r--r--app-arch/upx-ucl/upx-ucl-1.24.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-arch/upx-ucl/upx-ucl-1.24.ebuild b/app-arch/upx-ucl/upx-ucl-1.24.ebuild
new file mode 100644
index 000000000000..1d534f2c9323
--- /dev/null
+++ b/app-arch/upx-ucl/upx-ucl-1.24.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/upx-ucl/upx-ucl-1.24.ebuild,v 1.1 2003/11/01 05:43:49 brandy Exp $
+
+MY_P=${P/-ucl/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="upx is the Ultimate Packer for eXecutables."
+HOMEPAGE="http://upx.sourceforge.net"
+SRC_URI="mirror://sourceforge/upx/${MY_P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND="dev-libs/ucl
+ dev-lang/perl
+ !app-arch/upx"
+
+src_compile() {
+
+ sed -ie "s:CXX =:CXX =g++:" src/Makefile
+
+ make -C src UCLDIR=/usr CFLAGS_O="${CFLAGS}" || die "Failed compiling"
+ make -C doc || "Failed making documentation"
+}
+
+src_install() {
+
+ dobin src/upx
+
+ dodoc BUGS LICENSE LOADER.TXT NEWS PROJECTS README README.SRC THANKS doc/upx.doc
+ dohtml doc/upx.html
+ doman doc/upx.1
+}