summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-12-09 08:05:17 +0000
committerMike Frysinger <vapier@gentoo.org>2006-12-09 08:05:17 +0000
commit2136275a53b7b4522ad5be4a24cc431f467e8c01 (patch)
tree6daac6b1914a841a2065c8dac4efa13989809e96 /app-arch
parentold (diff)
downloadgentoo-2-2136275a53b7b4522ad5be4a24cc431f467e8c01.tar.gz
gentoo-2-2136275a53b7b4522ad5be4a24cc431f467e8c01.tar.bz2
gentoo-2-2136275a53b7b4522ad5be4a24cc431f467e8c01.zip
Version bump.
(Portage version: 2.1.2_rc3)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/gzip/ChangeLog8
-rw-r--r--app-arch/gzip/files/digest-gzip-1.3.83
-rw-r--r--app-arch/gzip/files/gzip-1.3.8-install-symlinks.patch11
-rw-r--r--app-arch/gzip/gzip-1.3.8.ebuild47
4 files changed, 68 insertions, 1 deletions
diff --git a/app-arch/gzip/ChangeLog b/app-arch/gzip/ChangeLog
index 81b2965cb68b..6c0121dcc436 100644
--- a/app-arch/gzip/ChangeLog
+++ b/app-arch/gzip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/gzip
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/ChangeLog,v 1.71 2006/12/07 13:56:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/ChangeLog,v 1.72 2006/12/09 08:05:17 vapier Exp $
+
+*gzip-1.3.8 (09 Dec 2006)
+
+ 09 Dec 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/gzip-1.3.8-install-symlinks.patch, +gzip-1.3.8.ebuild:
+ Version bump.
*gzip-1.3.7 (07 Dec 2006)
diff --git a/app-arch/gzip/files/digest-gzip-1.3.8 b/app-arch/gzip/files/digest-gzip-1.3.8
new file mode 100644
index 000000000000..d1baaf59f108
--- /dev/null
+++ b/app-arch/gzip/files/digest-gzip-1.3.8
@@ -0,0 +1,3 @@
+MD5 116774b594a6d5e07fc9999f5f42ecb0 gzip-1.3.8.tar.gz 544865
+RMD160 42162c6f5a9a03e7a9ac81ad04bb32a15695861c gzip-1.3.8.tar.gz 544865
+SHA256 45bab5af629eafb45039a2a70792c4a30baee23926e36b0f5a0349806d43e089 gzip-1.3.8.tar.gz 544865
diff --git a/app-arch/gzip/files/gzip-1.3.8-install-symlinks.patch b/app-arch/gzip/files/gzip-1.3.8-install-symlinks.patch
new file mode 100644
index 000000000000..8d92b609b5dd
--- /dev/null
+++ b/app-arch/gzip/files/gzip-1.3.8-install-symlinks.patch
@@ -0,0 +1,11 @@
+--- Makefile.in
++++ Makefile.in
+@@ -926,7 +926,7 @@
+ rm -f "$$dest" && \
+ case $@ in \
+ install-exec-hook) \
+- ln "$$source" "$$dest" || $(LN_S) "$$source" "$$dest";; \
++ $(LN_S) "$$source" "$$dest";; \
+ esac \
+ ) || exit; \
+ done; \
diff --git a/app-arch/gzip/gzip-1.3.8.ebuild b/app-arch/gzip/gzip-1.3.8.ebuild
new file mode 100644
index 000000000000..15d6d7f047a7
--- /dev/null
+++ b/app-arch/gzip/gzip-1.3.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.3.8.ebuild,v 1.1 2006/12/09 08:05:17 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Standard GNU compressor"
+HOMEPAGE="http://www.gnu.org/software/gzip/"
+SRC_URI="ftp://alpha.gnu.org/gnu/gzip/${P}.tar.gz
+ mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls static pic"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+PROVIDE="virtual/gzip"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ #epatch "${FILESDIR}"/${PN}-1.3.5-rsync.patch
+ epatch "${FILESDIR}"/${PN}-1.3.8-install-symlinks.patch
+}
+
+src_compile() {
+ use static && append-flags -static
+ # avoid text relocation in gzip
+ use pic && export DEFS="NO_ASM"
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc ChangeLog NEWS README THANKS TODO
+ docinto txt
+ dodoc algorithm.doc gzip.doc
+
+ # keep most things in /usr, just the fun stuff in /
+ dodir /bin
+ mv "${D}"/usr/bin/{gunzip,gzip,zcat} "${D}"/bin/ || die
+ dosym /bin/gunzip /usr/bin/gunzip || die
+}