summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-07-25 15:47:46 +0000
committerJeroen Roovers <jer@gentoo.org>2011-07-25 15:47:46 +0000
commit7f0d39dbb10838c1f00c372771dce9c7c31d9eed (patch)
tree83c2d1e65a57b6cad5e0b6e2bda9a70264824f33 /app-arch
parentVersion bump. Remove old. (diff)
downloadgentoo-2-7f0d39dbb10838c1f00c372771dce9c7c31d9eed.tar.gz
gentoo-2-7f0d39dbb10838c1f00c372771dce9c7c31d9eed.tar.bz2
gentoo-2-7f0d39dbb10838c1f00c372771dce9c7c31d9eed.zip
Old.
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/dpkg/ChangeLog7
-rw-r--r--app-arch/dpkg/dpkg-1.15.8.10.ebuild92
-rw-r--r--app-arch/dpkg/dpkg-1.15.8.11.ebuild92
-rw-r--r--app-arch/dpkg/dpkg-1.15.8.8.ebuild89
-rw-r--r--app-arch/dpkg/dpkg-1.16.0.1.ebuild92
-rw-r--r--app-arch/dpkg/dpkg-1.16.0.2.ebuild92
-rw-r--r--app-arch/dpkg/dpkg-1.16.0.ebuild92
7 files changed, 6 insertions, 550 deletions
diff --git a/app-arch/dpkg/ChangeLog b/app-arch/dpkg/ChangeLog
index de4857f0a627..9cd283a49813 100644
--- a/app-arch/dpkg/ChangeLog
+++ b/app-arch/dpkg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/dpkg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.171 2011/07/24 12:50:32 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.172 2011/07/25 15:47:46 jer Exp $
+
+ 25 Jul 2011; Jeroen Roovers <jer@gentoo.org> -dpkg-1.15.8.8.ebuild,
+ -dpkg-1.15.8.10.ebuild, -dpkg-1.15.8.11.ebuild, -dpkg-1.16.0.ebuild,
+ -dpkg-1.16.0.1.ebuild, -dpkg-1.16.0.2.ebuild:
+ ^
24 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> dpkg-1.16.0.3.ebuild:
ppc/ppc64 stable wrt #372765
diff --git a/app-arch/dpkg/dpkg-1.15.8.10.ebuild b/app-arch/dpkg/dpkg-1.15.8.10.ebuild
deleted file mode 100644
index 2a8e2ab85f08..000000000000
--- a/app-arch/dpkg/dpkg-1.15.8.10.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.15.8.10.ebuild,v 1.8 2011/04/16 16:29:48 jer Exp $
-
-EAPI=3
-
-inherit eutils multilib autotools toolchain-funcs
-
-DESCRIPTION="Package maintenance system for Debian"
-HOMEPAGE="http://packages.qa.debian.org/dpkg"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ppc ~ppc64 s390 sh sparc x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="bzip2 dselect nls test unicode zlib"
-
-LANGS="
- ast bs ca cs da de dz el eo es et eu fr gl hu id it ja km ko ku lt mr nb ne
- nl nn pa pl pt_BR pt ro ru sk sv th tl vi zh_CN zh_TW
-"
-
-for X in ${LANGS} ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
-RDEPEND=">=dev-lang/perl-5.6.0
- dev-perl/TimeDate
- >=sys-libs/ncurses-5.2-r7
- zlib? ( >=sys-libs/zlib-1.1.4 )
- bzip2? ( app-arch/bzip2 )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- nls? ( app-text/po4a )
- test? (
- dev-perl/DateTime-Format-DateParse
- dev-perl/IO-String
- dev-perl/Test-Pod
- )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.15.5.6-bootstrap.patch
-
- # don't mess with linker optimisation, respect user's flags (don't break!)
- sed -i -e '/DPKG_LINKER_OPTIMISATIONS/d' configure.ac || die
-
- # Force the use of the running bash for get-version (this file is never
- # installed, so no need to worry about hardcoding a temporary bash)
- sed -i -e '1c\#!'"${BASH}" get-version || die
-
- # this test depends on a Debian only gzip extension that adds --rsyncable
- # which will therefore always fail on Gentoo. (bug #310847).
- sed -i scripts/Makefile.am \
- -e '/850_Dpkg_Compression.t/d' \
- || die "sed failed"
-
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- local myconf
- if use nls; then
- myconf="--enable-nls $(use_with dselect)"
- else
- if use dselect; then
- elog "Building dselect requires USE=nls - disabling USE=dselect..."
- fi
- myconf="--disable-nls --without-dselect"
- fi
- econf \
- ${myconf} \
- $(use_with bzip2 bz2) \
- $(use_enable unicode) \
- $(use_with zlib) \
- --disable-compiler-warnings \
- --without-selinux \
- --without-start-stop-daemon
-}
-
-src_install() {
- strip-linguas ${LANGS}
- if [ -z "${LINGUAS}" ] ; then
- LINGUAS=none
- fi
-
- emake DESTDIR="${D}" LINGUAS="${LINGUAS}" install || die "emake install failed"
- rm "${ED}"/usr/sbin/install-info || die "rm install-info failed"
- dodoc ChangeLog INSTALL THANKS TODO
- keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
- keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
-}
diff --git a/app-arch/dpkg/dpkg-1.15.8.11.ebuild b/app-arch/dpkg/dpkg-1.15.8.11.ebuild
deleted file mode 100644
index 574a780faaa3..000000000000
--- a/app-arch/dpkg/dpkg-1.15.8.11.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.15.8.11.ebuild,v 1.1 2011/04/26 23:11:21 jer Exp $
-
-EAPI=3
-
-inherit eutils multilib autotools toolchain-funcs
-
-DESCRIPTION="Package maintenance system for Debian"
-HOMEPAGE="http://packages.qa.debian.org/dpkg"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="bzip2 dselect nls test unicode zlib"
-
-LANGS="
- ast bs ca cs da de dz el eo es et eu fr gl hu id it ja km ko ku lt mr nb ne
- nl nn pa pl pt_BR pt ro ru sk sv th tl vi zh_CN zh_TW
-"
-
-for X in ${LANGS} ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
-RDEPEND=">=dev-lang/perl-5.6.0
- dev-perl/TimeDate
- >=sys-libs/ncurses-5.2-r7
- zlib? ( >=sys-libs/zlib-1.1.4 )
- bzip2? ( app-arch/bzip2 )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- nls? ( app-text/po4a )
- test? (
- dev-perl/DateTime-Format-DateParse
- dev-perl/IO-String
- dev-perl/Test-Pod
- )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.15.5.6-bootstrap.patch
-
- # don't mess with linker optimisation, respect user's flags (don't break!)
- sed -i -e '/DPKG_LINKER_OPTIMISATIONS/d' configure.ac || die
-
- # Force the use of the running bash for get-version (this file is never
- # installed, so no need to worry about hardcoding a temporary bash)
- sed -i -e '1c\#!'"${BASH}" get-version || die
-
- # this test depends on a Debian only gzip extension that adds --rsyncable
- # which will therefore always fail on Gentoo. (bug #310847).
- sed -i scripts/Makefile.am \
- -e '/850_Dpkg_Compression.t/d' \
- || die "sed failed"
-
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- local myconf
- if use nls; then
- myconf="--enable-nls $(use_with dselect)"
- else
- if use dselect; then
- elog "Building dselect requires USE=nls - disabling USE=dselect..."
- fi
- myconf="--disable-nls --without-dselect"
- fi
- econf \
- ${myconf} \
- $(use_with bzip2 bz2) \
- $(use_enable unicode) \
- $(use_with zlib) \
- --disable-compiler-warnings \
- --without-selinux \
- --without-start-stop-daemon
-}
-
-src_install() {
- strip-linguas ${LANGS}
- if [ -z "${LINGUAS}" ] ; then
- LINGUAS=none
- fi
-
- emake DESTDIR="${D}" LINGUAS="${LINGUAS}" install || die "emake install failed"
- rm "${ED}"/usr/sbin/install-info || die "rm install-info failed"
- dodoc ChangeLog INSTALL THANKS TODO
- keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
- keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
-}
diff --git a/app-arch/dpkg/dpkg-1.15.8.8.ebuild b/app-arch/dpkg/dpkg-1.15.8.8.ebuild
deleted file mode 100644
index 57911f21aac9..000000000000
--- a/app-arch/dpkg/dpkg-1.15.8.8.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.15.8.8.ebuild,v 1.7 2011/01/08 18:55:28 jer Exp $
-
-EAPI=3
-
-inherit eutils multilib autotools toolchain-funcs
-
-DESCRIPTION="Package maintenance system for Debian"
-HOMEPAGE="http://packages.qa.debian.org/dpkg"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ppc ppc64 s390 sh sparc x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="bzip2 dselect nls test unicode zlib"
-
-LANGS="sv de es ja fr hu pl ru"
-
-for X in ${LANGS} ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
-RDEPEND=">=dev-lang/perl-5.6.0
- dev-perl/TimeDate
- >=sys-libs/ncurses-5.2-r7
- zlib? ( >=sys-libs/zlib-1.1.4 )
- bzip2? ( app-arch/bzip2 )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- nls? ( app-text/po4a )
- test? (
- dev-perl/DateTime-Format-DateParse
- dev-perl/IO-String
- dev-perl/Test-Pod
- )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.15.5.6-bootstrap.patch
-
- # don't mess with linker optimisation, respect user's flags (don't break!)
- sed -i -e '/DPKG_LINKER_OPTIMISATIONS/d' configure.ac || die
-
- # Force the use of the running bash for get-version (this file is never
- # installed, so no need to worry about hardcoding a temporary bash)
- sed -i -e '1c\#!'"${BASH}" get-version || die
-
- # this test depends on a Debian only gzip extension that adds --rsyncable
- # which will therefore always fail on Gentoo. (bug #310847).
- sed -i scripts/Makefile.am \
- -e '/850_Dpkg_Compression.t/d' \
- || die "sed failed"
-
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- local myconf
- if use nls; then
- myconf="--enable-nls $(use_with dselect)"
- else
- if use dselect; then
- elog "Building dselect requires USE=nls - disabling USE=dselect..."
- fi
- myconf="--disable-nls --without-dselect"
- fi
- econf \
- ${myconf} \
- $(use_with bzip2 bz2) \
- $(use_enable unicode) \
- $(use_with zlib) \
- --disable-compiler-warnings \
- --without-selinux \
- --without-start-stop-daemon
-}
-
-src_install() {
- strip-linguas ${LANGS}
- if [ -z "${LINGUAS}" ] ; then
- LINGUAS=none
- fi
-
- emake DESTDIR="${D}" LINGUAS="${LINGUAS}" install || die "emake install failed"
- rm "${ED}"/usr/sbin/install-info || die "rm install-info failed"
- dodoc ChangeLog INSTALL THANKS TODO
- keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
- keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
-}
diff --git a/app-arch/dpkg/dpkg-1.16.0.1.ebuild b/app-arch/dpkg/dpkg-1.16.0.1.ebuild
deleted file mode 100644
index 1ba7e296b3c9..000000000000
--- a/app-arch/dpkg/dpkg-1.16.0.1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.16.0.1.ebuild,v 1.2 2011/04/16 16:29:48 jer Exp $
-
-EAPI=3
-
-inherit eutils multilib autotools toolchain-funcs
-
-DESCRIPTION="Package maintenance system for Debian"
-HOMEPAGE="http://packages.qa.debian.org/dpkg"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="bzip2 dselect nls test unicode zlib"
-
-LANGS="
- ast bs ca cs da de dz el eo es et eu fr gl hu id it ja km ko ku lt mr nb ne
- nl nn pa pl pt_BR pt ro ru sk sv th tl vi zh_CN zh_TW
-"
-
-for X in ${LANGS} ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
-RDEPEND=">=dev-lang/perl-5.6.0
- dev-perl/TimeDate
- >=sys-libs/ncurses-5.2-r7
- zlib? ( >=sys-libs/zlib-1.1.4 )
- bzip2? ( app-arch/bzip2 )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- nls? ( app-text/po4a )
- test? (
- dev-perl/DateTime-Format-DateParse
- dev-perl/IO-String
- dev-perl/Test-Pod
- )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.15.5.6-bootstrap.patch
-
- # don't mess with linker optimisation, respect user's flags (don't break!)
- sed -i -e '/DPKG_LINKER_OPTIMISATIONS/d' configure.ac || die
-
- # Force the use of the running bash for get-version (this file is never
- # installed, so no need to worry about hardcoding a temporary bash)
- sed -i -e '1c\#!'"${BASH}" get-version || die
-
- # this test depends on a Debian only gzip extension that adds --rsyncable
- # which will therefore always fail on Gentoo. (bug #310847).
- sed -i scripts/Makefile.am \
- -e '/850_Dpkg_Compression.t/d' \
- || die "sed failed"
-
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- local myconf
- if use nls; then
- myconf="--enable-nls $(use_with dselect)"
- else
- if use dselect; then
- elog "Building dselect requires USE=nls - disabling USE=dselect..."
- fi
- myconf="--disable-nls --without-dselect"
- fi
- econf \
- ${myconf} \
- $(use_with bzip2 bz2) \
- $(use_enable unicode) \
- $(use_with zlib) \
- --disable-compiler-warnings \
- --without-selinux \
- --without-start-stop-daemon
-}
-
-src_install() {
- strip-linguas ${LANGS}
- if [ -z "${LINGUAS}" ] ; then
- LINGUAS=none
- fi
-
- emake DESTDIR="${D}" LINGUAS="${LINGUAS}" install || die "emake install failed"
- rm "${ED}"/usr/sbin/install-info || die "rm install-info failed"
- dodoc ChangeLog THANKS TODO
- keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
- keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
-}
diff --git a/app-arch/dpkg/dpkg-1.16.0.2.ebuild b/app-arch/dpkg/dpkg-1.16.0.2.ebuild
deleted file mode 100644
index 3fe5329cde27..000000000000
--- a/app-arch/dpkg/dpkg-1.16.0.2.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.16.0.2.ebuild,v 1.2 2011/04/16 16:10:10 jer Exp $
-
-EAPI=3
-
-inherit eutils multilib autotools toolchain-funcs
-
-DESCRIPTION="Package maintenance system for Debian"
-HOMEPAGE="http://packages.qa.debian.org/dpkg"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="bzip2 dselect nls test unicode zlib"
-
-LANGS="
- ast bs ca cs da de dz el eo es et eu fr gl hu id it ja km ko ku lt mr nb ne
- nl nn pa pl pt_BR pt ro ru sk sv th tl vi zh_CN zh_TW
-"
-
-for X in ${LANGS} ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
-RDEPEND=">=dev-lang/perl-5.6.0
- dev-perl/TimeDate
- >=sys-libs/ncurses-5.2-r7
- zlib? ( >=sys-libs/zlib-1.1.4 )
- bzip2? ( app-arch/bzip2 )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- nls? ( app-text/po4a )
- test? (
- dev-perl/DateTime-Format-DateParse
- dev-perl/IO-String
- dev-perl/Test-Pod
- )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.15.5.6-bootstrap.patch
-
- # don't mess with linker optimisation, respect user's flags (don't break!)
- sed -i -e '/DPKG_LINKER_OPTIMISATIONS/d' configure.ac || die
-
- # Force the use of the running bash for get-version (this file is never
- # installed, so no need to worry about hardcoding a temporary bash)
- sed -i -e '1c\#!'"${BASH}" get-version || die
-
- # this test depends on a Debian only gzip extension that adds --rsyncable
- # which will therefore always fail on Gentoo. (bug #310847).
- sed -i scripts/Makefile.am \
- -e '/850_Dpkg_Compression.t/d' \
- || die "sed failed"
-
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- local myconf
- if use nls; then
- myconf="--enable-nls $(use_with dselect)"
- else
- if use dselect; then
- elog "Building dselect requires USE=nls - disabling USE=dselect..."
- fi
- myconf="--disable-nls --without-dselect"
- fi
- econf \
- ${myconf} \
- $(use_with bzip2 bz2) \
- $(use_enable unicode) \
- $(use_with zlib) \
- --disable-compiler-warnings \
- --without-selinux \
- --without-start-stop-daemon
-}
-
-src_install() {
- strip-linguas ${LANGS}
- if [ -z "${LINGUAS}" ] ; then
- LINGUAS=none
- fi
-
- emake DESTDIR="${D}" LINGUAS="${LINGUAS}" install || die "emake install failed"
- rm "${ED}"/usr/sbin/install-info || die "rm install-info failed"
- dodoc ChangeLog THANKS TODO
- keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
- keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
-}
diff --git a/app-arch/dpkg/dpkg-1.16.0.ebuild b/app-arch/dpkg/dpkg-1.16.0.ebuild
deleted file mode 100644
index a2deb9599b2a..000000000000
--- a/app-arch/dpkg/dpkg-1.16.0.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.16.0.ebuild,v 1.2 2011/04/16 16:29:48 jer Exp $
-
-EAPI=3
-
-inherit eutils multilib autotools toolchain-funcs
-
-DESCRIPTION="Package maintenance system for Debian"
-HOMEPAGE="http://packages.qa.debian.org/dpkg"
-SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="bzip2 dselect nls test unicode zlib"
-
-LANGS="
- ast bs ca cs da de dz el eo es et eu fr gl hu id it ja km ko ku lt mr nb ne
- nl nn pa pl pt_BR pt ro ru sk sv th tl vi zh_CN zh_TW
-"
-
-for X in ${LANGS} ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
-RDEPEND=">=dev-lang/perl-5.6.0
- dev-perl/TimeDate
- >=sys-libs/ncurses-5.2-r7
- zlib? ( >=sys-libs/zlib-1.1.4 )
- bzip2? ( app-arch/bzip2 )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- nls? ( app-text/po4a )
- test? (
- dev-perl/DateTime-Format-DateParse
- dev-perl/IO-String
- dev-perl/Test-Pod
- )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.15.5.6-bootstrap.patch
-
- # don't mess with linker optimisation, respect user's flags (don't break!)
- sed -i -e '/DPKG_LINKER_OPTIMISATIONS/d' configure.ac || die
-
- # Force the use of the running bash for get-version (this file is never
- # installed, so no need to worry about hardcoding a temporary bash)
- sed -i -e '1c\#!'"${BASH}" get-version || die
-
- # this test depends on a Debian only gzip extension that adds --rsyncable
- # which will therefore always fail on Gentoo. (bug #310847).
- sed -i scripts/Makefile.am \
- -e '/850_Dpkg_Compression.t/d' \
- || die "sed failed"
-
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- local myconf
- if use nls; then
- myconf="--enable-nls $(use_with dselect)"
- else
- if use dselect; then
- elog "Building dselect requires USE=nls - disabling USE=dselect..."
- fi
- myconf="--disable-nls --without-dselect"
- fi
- econf \
- ${myconf} \
- $(use_with bzip2 bz2) \
- $(use_enable unicode) \
- $(use_with zlib) \
- --disable-compiler-warnings \
- --without-selinux \
- --without-start-stop-daemon
-}
-
-src_install() {
- strip-linguas ${LANGS}
- if [ -z "${LINGUAS}" ] ; then
- LINGUAS=none
- fi
-
- emake DESTDIR="${D}" LINGUAS="${LINGUAS}" install || die "emake install failed"
- rm "${ED}"/usr/sbin/install-info || die "rm install-info failed"
- dodoc ChangeLog THANKS TODO
- keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
- keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
-}