summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-12-06 03:09:11 +0000
committerMike Frysinger <vapier@gentoo.org>2012-12-06 03:09:11 +0000
commit82bf4e4371237b1686f763eb7f2c1de6cc0f2470 (patch)
tree243c37c292a025f7ba0f6b4a6dce0fb798251fe5 /app-arch
parentRDEPEND on libxml2 for the xmlcatalog utility. (diff)
downloadgentoo-2-82bf4e4371237b1686f763eb7f2c1de6cc0f2470.tar.gz
gentoo-2-82bf4e4371237b1686f763eb7f2c1de6cc0f2470.tar.bz2
gentoo-2-82bf4e4371237b1686f763eb7f2c1de6cc0f2470.zip
Add USE=static and move to EAPI=4 since EAPI=5 features are not in use.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/pixz/ChangeLog6
-rw-r--r--app-arch/pixz/pixz-1.0.ebuild22
-rw-r--r--app-arch/pixz/pixz-9999.ebuild22
3 files changed, 33 insertions, 17 deletions
diff --git a/app-arch/pixz/ChangeLog b/app-arch/pixz/ChangeLog
index 14c9f4c6e05b..713e77af891c 100644
--- a/app-arch/pixz/ChangeLog
+++ b/app-arch/pixz/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/pixz
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/pixz/ChangeLog,v 1.2 2012/11/25 02:10:01 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pixz/ChangeLog,v 1.3 2012/12/06 03:09:11 vapier Exp $
+
+ 06 Dec 2012; Mike Frysinger <vapier@gentoo.org> pixz-1.0.ebuild,
+ pixz-9999.ebuild:
+ Add USE=static and move to EAPI=4 since EAPI=5 features are not in use.
*pixz-1.0 (25 Nov 2012)
diff --git a/app-arch/pixz/pixz-1.0.ebuild b/app-arch/pixz/pixz-1.0.ebuild
index 47b343bda7ca..f22ecab3488a 100644
--- a/app-arch/pixz/pixz-1.0.ebuild
+++ b/app-arch/pixz/pixz-1.0.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/pixz/pixz-1.0.ebuild,v 1.1 2012/11/25 02:10:01 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pixz/pixz-1.0.ebuild,v 1.2 2012/12/06 03:09:11 vapier Exp $
-EAPI=5
+EAPI=4
-inherit toolchain-funcs
+inherit toolchain-funcs flag-o-matic
DESCRIPTION="Parallel Indexed XZ compressor"
HOMEPAGE="https://github.com/vasi/pixz"
if [[ ${PV} == "9999" ]] ; then
- inherit git-2
EGIT_REPO_URI="https://github.com/vasi/pixz.git"
+ inherit git-2
KEYWORDS=""
else
SRC_URI="mirror://github/vasi/${PN}/${P}.tar.gz"
@@ -20,11 +20,17 @@ fi
LICENSE="BSD-2"
SLOT="0"
-IUSE=""
+IUSE="static"
-DEPEND=">=app-arch/libarchive-2.8
- >=app-arch/xz-utils-5"
-RDEPEND="${DEPEND}"
+LIB_DEPEND=">=app-arch/libarchive-2.8[static-libs(+)]
+ >=app-arch/xz-utils-5[static-libs(+)]"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
+
+src_configure() {
+ use static && append-ldflags -static
+}
src_compile() {
emake CC="$(tc-getCC)" OPT=""
diff --git a/app-arch/pixz/pixz-9999.ebuild b/app-arch/pixz/pixz-9999.ebuild
index d6844dfc39f5..a7a58d427ae8 100644
--- a/app-arch/pixz/pixz-9999.ebuild
+++ b/app-arch/pixz/pixz-9999.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/pixz/pixz-9999.ebuild,v 1.2 2012/11/25 02:10:01 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pixz/pixz-9999.ebuild,v 1.3 2012/12/06 03:09:11 vapier Exp $
-EAPI=5
+EAPI=4
-inherit toolchain-funcs
+inherit toolchain-funcs flag-o-matic
DESCRIPTION="Parallel Indexed XZ compressor"
HOMEPAGE="https://github.com/vasi/pixz"
if [[ ${PV} == "9999" ]] ; then
- inherit git-2
EGIT_REPO_URI="https://github.com/vasi/pixz.git"
+ inherit git-2
KEYWORDS=""
else
SRC_URI="mirror://github/vasi/${PN}/${P}.tar.gz"
@@ -20,11 +20,17 @@ fi
LICENSE="BSD-2"
SLOT="0"
-IUSE=""
+IUSE="static"
-DEPEND=">=app-arch/libarchive-2.8
- >=app-arch/xz-utils-5"
-RDEPEND="${DEPEND}"
+LIB_DEPEND=">=app-arch/libarchive-2.8[static-libs(+)]
+ >=app-arch/xz-utils-5[static-libs(+)]"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
+
+src_configure() {
+ use static && append-ldflags -static
+}
src_compile() {
emake CC="$(tc-getCC)" OPT=""