summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-06-21 06:05:23 +0000
committerMike Frysinger <vapier@gentoo.org>2008-06-21 06:05:23 +0000
commitb33f4164f2ef4e6a91a8299a0efa71c2e6b5321a (patch)
tree49b64e31ee96011b2f4fce55e375f582ceb05439 /app-arch
parentold (diff)
downloadgentoo-2-b33f4164f2ef4e6a91a8299a0efa71c2e6b5321a.tar.gz
gentoo-2-b33f4164f2ef4e6a91a8299a0efa71c2e6b5321a.tar.bz2
gentoo-2-b33f4164f2ef4e6a91a8299a0efa71c2e6b5321a.zip
Only move "important" bzip2 binaries to / #226175 by Alexander Skwar.
(Portage version: 2.2_pre8/cvs/Linux 2.6.25 x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/bzip2/ChangeLog7
-rw-r--r--app-arch/bzip2/bzip2-1.0.5-r1.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/app-arch/bzip2/ChangeLog b/app-arch/bzip2/ChangeLog
index 62a62b12d516..7ea4e4e54e2f 100644
--- a/app-arch/bzip2/ChangeLog
+++ b/app-arch/bzip2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/bzip2
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/ChangeLog,v 1.67 2008/03/21 05:14:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/ChangeLog,v 1.68 2008/06/21 06:05:23 vapier Exp $
+
+*bzip2-1.0.5-r1 (21 Jun 2008)
+
+ 21 Jun 2008; Mike Frysinger <vapier@gentoo.org> +bzip2-1.0.5-r1.ebuild:
+ Only move "important" bzip2 binaries to / #226175 by Alexander Skwar.
21 Mar 2008; Mike Frysinger <vapier@gentoo.org>
-files/bzip2-1.0.3-shared-largefile-support.patch,
diff --git a/app-arch/bzip2/bzip2-1.0.5-r1.ebuild b/app-arch/bzip2/bzip2-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..fc3d37dde930
--- /dev/null
+++ b/app-arch/bzip2/bzip2-1.0.5-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/bzip2-1.0.5-r1.ebuild,v 1.1 2008/06/21 06:05:23 vapier Exp $
+
+inherit eutils multilib toolchain-funcs flag-o-matic
+
+DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
+HOMEPAGE="http://www.bzip.org/"
+SRC_URI="http://www.bzip.org/${PV}/${P}.tar.gz"
+
+LICENSE="BZIP2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="static"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.0.4-makefile-CFLAGS.patch
+ epatch "${FILESDIR}"/${PN}-1.0.4-saneso.patch
+ epatch "${FILESDIR}"/${PN}-1.0.4-man-links.patch #172986
+ epatch "${FILESDIR}"/${PN}-1.0.2-progress.patch
+ epatch "${FILESDIR}"/${PN}-1.0.3-no-test.patch
+ epatch "${FILESDIR}"/${PN}-1.0.4-POSIX-shell.patch #193365
+ sed -i -e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' Makefile || die "sed manpath"
+
+ # - Generate symlinks instead of hardlinks
+ # - pass custom variables to control libdir
+ sed -i \
+ -e 's:ln -s -f $(PREFIX)/bin/:ln -s :' \
+ -e 's:$(PREFIX)/lib:$(PREFIX)/$(LIBDIR):g' \
+ Makefile || die "sed links"
+
+ # fixup broken version stuff
+ sed -i \
+ -e "s:1\.0\.4:${PV}:" \
+ bzip2.1 bzip2.txt Makefile-libbz2_so manual.{html,ps,xml} || die
+}
+
+src_compile() {
+ local makeopts="
+ CC=$(tc-getCC)
+ AR=$(tc-getAR)
+ RANLIB=$(tc-getRANLIB)
+ "
+ emake ${makeopts} -f Makefile-libbz2_so all || die "Make failed libbz2"
+ use static && append-flags -static
+ emake LDFLAGS="${LDFLAGS}" ${makeopts} all || die "Make failed"
+}
+
+src_install() {
+ emake PREFIX="${D}"/usr LIBDIR=$(get_libdir) install || die
+ dodoc README* CHANGES bzip2.txt manual.*
+
+ # move "important" bzip2 binaries to /bin and use the shared libbz2.so
+ dodir /bin
+ mv "${D}"/usr/bin/b{zip2,zcat,unzip2} "${D}"/bin/ || die
+ dosym bzip2 /bin/bzcat
+ dosym bzip2 /bin/bunzip2
+ into /
+ if ! use static ; then
+ newbin bzip2-shared bzip2 || die "dobin shared"
+ fi
+
+ dolib.so libbz2.so.${PV} || die "dolib shared"
+ for v in libbz2.so{,.{${PV%%.*},${PV%.*}}} ; do
+ dosym libbz2.so.${PV} /$(get_libdir)/${v}
+ done
+ gen_usr_ldscript libbz2.so
+}