summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-10-28 06:48:47 +0000
committerJustin Lecher <jlec@gentoo.org>2014-10-28 06:48:47 +0000
commit2f3ec0bc55c99a48861a6b858e03cfcdb5def8cd (patch)
tree2734826557a42525d1e1f62818bfc6ba6b96f291 /app-backup
parentVersion bump. (diff)
downloadgentoo-2-2f3ec0bc55c99a48861a6b858e03cfcdb5def8cd.tar.gz
gentoo-2-2f3ec0bc55c99a48861a6b858e03cfcdb5def8cd.tar.bz2
gentoo-2-2f3ec0bc55c99a48861a6b858e03cfcdb5def8cd.zip
app-backup/deja-dup: Add compatibility for duplicity-0.6.25
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/deja-dup/ChangeLog8
-rw-r--r--app-backup/deja-dup/deja-dup-32.0-r1.ebuild78
-rw-r--r--app-backup/deja-dup/files/deja-dup-32.0-duplicity-0.6.25.patch41
3 files changed, 126 insertions, 1 deletions
diff --git a/app-backup/deja-dup/ChangeLog b/app-backup/deja-dup/ChangeLog
index cf00daaecf0a..9816c53c7e06 100644
--- a/app-backup/deja-dup/ChangeLog
+++ b/app-backup/deja-dup/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-backup/deja-dup
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/deja-dup/ChangeLog,v 1.51 2014/09/20 16:31:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/deja-dup/ChangeLog,v 1.52 2014/10/28 06:48:47 jlec Exp $
+
+*deja-dup-32.0-r1 (28 Oct 2014)
+
+ 28 Oct 2014; Justin Lecher <jlec@gentoo.org> +deja-dup-32.0-r1.ebuild,
+ +files/deja-dup-32.0-duplicity-0.6.25.patch:
+ Add compatibility for duplicity-0.6.25
*deja-dup-32.0 (20 Sep 2014)
diff --git a/app-backup/deja-dup/deja-dup-32.0-r1.ebuild b/app-backup/deja-dup/deja-dup-32.0-r1.ebuild
new file mode 100644
index 000000000000..451dbfafa874
--- /dev/null
+++ b/app-backup/deja-dup/deja-dup-32.0-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/deja-dup/deja-dup-32.0-r1.ebuild,v 1.1 2014/10/28 06:48:47 jlec Exp $
+
+EAPI=5
+
+GNOME2_LA_PUNT="yes"
+
+VALA_MIN_API_VERSION="0.20"
+VALA_MAX_API_VERSION="0.24"
+
+inherit cmake-utils eutils gnome2 vala
+
+DESCRIPTION="Simple backup tool using duplicity back-end"
+HOMEPAGE="https://launchpad.net/deja-dup/"
+SRC_URI="http://launchpad.net/${PN}/32/${PV}/+download/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nautilus test"
+
+RESTRICT="test"
+
+COMMON_DEPEND="
+ app-crypt/libsecret[vala]
+ >=dev-libs/glib-2.34:2
+ >=dev-libs/libpeas-1.0
+ >=x11-libs/gtk+-3.6:3
+ >=x11-libs/libnotify-0.7
+
+ >=app-backup/duplicity-0.6.23
+ dev-libs/dbus-glib
+
+ nautilus? ( gnome-base/nautilus )"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/dconf
+ gnome-base/gvfs[fuse]"
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ $(vala_depend)
+ dev-perl/Locale-gettext
+ virtual/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-duplicity-0.6.25.patch
+)
+
+src_prepare() {
+ sed \
+ -e '/RPATH/s:PKG_LIBEXECDIR:PKG_LIBDIR:g' \
+ -i CMakeLists.txt || die
+ vala_src_prepare
+ gnome2_src_prepare
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CCPANEL=OFF
+ -DENABLE_UNITY=OFF
+ -DENABLE_UNITY_CCPANEL=OFF
+ -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}"/etc
+ $(cmake-utils_use_enable nautilus)
+ $(cmake-utils_use_enable test TESTING)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+}
diff --git a/app-backup/deja-dup/files/deja-dup-32.0-duplicity-0.6.25.patch b/app-backup/deja-dup/files/deja-dup-32.0-duplicity-0.6.25.patch
new file mode 100644
index 000000000000..016e67829fd5
--- /dev/null
+++ b/app-backup/deja-dup/files/deja-dup-32.0-duplicity-0.6.25.patch
@@ -0,0 +1,41 @@
+=== modified file 'AUTHORS'
+--- AUTHORS 2014-04-29 02:38:47 +0000
++++ AUTHORS 2014-10-23 06:41:44 +0000
+@@ -12,6 +12,10 @@
+ Comment: For specific author information, see the bzr logs
+ License: GPL-3+
+
++Files: libdeja/tools/duplicity/DuplicityPlugin.vala
++Copyright: 2014 Adrien Bak <adrien.bak@gmail.com>
++Licence: GPL-3+
++
+ Files: po/*.po
+ Copyright: 2008–2013 Rosetta Contributors and Canonical Ltd
+ License: GPL-3+
+
+=== modified file 'libdeja/tools/duplicity/DuplicityPlugin.vala'
+--- libdeja/tools/duplicity/DuplicityPlugin.vala 2014-01-24 16:07:59 +0000
++++ libdeja/tools/duplicity/DuplicityPlugin.vala 2014-10-23 06:41:44 +0000
+@@ -35,13 +35,17 @@
+ {
+ string output;
+ Process.spawn_command_line_sync("duplicity --version", out output, null, null);
++ var tokens = output.split(" ");
+
+- var tokens = output.split(" ", 2);
+- if (tokens == null || tokens[0] == null || tokens[1] == null)
++ if (tokens == null || tokens.length < 2 )
+ throw new SpawnError.FAILED(_("Could not understand duplicity version."));
+
+- // First token is 'duplicity' and is ignorable. Second looks like '0.5.03'
+- var version_string = tokens[1].strip();
++ // in version 0.6.25, the output fro duplicity --version changed and the string
++ // "duplicity major.minor.micro" is not preceded by a deprecation warning
++ // as a consequence, the substring "major.minor.micro" is now
++ // always the penultimate token (the last one always being null)
++
++ var version_string = tokens[tokens.length - 1].strip();
+ int major, minor, micro;
+ if (!DejaDup.parse_version(version_string, out major, out minor, out micro))
+ throw new SpawnError.FAILED(_("Could not understand duplicity version ‘%s’.").printf(version_string));
+