summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2007-03-05 15:23:12 +0000
committerJeroen Roovers <jer@gentoo.org>2007-03-05 15:23:12 +0000
commit3fdb68dfb77145a191baf414f0cac30116b11849 (patch)
tree996b5c50acea1b8dcafceb8304b19a0a8b232945 /app-backup
parentremove mask on Ice now that db-4.5 is unmasked (diff)
downloadgentoo-2-3fdb68dfb77145a191baf414f0cac30116b11849.tar.gz
gentoo-2-3fdb68dfb77145a191baf414f0cac30116b11849.tar.bz2
gentoo-2-3fdb68dfb77145a191baf414f0cac30116b11849.zip
Version bump.
(Portage version: 2.1.2.1)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/amanda/ChangeLog7
-rw-r--r--app-backup/amanda/amanda-2.5.1_p3.ebuild360
-rw-r--r--app-backup/amanda/files/digest-amanda-2.5.1_p33
3 files changed, 369 insertions, 1 deletions
diff --git a/app-backup/amanda/ChangeLog b/app-backup/amanda/ChangeLog
index 51d01fc1e6f5..181059a81395 100644
--- a/app-backup/amanda/ChangeLog
+++ b/app-backup/amanda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-backup/amanda
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/amanda/ChangeLog,v 1.18 2007/01/24 04:06:29 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/amanda/ChangeLog,v 1.19 2007/03/05 15:23:12 jer Exp $
+
+*amanda-2.5.1_p3 (05 Mar 2007)
+
+ 05 Mar 2007; Jeroen Roovers <jer@gentoo.org> +amanda-2.5.1_p3.ebuild:
+ Version bump.
24 Jan 2007; Marius Mauch <genone@gentoo.org> amanda-2.4.5.ebuild,
amanda-2.4.5_p1.ebuild, amanda-2.5.1_p2.ebuild:
diff --git a/app-backup/amanda/amanda-2.5.1_p3.ebuild b/app-backup/amanda/amanda-2.5.1_p3.ebuild
new file mode 100644
index 000000000000..3bfc62fb3057
--- /dev/null
+++ b/app-backup/amanda/amanda-2.5.1_p3.ebuild
@@ -0,0 +1,360 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/amanda/amanda-2.5.1_p3.ebuild,v 1.1 2007/03/05 15:23:12 jer Exp $
+
+inherit eutils
+
+DESCRIPTION="The Advanced Maryland Automatic Network Disk Archiver"
+HOMEPAGE="http://www.amanda.org/"
+SRC_URI="mirror://sourceforge/amanda/${P/_/}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+RDEPEND="sys-libs/readline
+ virtual/inetd
+ app-arch/mt-st
+ sci-visualization/gnuplot
+ sys-apps/gawk
+ app-arch/tar
+ dev-lang/perl
+ sys-block/mtx
+ app-arch/dump
+ virtual/mailx
+ samba? ( net-fs/samba )
+ berkdb? ( sys-libs/db )
+ gdbm? ( sys-libs/gdbm )
+ !sparc? ( xfs? ( sys-fs/xfsdump ) )
+ >=sys-apps/portage-2.0.51-r3
+ app-crypt/aespipe
+ app-crypt/gnupg"
+
+DEPEND="${RDEPEND}
+ sys-devel/autoconf
+ sys-devel/automake"
+
+IUSE="berkdb debug gdbm minimal samba xfs"
+
+S="${WORKDIR}/${P/_/}"
+MYFILESDIR="${WORKDIR}/files"
+MYTMPDIR="${WORKDIR}/tmp"
+MYINSTTMPDIR="/usr/share/amanda"
+ENVDIR="/etc/env.d"
+ENVDFILE="97amanda"
+TMPENVFILE="${MYTMPDIR}/${ENVDFILE}"
+TMPINSTENVFILE="${MYINSTTMPDIR}/tmpenv-${ENVDFILE}"
+
+amanda_variable_setup() {
+
+ # Setting vars
+ local currentamanda
+
+ # Grab the current settings
+ currentamanda="$(set | egrep "^AMANDA_" | xargs)"
+ use debug && einfo "Current settings: ${currentamanda}"
+ #for i in ${currentamanda}; do
+ # eval `eval echo ${i}`
+ # echo "Setting: ${i}"
+ #done;
+
+ # First we set the defaults
+ [ -z "${AMANDA_GROUP_GID}" ] && AMANDA_GROUP_GID=87
+ [ -z "${AMANDA_GROUP_NAME}" ] && AMANDA_GROUP_NAME=amanda
+ [ -z "${AMANDA_USER_NAME}" ] && AMANDA_USER_NAME=amanda
+ [ -z "${AMANDA_USER_UID}" ] && AMANDA_USER_UID=87
+ [ -z "${AMANDA_USER_SH}" ] && AMANDA_USER_SH=-1
+ [ -z "${AMANDA_USER_HOMEDIR}" ] && AMANDA_USER_HOMEDIR=/var/spool/amanda
+ [ -z "${AMANDA_USER_GROUPS}" ] && AMANDA_USER_GROUPS="${AMANDA_GROUP_NAME}"
+ # This installs Amanda, with the server. However, it could be a client,
+ # just specify an alternate server name in AMANDA_SERVER.
+ [ -z "${AMANDA_SERVER}" ] && AMANDA_SERVER="${HOSTNAME}"
+ [ -z "${AMANDA_SERVER_TAPE}" ] && AMANDA_SERVER_TAPE="${AMANDA_SERVER}"
+ [ -z "${AMANDA_SERVER_INDEX}" ] && AMANDA_SERVER_INDEX="${AMANDA_SERVER}"
+ [ -z "${AMANDA_TAR_LISTDIR}" ] && AMANDA_TAR_LISTDIR=${AMANDA_USER_HOMEDIR}/tar-lists
+ [ -z "${AMANDA_CONFIG_NAME}" ] && AMANDA_CONFIG_NAME=DailySet1
+ [ -z "${AMANDA_TMPDIR}" ] && AMANDA_TMPDIR=${AMANDA_USER_HOMEDIR}/tmp
+ # These are left empty by default
+ [ -z "${AMANDA_PORTS_UDP}" ] && AMANDA_PORTS_UDP=
+ [ -z "${AMANDA_PORTS_TCP}" ] && AMANDA_PORTS_TCP=
+ [ -z "${AMANDA_PORTS_BOTH}" ] && AMANDA_PORTS_BOTH=
+ [ -z "${AMANDA_PORTS}" ] && AMANDA_PORTS=
+
+ # This one is a little more complicated
+ # The priority list is this:
+ # 1. 'Berkely DB style' (only if USE="berkdb")
+ # 2. 'GDBM style' (only if USE="gdbm")
+ # 3. 'Text style'
+ [ -z "${AMANDA_DBMODE}" ] && use berkdb && AMANDA_DBMODE=db
+ [ -z "${AMANDA_DBMODE}" ] && use gdbm && AMANDA_DBMODE=gdbm
+ [ -z "${AMANDA_DBMODE}" ] && AMANDA_DBMODE=text
+
+ # Now pull in the old stuff
+ if [ -f "${ENVDIR}/${ENVDFILE}" ]; then
+ # We don't just source it as we don't want everything in there.
+ eval $(egrep "^AMANDA_" ${ENVDIR}/${ENVDFILE})
+ fi
+
+ # Re-apply the new settings if any
+ [ -n "${currentamanda}" ] && eval `echo "${currentamanda}"`
+
+}
+
+pkg_setup() {
+ # Now add users if needed
+ amanda_variable_setup
+ enewgroup "${AMANDA_GROUP_NAME}" "${AMANDA_GROUP_GID}"
+ enewuser "${AMANDA_USER_NAME}" "${AMANDA_USER_UID}" "${AMANDA_USER_SH}" "${AMANDA_USER_HOMEDIR}" "${AMANDA_USER_GROUPS}"
+}
+
+src_unpack() {
+ unpack "${A}"
+ # Fix glitch with recognizing tar-1.14.90
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/patch-tar-1.14.90 || die "Failed to add tar support patch"
+
+ # now the real fun
+ amanda_variable_setup
+ # places for us to work in
+ mkdir -p "${MYFILESDIR}" "${MYTMPDIR}"
+ # Now we store the settings we just created
+ set | egrep "^AMANDA_" > "${TMPENVFILE}"
+}
+
+src_compile() {
+ # fix bug #36316
+ addpredict /var/cache/samba/gencache.tdb
+
+ [ ! -f "${TMPENVFILE}" ] && die "Variable setting file (${TMPENVFILE}) should exist!"
+ source "${TMPENVFILE}"
+ local myconf
+ cd ${S}
+
+ einfo "Using '${AMANDA_DBMODE}' style database"
+ myconf="${myconf} --with-db=${AMANDA_DBMODE}"
+ einfo "Using ${AMANDA_SERVER_TAPE} for tape server."
+ myconf="${myconf} --with-tape-server=${AMANDA_SERVER_TAPE}"
+ einfo "Using ${AMANDA_SERVER_INDEX} for index server."
+ myconf="${myconf} --with-index-server=${AMANDA_SERVER_TAPE}"
+ einfo "Using ${AMANDA_USER_NAME} for amanda user."
+ myconf="${myconf} --with-user=${AMANDA_USER_NAME}"
+ einfo "Using ${AMANDA_GROUP_NAME} for amanda group."
+ myconf="${myconf} --with-group=${AMANDA_GROUP_NAME}"
+ einfo "Using ${AMANDA_TAR_LISTDIR} as tar listdir."
+ myconf="${myconf} --with-gnutar-listdir=${AMANDA_TAR_LISTDIR}"
+ einfo "Using ${AMANDA_CONFIG_NAME} as default config name."
+ myconf="${myconf} --with-config=${AMANDA_CONFIG_NAME}"
+ einfo "Using ${AMANDA_TMPDIR} as Amanda temporary directory."
+ myconf="${myconf} --with-tmpdir=${AMANDA_TMPDIR}"
+
+ if [ -n "${AMANDA_PORTS_UDP}" ] && [ -n "${AMANDA_PORTS_TCP}" ] && [ -z "${AMANDA_PORTS_BOTH}" ] ; then
+ eerror "If you want _both_ UDP and TCP ports, please use only the"
+ eerror "AMANDA_PORTS environment variable for identical ports, or set"
+ eerror "AMANDA_PORTS_BOTH."
+ die "Bad port setup!"
+ fi
+ if [ -n "${AMANDA_PORTS_UDP}" ]; then
+ einfo "Using UDP ports ${AMANDA_PORTS_UDP/,/-}"
+ myconf="${myconf} --with-udpportrange=${AMANDA_PORTS_UDP}"
+ fi
+ if [ -n "${AMANDA_PORTS_TCP}" ]; then
+ einfo "Using TCP ports ${AMANDA_PORTS_TCP/,/-}"
+ myconf="${myconf} --with-tcpportrange=${AMANDA_PORTS_TCP}"
+ fi
+ if [ -n "${AMANDA_PORTS}" ]; then
+ einfo "Using ports ${AMANDA_PORTS/,/-}"
+ myconf="${myconf} --with-portrange=${AMANDA_PORTS}"
+ fi
+
+ # Extras
+ # Speed option
+ myconf="${myconf} --with-buffered-dump"
+ # Debug
+ myconf="${myconf} `use_with debug debugging`"
+ # Where to put our files
+ myconf="${myconf} --localstatedir=${AMANDA_USER_HOMEDIR}"
+
+ # Samba support
+ use samba && myconf="${myconf} --with-smbclient=/usr/bin/smbclient" || myconf="${myconf} --without-smbclient"
+
+ # Force the correct TAR
+ myconf="${myconf} --with-gnutar=/bin/tar"
+
+ # Client only, as requested in bug #127725
+ use minimal && myconf="${myconf} --without-server"
+
+ econf ${myconf} || die "econf failed!"
+ emake -j1 || die "emake failed!"
+
+ # Compile the tapetype program too
+ # This is deprecated, use amtapetype instead!
+ # cd tape-src
+ # emake tapetype || die "emake tapetype failed!"
+
+ # Only needed if you we do versioning
+ #dosed "s,/usr/local/bin/perl,/usr/bin/perl," ${S}/contrib/set_prod_link.pl
+ #perl ${S}/contrib/set_prod_link.pl
+
+}
+
+src_install() {
+ [ ! -f "${TMPENVFILE}" ] && die "Variable setting file (${TMPENVFILE}) should exist!"
+ source ${TMPENVFILE}
+
+ einfo "Doing stock install"
+ make DESTDIR=${D} install || die
+
+ # Prepare our custom files
+ einfo "Building custom configuration files"
+ cp ${FILESDIR}/amanda-* ${MYFILESDIR}
+ local i # our iterator
+ local sedexpr # var for sed expr
+ sedexpr=''
+ for i in AMANDA_GROUP_GID AMANDA_GROUP_NAME AMANDA_USER_NAME AMANDA_USER_UID AMANDA_USER_SH AMANDA_USER_HOMEDIR AMANDA_USER_GROUPS AMANDA_SERVER AMANDA_SERVER_TAPE AMANDA_SERVER_INDEX AMANDA_TAR_LISTDIR AMANDA_CONFIG_NAME AMANDA_TMPDIR AMANDA_PORTS_UDP AMANDA_PORTS_TCP AMANDA_PORTS_BOTH AMANDA_PORTS; do
+ local val
+ eval "val=\"\${${i}}\""
+ sedexpr="${sedexpr}s|__${i}__|${val}|g;"
+ done
+ #einfo "Compiled SED expression: '${sedexpr}'"
+
+ # now apply the sed expr
+ for i in "${FILESDIR}"/amanda-* ; do
+ local filename
+ filename=`basename ${i}`
+ #einfo "Applying compiled SED expression to ${filename}"
+ sed -re "${sedexpr}" <${i} >"${MYFILESDIR}/${filename}"
+ done
+
+
+
+ # Build the envdir file
+ # Don't forget this..
+ einfo "Building environment file"
+ echo "# These settings are what was present in the environment when this" >>${MYFILESDIR}/${ENVDFILE}
+ echo "# Amanda was compiled. Changing anything below this comment will" >>${MYFILESDIR}/${ENVDFILE}
+ echo "# have no effect on your application, but it merely exists to" >>${MYFILESDIR}/${ENVDFILE}
+ echo "# preserve them for your next emerge of Amanda" >>${MYFILESDIR}/${ENVDFILE}
+ cat ${TMPENVFILE} | sed "s,=\$,='',g" >>${MYFILESDIR}/${ENVDFILE}
+
+ into /usr
+
+ # Depreacted, use amtapetype instead
+ #einfo "Installing tapetype utility"
+ #newsbin tape-src/tapetype tapetype
+
+ # docs
+ einfo "Installing documentation"
+ dodoc AUTHORS C* INSTALL NEWS README
+ # Clean up some bits
+ dodoc /usr/share/amanda/*
+ rm -rf ${D}/usr/share/amanda
+ mkdir -p ${D}/${MYINSTTMPDIR} || die
+ cp ${TMPENVFILE} "${D}/${TMPINSTENVFILE}" || die
+ # our inetd sample
+ einfo "Installing standard inetd sample"
+ dodoc ${MYFILESDIR}/amanda-inetd.amanda.sample
+ # Stock extra docs
+ docinto docs
+ dodoc ${S}/docs/*
+ # Labels
+ einfo "Installing labels"
+ docinto labels
+ dodoc ${S}/example/3hole.ps
+ dodoc ${S}/example/8.5x11.ps
+ dodoc ${S}/example/DIN-A4.ps
+ dodoc ${S}/example/DLT.ps
+ dodoc ${S}/example/EXB-8500.ps
+ dodoc ${S}/example/HP-DAT.ps
+ # Amanda example configs
+ einfo "Installing example configurations"
+ docinto example
+ dodoc ${S}/example/*
+ docinto example1
+ newdoc ${FILESDIR}/example_amanda.conf amanda.conf
+ newdoc ${FILESDIR}/example_disklist disklist
+ newdoc ${FILESDIR}/example_global.conf global.conf
+ docinto example2
+ newdoc ${S}/example/amanda.conf amanda.conf
+ newdoc ${S}/example/disklist disklist
+ # Compress it all
+ prepalldocs
+
+ # Just make sure it exists for XFS to work...
+ use !sparc && use xfs && keepdir /var/xfsdump/inventory
+
+ insinto /etc/amanda
+ einfo "Installing .amandahosts File for ${AMANDA_USER_NAME} user"
+ newins ${MYFILESDIR}/amanda-amandahosts amandahosts
+ dosym /etc/amanda/amandahosts ${AMANDA_USER_HOMEDIR}/.amandahosts
+ insinto ${AMANDA_USER_HOMEDIR}
+ einfo "Installing .profile for ${AMANDA_USER_NAME} user"
+ newins ${MYFILESDIR}/amanda-profile .profile
+
+ einfo "Installing Sample Daily Cron Job for Amanda"
+ CRONDIR=/etc/cron.daily/
+ exeinto ${CRONDIR}
+ newexe ${MYFILESDIR}/amanda-cron amanda
+ # Not excetuable by default
+ fperms 644 ${CRONDIR}/amanda
+
+ insinto /etc/amanda/${AMANDA_CONFIG_NAME}
+ keepdir /etc/amanda
+ keepdir /etc/amanda/${AMANDA_CONFIG_NAME}
+
+ local i
+ for i in ${AMANDA_USER_HOMEDIR} ${AMANDA_TAR_LISTDIR} ${AMANDA_TMPDIR} ${AMANDA_TMPDIR}/dumps ${AMANDA_USER_HOMEDIR}/${AMANDA_CONFIG_NAME} /etc/amanda /etc/amanda/${AMANDA_CONFIG_NAME}; do
+ einfo "Securing directory (${i})"
+ dodir ${i}
+ keepdir ${i}
+ fowners ${AMANDA_USER_NAME}:${AMANDA_GROUP_NAME} ${i}
+ fperms 700 ${i}
+ done
+
+ # DevFS
+ einfo "Installing DevFS config file"
+ insinto /etc/devfs.d
+ newins ${MYFILESDIR}/amanda-devfs amanda
+
+ # Env.d
+ einfo "Installing environment config file"
+ insinto /etc/env.d
+ doins ${MYFILESDIR}/${ENVDFILE}
+
+ # Installing Amanda Xinetd Services Definition
+ einfo "Installing xinetd service file"
+ insinto /etc/xinetd.d
+ newins ${MYFILESDIR}/amanda-xinetd amanda
+
+}
+
+pkg_postinst() {
+ local aux="${ROOT}/${TMPINSTENVFILE}"
+ [ ! -f "${aux}" ] && die "Variable setting file (${aux}) should exist!"
+ source "${aux}"
+ rm "${aux}"
+ rmdir ${ROOT}/${MYINSTTMPDIR} 2>/dev/null # ignore error
+
+ local i
+ for i in amandates dumpdates; do
+ einfo "Creating inital Amanda file (${i})"
+ touch ${ROOT}/etc/${i}
+ chown ${AMANDA_USER_NAME}:${AMANDA_GROUP_NAME} ${ROOT}/etc/${i}
+ chmod 600 ${ROOT}/etc/${i}
+ done
+
+ elog "You should configure Amanda in /etc/amanda now."
+ elog
+ elog "If you use xinetd, Don't forget to check /etc/xinetd.d/amanda"
+ elog "and restart xinetd afterwards!"
+ elog
+ elog "Otherwise, please look at /usr/share/doc/${P}/inetd.amanda.sample"
+ elog "as an example of how to configure your inetd."
+ elog
+ elog "NOTICE: If you need raw acces to partitions you need to add the"
+ elog "amanda user to the 'disk' group and uncomment following lines in"
+ elog "your /etc/devfs.d/amanda:"
+ elog "SCSI:"
+ elog "REGISTER ^scsi/host.*/bus.*/target.*/lun.*/part[0-9] PERMISSIONS root.disk 660"
+ elog "IDE:"
+ elog "REGISTER ^ide/host.*/bus.*/target.*/lun.*/part[0-9] PERMISSIONS root.disk 660"
+ elog
+ elog "NOTICE: If you have a tape changer, also uncomment the following"
+ elog "REGISTER ^scsi/host.*/bus.*/target.*/lun.*/generic PERMISSIONS root.disk 660"
+}
diff --git a/app-backup/amanda/files/digest-amanda-2.5.1_p3 b/app-backup/amanda/files/digest-amanda-2.5.1_p3
new file mode 100644
index 000000000000..9c0687c0c6d0
--- /dev/null
+++ b/app-backup/amanda/files/digest-amanda-2.5.1_p3
@@ -0,0 +1,3 @@
+MD5 7232da6d43543f2c7dac2ded21c65ee9 amanda-2.5.1p3.tar.gz 1905664
+RMD160 90462c7d65736c5920bc2782e8666a34b3f32026 amanda-2.5.1p3.tar.gz 1905664
+SHA256 64e60f323a89a8a064936334335cfde6cf41e6127f7f8b1c9b6de2d393de3f72 amanda-2.5.1p3.tar.gz 1905664