summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2007-02-28 14:40:44 +0000
committerWolfram Schlich <wschlich@gentoo.org>2007-02-28 14:40:44 +0000
commit9ac663874cda8d3afa7d3dffab19276b8e022f60 (patch)
tree81e6233723908472e151a9f66cd49d0adc8ea0de /app-backup
parentFix quoting, bug #168723 (diff)
downloadgentoo-2-9ac663874cda8d3afa7d3dffab19276b8e022f60.tar.gz
gentoo-2-9ac663874cda8d3afa7d3dffab19276b8e022f60.tar.bz2
gentoo-2-9ac663874cda8d3afa7d3dffab19276b8e022f60.zip
version bump
(Portage version: 2.1.2)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/bacula/ChangeLog12
-rw-r--r--app-backup/bacula/bacula-2.0.2.ebuild336
-rw-r--r--app-backup/bacula/files/2.0.2/bacula-all-conf23
-rw-r--r--app-backup/bacula/files/2.0.2/bacula-all-init71
-rw-r--r--app-backup/bacula/files/2.0.2/bacula-dir-conf15
-rw-r--r--app-backup/bacula/files/2.0.2/bacula-dir-init25
-rw-r--r--app-backup/bacula/files/2.0.2/bacula-fd-conf8
-rw-r--r--app-backup/bacula/files/2.0.2/bacula-fd-init22
-rw-r--r--app-backup/bacula/files/2.0.2/bacula-sd-conf11
-rw-r--r--app-backup/bacula/files/2.0.2/bacula-sd-init22
-rw-r--r--app-backup/bacula/files/bacula-2.0.2-default-configs.patch110
-rw-r--r--app-backup/bacula/files/digest-bacula-2.0.26
12 files changed, 660 insertions, 1 deletions
diff --git a/app-backup/bacula/ChangeLog b/app-backup/bacula/ChangeLog
index 2326b42a6dd7..48b9d7fd6250 100644
--- a/app-backup/bacula/ChangeLog
+++ b/app-backup/bacula/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-backup/bacula
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/ChangeLog,v 1.21 2007/02/15 11:14:56 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/ChangeLog,v 1.22 2007/02/28 14:40:44 wschlich Exp $
+
+*bacula-2.0.2 (28 Feb 2007)
+
+ 28 Feb 2007; Wolfram Schlich <wschlich@gentoo.org>
+ +files/2.0.2/bacula-all-conf, +files/2.0.2/bacula-dir-conf,
+ +files/2.0.2/bacula-fd-conf, +files/bacula-2.0.2-default-configs.patch,
+ +files/2.0.2/bacula-all-init, +files/2.0.2/bacula-dir-init,
+ +files/2.0.2/bacula-fd-init, +files/2.0.2/bacula-sd-conf,
+ +files/2.0.2/bacula-sd-init, +bacula-2.0.2.ebuild:
+ version bump
15 Feb 2007; Daniel Black <dragonheart@gentoo.org>
bacula-1.36.3-r3.ebuild, bacula-1.38.5.ebuild, bacula-1.38.9.ebuild:
diff --git a/app-backup/bacula/bacula-2.0.2.ebuild b/app-backup/bacula/bacula-2.0.2.ebuild
new file mode 100644
index 000000000000..8681d203b52e
--- /dev/null
+++ b/app-backup/bacula/bacula-2.0.2.ebuild
@@ -0,0 +1,336 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/bacula-2.0.2.ebuild,v 1.1 2007/02/28 14:40:44 wschlich Exp $
+
+#
+# TODO:
+# - install stuff from examples/:
+# - examples/nagios/ + add nagios USE flag etc.
+# (see also example/reports/check_bacula_pools.sh which is newer
+# than examples/nagios/check_bacula_pools.sh)
+# - examples/autochangers/
+# - examples/devices/
+# - examples/python/
+# - examples/reports/baculareport.pl
+# - correctly filter unneeded /usr/libexec/bacula/ stuff depending
+# on selected USE flags, e.g. bacula-clientonly
+#
+
+inherit eutils
+
+IUSE="bacula-clientonly bacula-console bacula-nodir bacula-nosd bacula-split-init doc gnome logrotate logwatch mysql postgres python readline sqlite sqlite3 ssl static tcpd wxwindows X"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+DESCRIPTION="Featureful client/server network backup suite"
+HOMEPAGE="http://www.bacula.org/"
+
+DOC_VER="${PV}"
+SRC_URI="mirror://sourceforge/bacula/${P}.tar.gz
+ doc? ( mirror://sourceforge/bacula/${PN}-docs-${DOC_VER}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="
+ >=sys-libs/zlib-1.1.4
+ dev-libs/gmp
+ !bacula-clientonly? (
+ postgres? ( >=dev-db/postgresql-7.4.0 )
+ mysql? ( virtual/mysql )
+ sqlite? ( =dev-db/sqlite-2* )
+ sqlite3? ( >=dev-db/sqlite-3.0.0 )
+ virtual/mta
+ )
+ bacula-console? (
+ wxwindows? ( >=x11-libs/wxGTK-2.4.2 )
+ gnome? (
+ >=gnome-base/libgnome-2
+ app-admin/gnomesu
+ )
+ )
+ ssl? ( dev-libs/openssl )
+ logrotate? ( app-admin/logrotate )
+ logwatch? ( sys-apps/logwatch )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ readline? ( >=sys-libs/readline-4.1 )"
+RDEPEND="${DEPEND}
+ !bacula-clientonly? (
+ sys-block/mtx
+ app-arch/mt-st
+ )"
+
+pkg_setup() {
+ local dbnum
+ declare -i dbnum=0
+ if ! useq bacula-clientonly; then
+ if useq mysql; then
+ export mydbtype='mysql'
+ let dbnum++
+ fi
+ if useq postgres; then
+ export mydbtype='postgresql'
+ let dbnum++
+ fi
+ if useq sqlite; then
+ export mydbtype='sqlite'
+ let dbnum++
+ fi
+ if useq sqlite3; then
+ export mydbtype='sqlite3'
+ let dbnum++
+ fi
+ if [[ "${dbnum}" -lt 1 ]]; then
+ eerror
+ eerror "To use ${P} it is required to set a database in the USE flags."
+ eerror "Supported databases are mysql, postgresql, sqlite, sqlite3"
+ eerror
+ die "No database type selected."
+ elif [[ "${dbnum}" -gt 1 ]]; then
+ eerror
+ eerror "You have set ${P} to use multiple database types."
+ eerror "I don't know which to set as the default!"
+ eerror "You can use /etc/portage/package.use to set per-package USE flags"
+ eerror "Set it so only one database type, mysql, postgres, sqlite, sqlite3"
+ eerror
+ die "Multiple database types selected."
+ fi
+ fi
+
+ # create the daemon group and user
+ if [ -z "$(egetent group bacula)" ]; then
+ enewgroup bacula
+ einfo
+ einfo "The group 'bacula' has been created. Any users you add to this"
+ einfo "group have access to files created by the daemons."
+ einfo
+ fi
+ if ! useq bacula-clientonly; then
+ if [ -z "$(egetent passwd bacula)" ]; then
+ enewuser bacula -1 -1 /var/lib/bacula bacula,disk,tape,cdrom,cdrw
+ einfo
+ einfo "The user 'bacula' has been created. Please see the bacula manual"
+ einfo "for information about running bacula as a non-root user."
+ einfo
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # adjusts default configuration files for several binaries
+ # to /etc/bacula/<config> instead of ./<config>
+ pushd src && epatch "${FILESDIR}/${P}"-default-configs.patch && popd
+}
+
+src_compile() {
+ local myconf=''
+
+ if useq bacula-clientonly; then
+ myconf="${myconf} \
+ $(use_enable bacula-clientonly client-only) \
+ $(use_enable static static-fd)"
+ else
+ myconf="${myconf} \
+ $(use_with ${mydbtype}) \
+ $(use_enable static static-tools) \
+ $(use_enable static static-fd) \
+ $(use_enable !bacula-nodir build-dird) \
+ $(use_enable !bacula-nosd build-stored)"
+ if ! useq bacula-nodir; then
+ myconf="${myconf} $(use_enable static static-dir)"
+ fi
+ if ! useq bacula-nosd; then
+ myconf="${myconf} $(use_enable static static-sd)"
+ fi
+
+ fi
+
+ if useq bacula-console; then
+ myconf="${myconf} \
+ $(use_with X x) \
+ $(use_enable gnome) \
+ $(use_enable gnome tray-monitor) \
+ $(use_enable wxwindows wx-console) \
+ $(use_enable static static-cons)"
+ fi
+
+ myconf="${myconf} \
+ $(use_with python) \
+ $(use_with readline) \
+ $(use_with ssl openssl) \
+ $(use_with tcpd tcp-wrappers)"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-pid-dir=/var/run \
+ --sysconfdir=/etc/bacula \
+ --infodir=/usr/share/info \
+ --with-subsys-dir=/var/lock/subsys \
+ --with-working-dir=/var/lib/bacula \
+ --with-scriptdir=/usr/libexec/bacula \
+ --with-dir-user=bacula \
+ --with-dir-group=bacula \
+ --with-sd-user=root \
+ --with-sd-group=bacula \
+ --with-fd-user=root \
+ --with-fd-group=bacula \
+ --enable-smartalloc \
+ --host=${CHOST} \
+ ${myconf} \
+ || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # remove some scripts we don't need at all
+ rm -f "${D}"/usr/libexec/bacula/{bacula,bacula-ctl-dir,bacula-ctl-fd,bacula-ctl-sd,startmysql,stopmysql}
+
+ # rename statically linked apps
+ if useq static; then
+ pushd "${D}"/usr/sbin
+ mv static-bacula-fd bacula-fd
+ mv static-bconsole bconsole
+ if ! useq bacula-clientonly; then
+ mv static-bacula-dir bacula-dir
+ mv static-bacula-sd bacula-sd
+ fi
+ if useq gnome; then
+ mv static-gnome-console gnome-console
+ fi
+ popd
+ fi
+
+ # gnome menu files
+ if useq bacula-console && useq gnome; then
+ emake DESTDIR="${D}" \
+ install-menu \
+ install-menu-xsu || die "Failed to install gnome menu files" \
+ make_desktop_entry \
+ "gnome-console -c /etc/bacula/gnome-console.conf" \
+ "Bacula Console" /usr/share/pixmaps/bacula.png "app-admin" \
+ "/usr/sbin"
+ fi
+
+ # extra files which 'make install' doesn't cover
+ if ! useq bacula-clientonly; then
+ # the database update scripts
+ diropts -m0750
+ dodir /usr/libexec/bacula/updatedb
+ insinto /usr/libexec/bacula/updatedb/
+ insopts -m0754
+ doins "${S}"/updatedb/*
+ fperms 0640 /usr/libexec/bacula/updatedb/README
+
+ # the logrotate configuration
+ if useq logrotate; then
+ diropts -m0755
+ dodir /etc/logrotate.d
+ insinto /etc/logrotate.d
+ insopts -m0644
+ newins "${S}"/scripts/logrotate bacula
+ fi
+
+ # the logwatch scripts
+ if useq logwatch; then
+ diropts -m0750
+ dodir /etc/log.d/scripts/services
+ dodir /etc/log.d/conf/logfiles
+ dodir /etc/log.d/conf/services
+ cd "${S}"/scripts/logwatch
+ emake DESTDIR="${D}" install || die "Failed to install logwatch scripts"
+ cd "${S}"
+ fi
+ fi
+
+ # documentation
+ for d in "${S}"/{ChangeLog,LICENSE,README,ReleaseNotes,SUPPORT,kernstodo,projects}; do
+ dodoc "${d}"
+ done
+ if useq doc; then
+ dodoc "${WORKDIR}/${PN}-docs-${DOC_VER}"/developers/developers.pdf
+ dodoc "${WORKDIR}/${PN}-docs-${DOC_VER}"/manual/bacula.pdf
+ diropts -m0755
+ dodir /usr/share/doc/"${PF}"/developers
+ dodir /usr/share/doc/"${PF}"/manual
+ insopts -m0644
+ insinto /usr/share/doc/"${PF}"/developers
+ doins "${WORKDIR}/${PN}-docs-${DOC_VER}"/developers/developers/*
+ insinto /usr/share/doc/"${PF}"/manual
+ doins "${WORKDIR}/${PN}-docs-${DOC_VER}"/manual/bacula/*
+ fi
+ prepall
+
+ # setup init scripts
+ myservices="fd"
+ if ! useq bacula-clientonly; then
+ if ! useq bacula-nodir; then
+ myservices="${myservices} dir"
+ fi
+ if ! useq bacula-nosd; then
+ myservices="${myservices} sd"
+ fi
+ fi
+ exeinto /etc/init.d/
+ insinto /etc/conf.d/
+ if useq bacula-split-init; then
+ myscripts=""
+ for service in ${myservices}; do
+ myscripts="${myscripts} bacula-${service}"
+ done
+ else
+ myscripts="bacula-all"
+ fi
+ for script in ${myscripts}; do
+ # copy over init script and config to a temporary location
+ # so we can modify them as needed
+ cp "${FILESDIR}/${PV}/${script}"-conf "${T}/${script}".conf
+ cp "${FILESDIR}/${PV}/${script}"-init "${T}/${script}".init
+ # set database dependancy for the all-in-one and director init scripts
+ case "${mydbtype}" in
+ sqlite*)
+ # sqlite + sqlite3 databases don't have daemons
+ sed -i -e "s:%database%::" "${T}/${script}".init
+ ;;
+ *)
+ # all other databases have daemons
+ sed -i -e "s:%database%:${mydbtype}:" "${T}/${script}".init
+ ;;
+ esac
+ # set services for the all-in-one init script
+ sed -i -e "s:%services%:${myservices}:" "${T}/${script}".conf
+ # install init script and config
+ newexe "${T}/${script}".init "${script}"
+ newins "${T}/${script}".conf "${script}"
+ done
+
+ # make sure the working directory exists
+ diropts -m0750
+ keepdir /var/lib/bacula
+}
+
+pkg_postinst() {
+ if useq bacula-clientonly; then
+ fowners root:bacula /var/lib/bacula
+ else
+ fowners bacula:bacula /var/lib/bacula
+ fi
+
+ if ! useq bacula-clientonly && ! useq bacula-nodir; then
+ einfo
+ einfo "If this is a new install, you must create the ${mydbtype} databases with:"
+ einfo " /usr/libexec/bacula/create_${mydbtype}_database"
+ einfo " /usr/libexec/bacula/make_${mydbtype}_tables"
+ einfo " /usr/libexec/bacula/grant_${mydbtype}_privileges"
+ einfo
+ einfo "If you're upgrading from a major release, you must upgrade your bacula catalog database."
+ einfo "Please read the manual chapter for how to upgrade your database."
+ einfo "You can find database upgrade scripts in /usr/libexec/bacula/updatedb."
+ einfo
+ fi
+}
diff --git a/app-backup/bacula/files/2.0.2/bacula-all-conf b/app-backup/bacula/files/2.0.2/bacula-all-conf
new file mode 100644
index 000000000000..32c19ef6cbe8
--- /dev/null
+++ b/app-backup/bacula/files/2.0.2/bacula-all-conf
@@ -0,0 +1,23 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/files/2.0.2/bacula-all-conf,v 1.1 2007/02/28 14:40:44 wschlich Exp $
+
+# Config file for /etc/init.d/bacula
+
+# Add the daemons you want to run:
+# dir - Director (Master Control Program)
+# fd - File Daemon (Client)
+# sd - Storage Daemon
+SERVICES="%services%"
+
+# If the database server where you store your bacula catalog
+# is on a different machine, please set this to 0.
+LOCAL_DB=1
+
+# Options for each daemon.
+# The DIR and SD can be run as a non-root user, however
+# please ensure that this user has proper permissions to
+# access your backup devices.
+SD_OPTIONS="-u root -g bacula -c /etc/bacula/bacula-sd.conf"
+FD_OPTIONS="-u root -g bacula -c /etc/bacula/bacula-fd.conf"
+DIR_OPTIONS="-u root -g bacula -c /etc/bacula/bacula-dir.conf"
diff --git a/app-backup/bacula/files/2.0.2/bacula-all-init b/app-backup/bacula/files/2.0.2/bacula-all-init
new file mode 100644
index 000000000000..b510d13fb1c0
--- /dev/null
+++ b/app-backup/bacula/files/2.0.2/bacula-all-init
@@ -0,0 +1,71 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/files/2.0.2/bacula-all-init,v 1.1 2007/02/28 14:40:44 wschlich Exp $
+
+depend() {
+ need net
+ if [ ${LOCAL_DB} -eq 1 ]; then
+ need "%database%"
+ fi
+ use dns
+}
+
+start() {
+ local retval
+ declare -i retval=0
+ for s in ${SERVICES} ; do
+ case ${s} in
+ sd)
+ ebegin "Starting bacula storage daemon"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-sd \
+ -- ${SD_OPTIONS}
+ let retval+=$?
+ ;;
+ fd)
+ ebegin "Starting bacula file daemon"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-fd \
+ -- ${FD_OPTIONS}
+ let retval+=$?
+ ;;
+ dir)
+ ebegin "Starting bacula director"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-dir \
+ -- ${DIR_OPTIONS}
+ let retval+=$?
+ ;;
+ *)
+ eerror "Unrecognized service found in SERVICES: '${s}'"
+ ;;
+ esac
+ done
+ eend ${retval}
+}
+
+stop() {
+ local retval
+ declare -i retval=0
+ for s in ${SERVICES} ; do
+ case ${s} in
+ sd)
+ ebegin "Stopping bacula storage daemon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-sd.*.pid
+ let retval+=$?
+ ;;
+ fd)
+ ebegin "Stopping bacula file daemon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-fd.*.pid
+ let retval+=$?
+ ;;
+ dir)
+ ebegin "Stopping bacula director"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-dir.*.pid
+ let retval+=$?
+ ;;
+ *)
+ eerror "Unrecognized service found in SERVICES: '${s}'"
+ ;;
+ esac
+ done
+ eend ${retval}
+}
diff --git a/app-backup/bacula/files/2.0.2/bacula-dir-conf b/app-backup/bacula/files/2.0.2/bacula-dir-conf
new file mode 100644
index 000000000000..20631aea798e
--- /dev/null
+++ b/app-backup/bacula/files/2.0.2/bacula-dir-conf
@@ -0,0 +1,15 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/files/2.0.2/bacula-dir-conf,v 1.1 2007/02/28 14:40:44 wschlich Exp $
+
+# Config file for /etc/init.d/bacula-dir
+
+# If the database server where you store your bacula catalog
+# is on a different machine, please set this to 0.
+LOCAL_DB=1
+
+# Options for the director daemon.
+# The DIR can be run as a non-root user, however
+# please ensure that this user has proper permissions to
+# access your backup devices.
+DIR_OPTIONS="-u root -g bacula -c /etc/bacula/bacula-dir.conf"
diff --git a/app-backup/bacula/files/2.0.2/bacula-dir-init b/app-backup/bacula/files/2.0.2/bacula-dir-init
new file mode 100644
index 000000000000..ed111a3e3ea4
--- /dev/null
+++ b/app-backup/bacula/files/2.0.2/bacula-dir-init
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/files/2.0.2/bacula-dir-init,v 1.1 2007/02/28 14:40:44 wschlich Exp $
+
+depend() {
+ need net
+ if [ ${LOCAL_DB} -eq 1 ]; then
+ need "%database%"
+ fi
+ use dns
+}
+
+start() {
+ ebegin "Starting bacula director"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-dir \
+ -- ${DIR_OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping bacula director"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-dir.*.pid
+ eend $?
+}
diff --git a/app-backup/bacula/files/2.0.2/bacula-fd-conf b/app-backup/bacula/files/2.0.2/bacula-fd-conf
new file mode 100644
index 000000000000..a8f37b99c8e2
--- /dev/null
+++ b/app-backup/bacula/files/2.0.2/bacula-fd-conf
@@ -0,0 +1,8 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/files/2.0.2/bacula-fd-conf,v 1.1 2007/02/28 14:40:44 wschlich Exp $
+
+# Config file for /etc/init.d/bacula-fd
+
+# Options for the file director.
+FD_OPTIONS="-u root -g bacula -c /etc/bacula/bacula-fd.conf"
diff --git a/app-backup/bacula/files/2.0.2/bacula-fd-init b/app-backup/bacula/files/2.0.2/bacula-fd-init
new file mode 100644
index 000000000000..fa2c3e6e8e78
--- /dev/null
+++ b/app-backup/bacula/files/2.0.2/bacula-fd-init
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/files/2.0.2/bacula-fd-init,v 1.1 2007/02/28 14:40:44 wschlich Exp $
+
+depend() {
+ need net
+ use dns
+}
+
+start() {
+ ebegin "Starting bacula file daemon"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-fd \
+ -- ${FD_OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping bacula file daemon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-fd.*.pid
+ eend $?
+}
diff --git a/app-backup/bacula/files/2.0.2/bacula-sd-conf b/app-backup/bacula/files/2.0.2/bacula-sd-conf
new file mode 100644
index 000000000000..47b9dcca22a7
--- /dev/null
+++ b/app-backup/bacula/files/2.0.2/bacula-sd-conf
@@ -0,0 +1,11 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/files/2.0.2/bacula-sd-conf,v 1.1 2007/02/28 14:40:44 wschlich Exp $
+
+# Config file for /etc/init.d/bacula-sd
+
+# Options for the storage daemon.
+# The SD can be run as a non-root user, however
+# please ensure that this user has proper permissions to
+# access your backup devices.
+SD_OPTIONS="-u root -g bacula -c /etc/bacula/bacula-sd.conf"
diff --git a/app-backup/bacula/files/2.0.2/bacula-sd-init b/app-backup/bacula/files/2.0.2/bacula-sd-init
new file mode 100644
index 000000000000..f89f9cf33b7f
--- /dev/null
+++ b/app-backup/bacula/files/2.0.2/bacula-sd-init
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/files/2.0.2/bacula-sd-init,v 1.1 2007/02/28 14:40:44 wschlich Exp $
+
+depend() {
+ need net
+ use dns
+}
+
+start() {
+ ebegin "Starting bacula storage daemon"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-sd \
+ -- ${SD_OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping bacula storage daemon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-sd.*.pid
+ eend $?
+}
diff --git a/app-backup/bacula/files/bacula-2.0.2-default-configs.patch b/app-backup/bacula/files/bacula-2.0.2-default-configs.patch
new file mode 100644
index 000000000000..9f699b8cb595
--- /dev/null
+++ b/app-backup/bacula/files/bacula-2.0.2-default-configs.patch
@@ -0,0 +1,110 @@
+--- stored/bcopy.c 2006-11-27 05:03:01.000000000 -0500
++++ stored/bcopy.c 2007-01-11 21:14:58.883253250 -0500
+@@ -57,7 +57,7 @@
+ static uint32_t jobs = 0;
+ static DEV_BLOCK *out_block;
+
+-#define CONFIG_FILE "bacula-sd.conf"
++#define CONFIG_FILE "/etc/bacula/bacula-sd.conf"
+ char *configfile = NULL;
+ STORES *me = NULL; /* our Global resource */
+ bool forge_on = false; /* proceed inspite of I/O errors */
+--- stored/bextract.c 2006-12-01 03:45:13.000000000 -0500
++++ stored/bextract.c 2007-01-11 21:13:33.333906750 -0500
+@@ -64,7 +64,7 @@
+ static uint32_t wsize; /* write size */
+ static uint64_t fileAddr = 0; /* file write address */
+
+-#define CONFIG_FILE "bacula-sd.conf"
++#define CONFIG_FILE "/etc/bacula/bacula-sd.conf"
+ char *configfile = NULL;
+ STORES *me = NULL; /* our Global resource */
+ bool forge_on = false;
+--- stored/bls.c 2006-12-13 14:42:12.000000000 -0500
++++ stored/bls.c 2007-01-11 21:13:47.850814000 -0500
+@@ -59,7 +59,7 @@
+ static uint32_t num_files = 0;
+ static ATTR *attr;
+
+-#define CONFIG_FILE "bacula-sd.conf"
++#define CONFIG_FILE "/etc/bacula/bacula-sd.conf"
+ char *configfile = NULL;
+ STORES *me = NULL; /* our Global resource */
+ bool forge_on = false;
+--- stored/bscan.c 2006-12-01 03:45:13.000000000 -0500
++++ stored/bscan.c 2007-01-11 21:14:05.375909250 -0500
+@@ -100,7 +100,7 @@
+ static int num_media = 0;
+ static int num_files = 0;
+
+-#define CONFIG_FILE "bacula-sd.conf"
++#define CONFIG_FILE "/etc/bacula/bacula-sd.conf"
+ char *configfile = NULL;
+ STORES *me = NULL; /* our Global resource */
+ bool forge_on = false; /* proceed inspite of I/O errors */
+--- stored/btape.c 2006-12-14 06:41:00.000000000 -0500
++++ stored/btape.c 2007-01-11 21:14:29.265402250 -0500
+@@ -98,7 +98,7 @@
+
+
+ /* Static variables */
+-#define CONFIG_FILE "bacula-sd.conf"
++#define CONFIG_FILE "/etc/bacula/bacula-sd.conf"
+ char *configfile = NULL;
+
+ #define MAX_CMD_ARGS 30
+--- tray-monitor/tray-monitor.c 2006-12-01 03:45:14.000000000 -0500
++++ tray-monitor/tray-monitor.c 2007-01-11 21:17:29.828686750 -0500
+@@ -101,7 +101,7 @@
+ char** xpm_generic_var;
+ static gboolean blinkstate = TRUE;
+
+-#define CONFIG_FILE "./tray-monitor.conf" /* default configuration file */
++#define CONFIG_FILE "/etc/bacula/tray-monitor.conf" /* default configuration file */
+
+ static void usage()
+ {
+--- dird/dird.c 2006-12-22 10:01:05.000000000 -0500
++++ dird/dird.c 2007-01-11 21:18:16.255588250 -0500
+@@ -83,7 +83,7 @@
+ extern URES res_all;
+ #endif
+
+-#define CONFIG_FILE "bacula-dir.conf" /* default configuration file */
++#define CONFIG_FILE "/etc/bacula/bacula-dir.conf" /* default configuration file */
+
+ static void usage()
+ {
+--- console/console.c 2006-11-27 05:02:59.000000000 -0500
++++ console/console.c 2007-01-11 21:18:36.580858500 -0500
+@@ -104,7 +104,7 @@
+ static int sleepcmd(FILE *input, BSOCK *UA_sock);
+
+
+-#define CONFIG_FILE "bconsole.conf" /* default configuration file */
++#define CONFIG_FILE "/etc/bacula/bconsole.conf" /* default configuration file */
+
+ static void usage()
+ {
+--- gnome2-console/console.c 2006-12-08 09:27:10.000000000 -0500
++++ gnome2-console/console.c 2007-01-11 21:19:17.287402500 -0500
+@@ -93,7 +93,7 @@
+ static guint initial;
+ static int numdir = 0;
+
+-#define CONFIG_FILE "./gnome-console.conf" /* default configuration file */
++#define CONFIG_FILE "/etc/bacula/gnome-console.conf" /* default configuration file */
+
+ static void usage()
+ {
+--- filed/filed.c 2006-11-27 05:03:00.000000000 -0500
++++ filed/filed.c 2007-01-11 21:20:13.722929500 -0500
+@@ -49,7 +49,7 @@
+ bool no_signals = false;
+
+
+-#define CONFIG_FILE "bacula-fd.conf" /* default config file */
++#define CONFIG_FILE "/etc/bacula/bacula-fd.conf" /* default config file */
+
+ char *configfile = NULL;
+ static bool foreground = false;
diff --git a/app-backup/bacula/files/digest-bacula-2.0.2 b/app-backup/bacula/files/digest-bacula-2.0.2
new file mode 100644
index 000000000000..db3b6ff03ecf
--- /dev/null
+++ b/app-backup/bacula/files/digest-bacula-2.0.2
@@ -0,0 +1,6 @@
+MD5 299883ddd460336cfb613fd6d9bff989 bacula-2.0.2.tar.gz 2466754
+RMD160 94ef083b55a46126119cd30eac0758df9f8dc24b bacula-2.0.2.tar.gz 2466754
+SHA256 f72a7b0468652db18c6523dad39b798d58452b097be3b4f4cf1269f2deb657e1 bacula-2.0.2.tar.gz 2466754
+MD5 a114daae0e276ee274ccd558e42e13f0 bacula-docs-2.0.2.tar.gz 29776690
+RMD160 14c6582e9dabc4448fb681be192f46835ba0cb30 bacula-docs-2.0.2.tar.gz 29776690
+SHA256 1160405076fa2bc52c7c388d6b8bcfb9d692ffe794d9b22758ed9db7d9672b36 bacula-docs-2.0.2.tar.gz 29776690