summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-10-30 16:10:17 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-10-30 16:10:17 +0000
commit7500773c7bfab9a3916a7b47063d48282366a6d9 (patch)
tree1f5ea2169cb5b0946c5428f15840683a0b6aa040 /app-benchmarks/httperf/httperf-0.9.0-r2.ebuild
parentStable for HPPA (bug #439146). (diff)
downloadgentoo-2-7500773c7bfab9a3916a7b47063d48282366a6d9.tar.gz
gentoo-2-7500773c7bfab9a3916a7b47063d48282366a6d9.tar.bz2
gentoo-2-7500773c7bfab9a3916a7b47063d48282366a6d9.zip
Bump to EAPI 4, add Prefix support wrt bug #440140
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-benchmarks/httperf/httperf-0.9.0-r2.ebuild')
-rw-r--r--app-benchmarks/httperf/httperf-0.9.0-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-benchmarks/httperf/httperf-0.9.0-r2.ebuild b/app-benchmarks/httperf/httperf-0.9.0-r2.ebuild
new file mode 100644
index 000000000000..9a0c0d1d67e2
--- /dev/null
+++ b/app-benchmarks/httperf/httperf-0.9.0-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/httperf/httperf-0.9.0-r2.ebuild,v 1.1 2012/10/30 16:10:17 pinkbyte Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils toolchain-funcs
+
+DESCRIPTION="A tool from HP for measuring web server performance."
+HOMEPAGE="http://code.google.com/p/httperf/"
+SRC_URI="http://httperf.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux ~mips ~x64-macos ~x86"
+IUSE="debug"
+
+DEPEND="dev-libs/openssl"
+RDEPEND="dev-libs/openssl"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_configure() {
+ econf --bindir="${EPREFIX}"/usr/bin \
+ $(use_enable debug)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" -j1
+}