summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-09-25 01:56:21 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-09-25 01:56:21 +0000
commitfc81224717c605549c1f16bc1958e4733018e1fb (patch)
tree3a034ab8dbeb3792e3d63ffaeeb0beee697e85bf /app-benchmarks/ltp
parentMarked ~amd64 (diff)
downloadgentoo-2-fc81224717c605549c1f16bc1958e4733018e1fb.tar.gz
gentoo-2-fc81224717c605549c1f16bc1958e4733018e1fb.tar.bz2
gentoo-2-fc81224717c605549c1f16bc1958e4733018e1fb.zip
fixed to use treecopy for BSD compatibility - bug #106443
(Portage version: 2.0.52-r1)
Diffstat (limited to 'app-benchmarks/ltp')
-rw-r--r--app-benchmarks/ltp/ChangeLog7
-rw-r--r--app-benchmarks/ltp/Manifest10
-rw-r--r--app-benchmarks/ltp/ltp-20041104.ebuild6
-rw-r--r--app-benchmarks/ltp/ltp-20041203.ebuild8
4 files changed, 18 insertions, 13 deletions
diff --git a/app-benchmarks/ltp/ChangeLog b/app-benchmarks/ltp/ChangeLog
index 269c34410833..2170ec696b81 100644
--- a/app-benchmarks/ltp/ChangeLog
+++ b/app-benchmarks/ltp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/ltp
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ltp/ChangeLog,v 1.5 2005/08/07 12:04:32 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ltp/ChangeLog,v 1.6 2005/09/25 01:56:21 dragonheart Exp $
+
+ 25 Sep 2005; Daniel Black <dragonheart@gentoo.org> ltp-20041104.ebuild,
+ ltp-20041203.ebuild:
+ fixed to use treecopy for BSD compatibility - bug #106443 - thanks Diego
+ Pettenò
07 Aug 2005; Simon Stelling <blubb@gentoo.org> ltp-20041203.ebuild:
added ~amd64 keyword
diff --git a/app-benchmarks/ltp/Manifest b/app-benchmarks/ltp/Manifest
index 3c7353f1e6ae..219c92054faf 100644
--- a/app-benchmarks/ltp/Manifest
+++ b/app-benchmarks/ltp/Manifest
@@ -1,10 +1,10 @@
-MD5 f45f417bed36364437c59779c00daeec ChangeLog 1017
-MD5 5577d51f140105e12307dcdb1fddfafc ltp-20041104.ebuild 1160
-MD5 66d494f650a410258f323406f7447ec3 ltp-20041203.ebuild 1174
+MD5 472b739f0435b364a7466b7691924601 ltp-20041104.ebuild 1165
MD5 f592f012ff1df95e9b2dcd743df2405b metadata.xml 402
+MD5 f45f417bed36364437c59779c00daeec ChangeLog 1017
+MD5 a089f90b26bbbca9384745a5cf500b1c ltp-20041203.ebuild 1178
+MD5 e2a7ff766a942e7a6a8e299cb74edacb files/runltp-path.patch 387
MD5 e4bb569a7ad39bd83b66430469168d6b files/IDcheck-noninteractive.patch 729
MD5 d1ba3a9b21ea0697d2b92b74e9147231 files/digest-ltp-20041104 67
+MD5 e17b3facc501915809ff69e8f9a12056 files/ltp-ballista-paths.patch 8166
MD5 acbebd9bb97c2f8b55f62c4c87a48deb files/digest-ltp-20041203 67
MD5 1c87578ced34310bd048cc03c9ac45c4 files/ltp-20041203-ballista-paths.patch 6203
-MD5 e17b3facc501915809ff69e8f9a12056 files/ltp-ballista-paths.patch 8166
-MD5 e2a7ff766a942e7a6a8e299cb74edacb files/runltp-path.patch 387
diff --git a/app-benchmarks/ltp/ltp-20041104.ebuild b/app-benchmarks/ltp/ltp-20041104.ebuild
index 108dcecb6e08..ea5415a91a3a 100644
--- a/app-benchmarks/ltp/ltp-20041104.ebuild
+++ b/app-benchmarks/ltp/ltp-20041104.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ltp/ltp-20041104.ebuild,v 1.3 2005/01/01 12:05:01 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ltp/ltp-20041104.ebuild,v 1.4 2005/09/25 01:56:21 dragonheart Exp $
-inherit eutils
+inherit eutils portability
MY_P="${PN}-full-${PV}"
S="${WORKDIR}/${MY_P}"
@@ -35,7 +35,7 @@ src_install() {
make install || die "install failed"
mkdir -p ${D}/usr/libexec/ltp/testcases ${D}/usr/bin/ || die "mkdir failed"
- cp --parents -r testcases pan/pan runtest ver_linux IDcheck.sh ${D}/usr/libexec/ltp || die "cp failed"
+ treecopy testcases pan/pan runtest ver_linux IDcheck.sh ${D}/usr/libexec/ltp || die "cp failed"
cp runltp runalltests.sh ${D}/usr/bin || die "cp failed"
# TODO: fix this so it works from "outside" the source tree
diff --git a/app-benchmarks/ltp/ltp-20041203.ebuild b/app-benchmarks/ltp/ltp-20041203.ebuild
index 4c34ba1b63d3..ce8bd7dd1b5e 100644
--- a/app-benchmarks/ltp/ltp-20041203.ebuild
+++ b/app-benchmarks/ltp/ltp-20041203.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ltp/ltp-20041203.ebuild,v 1.4 2005/08/07 12:04:32 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ltp/ltp-20041203.ebuild,v 1.5 2005/09/25 01:56:21 dragonheart Exp $
-inherit eutils
+inherit eutils portability
MY_P="${PN}-full-${PV}"
S="${WORKDIR}/${MY_P}"
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/ltp/${MY_P}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="~amd64 ~ppc x86"
IUSE=""
@@ -35,7 +35,7 @@ src_install() {
make install || die "install failed"
mkdir -p ${D}/usr/libexec/ltp/testcases ${D}/usr/bin/ || die "mkdir failed"
- cp --parents -r testcases pan/pan runtest ver_linux IDcheck.sh ${D}/usr/libexec/ltp || die "cp failed"
+ treecopy testcases pan/pan runtest ver_linux IDcheck.sh ${D}/usr/libexec/ltp || die "cp failed"
cp runltp runalltests.sh ${D}/usr/bin || die "cp failed"
# TODO: fix this so it works from "outside" the source tree