summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-10-12 19:30:32 +0000
committerJeroen Roovers <jer@gentoo.org>2010-10-12 19:30:32 +0000
commit293a1c4f6a714f34b76a17bfa5f7a09cd8a4c225 (patch)
tree078fc02dd27df388ff2ef6440f43ab25c74d7558 /app-benchmarks/pipebench/pipebench-0.40-r1.ebuild
parentFix missing includes and defines. Respect CC (bug #243522), LDFLAGS. (diff)
downloadgentoo-2-293a1c4f6a714f34b76a17bfa5f7a09cd8a4c225.tar.gz
gentoo-2-293a1c4f6a714f34b76a17bfa5f7a09cd8a4c225.tar.bz2
gentoo-2-293a1c4f6a714f34b76a17bfa5f7a09cd8a4c225.zip
Respect CC (bug #243524), LDFLAGS. Make sed die.
(Portage version: 2.2_rc92/cvs/Linux i686)
Diffstat (limited to 'app-benchmarks/pipebench/pipebench-0.40-r1.ebuild')
-rw-r--r--app-benchmarks/pipebench/pipebench-0.40-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-benchmarks/pipebench/pipebench-0.40-r1.ebuild b/app-benchmarks/pipebench/pipebench-0.40-r1.ebuild
new file mode 100644
index 000000000000..18ea4fa06d52
--- /dev/null
+++ b/app-benchmarks/pipebench/pipebench-0.40-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/pipebench/pipebench-0.40-r1.ebuild,v 1.1 2010/10/12 19:30:32 jer Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Measures the speed of stdin/stdout communication"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=pipebench"
+SRC_URI="ftp://ftp.habets.pp.se/pub/synscan/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+src_prepare() {
+ sed -i Makefile \
+ -e 's:CFLAGS=-Wall:CFLAGS+= -Wall:' \
+ -e 's:$(CFLAGS) -o:$(LDFLAGS) &:g' \
+ -e "s:/usr/local/bin/:${D}/usr/bin:" \
+ -e "s:/usr/local/man/man1/:${D}/usr/share/man/man1:" \
+ || die "sed Makefile"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die
+}
+
+src_install() {
+ dodir /usr/{bin,share/man/man1}
+ emake install || die
+ dodoc README
+}