summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-01-19 13:21:17 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-01-19 13:21:17 +0000
commit0123f93d1406260c2b55501d54f8e7f72308dcde (patch)
tree252b87a66e13ee39a73617c774c354bcbf4c9a3d /app-benchmarks
parentStable on sparc --- Bug #162682 --- builds all examples, demo runs, all as (diff)
downloadgentoo-2-0123f93d1406260c2b55501d54f8e7f72308dcde.tar.gz
gentoo-2-0123f93d1406260c2b55501d54f8e7f72308dcde.tar.bz2
gentoo-2-0123f93d1406260c2b55501d54f8e7f72308dcde.zip
Port to generation 2 and add the source use flag. Now has java as the herd so we can touch this freely in the future.
(Portage version: 2.1.2)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/bootchart/ChangeLog11
-rw-r--r--app-benchmarks/bootchart/bootchart-0.9-r1.ebuild114
-rw-r--r--app-benchmarks/bootchart/files/digest-bootchart-0.9-r13
-rw-r--r--app-benchmarks/bootchart/metadata.xml1
4 files changed, 127 insertions, 2 deletions
diff --git a/app-benchmarks/bootchart/ChangeLog b/app-benchmarks/bootchart/ChangeLog
index 608bdda1f705..990c63c6d41b 100644
--- a/app-benchmarks/bootchart/ChangeLog
+++ b/app-benchmarks/bootchart/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-benchmarks/bootchart
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart/ChangeLog,v 1.1 2006/08/15 11:44:28 uberlord Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart/ChangeLog,v 1.2 2007/01/19 13:21:17 betelgeuse Exp $
+
+*bootchart-0.9-r1 (19 Jan 2007)
+
+ 19 Jan 2007; Petteri Räty <betelgeuse@gentoo.org> metadata.xml,
+ +bootchart-0.9-r1.ebuild:
+ Port to generation 2 and add the source use flag. Now has java as the herd
+ so we can touch this freely in the future.
*bootchart-0.9 (15 Aug 2006)
diff --git a/app-benchmarks/bootchart/bootchart-0.9-r1.ebuild b/app-benchmarks/bootchart/bootchart-0.9-r1.ebuild
new file mode 100644
index 000000000000..2b5dd6f42c0b
--- /dev/null
+++ b/app-benchmarks/bootchart/bootchart-0.9-r1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart/bootchart-0.9-r1.ebuild,v 1.1 2007/01/19 13:21:17 betelgeuse Exp $
+
+inherit eutils java-pkg-opt-2 java-ant-2
+
+DESCRIPTION="Performance analysis and visualization of the system boot process"
+HOMEPAGE="http://www.bootchart.org"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+DEPEND="
+ java? (
+ >=virtual/jdk-1.4
+ >=dev-java/ant-core-1.4
+ dev-java/commons-cli
+ source? ( app-arch/zip )
+ )
+"
+
+RDEPEND="
+ java? (
+ >=virtual/jdk-1.4
+ dev-java/commons-cli
+ )
+ acct? ( sys-process/acct )
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="acct debug doc java source"
+KEYWORDS="~amd64 ~x86"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-0.9-gentoo.patch"
+
+ # delete the included commons-cli and use gentoo's instead
+ # The rest of lib is also bundled but a bit problematic to
+ # package https://bugs.gentoo.org/show_bug.cgi?id=162788
+ rm -rf lib/org/apache/commons/cli lib/org/apache/commons/lang
+
+ if use java ; then
+ java-ant_rewrite-classpath
+ sed -i -e 's,AUTO_RENDER="no",AUTO_RENDER="yes",g' \
+ script/bootchartd.conf
+ fi
+
+ if use acct ; then
+ sed -i -e 's,PROCESS_ACCOUNTING="no",PROCESS_ACCOUNTING="yes",g' \
+ script/bootchartd.conf
+ fi
+}
+
+src_compile() {
+ if use java ; then
+ local antflags="jar -Dcompiler.nowarn=true $(use_doc)"
+ use debug || antflags="${antflags} -Dbuild.debug=false"
+ eant ${antflags} \
+ -Dgentoo.classpath="$(java-pkg_getjars commons-cli-1):./build"
+ fi
+}
+
+src_install() {
+ dodoc README README.logger ChangeLog COPYING TODO
+
+ insinto /lib/rcscripts/addons
+ doins "${FILESDIR}/profiling-functions.sh"
+
+ into /
+ newsbin script/bootchartd bootchartd
+ into /usr
+
+ # This dir is normally empty, but is used to bind to the
+ # temporary dir bootchart normally makes. We do this so
+ # that our profiling script can write to a fixed location.
+ keepdir /lib/bootchart
+
+ insinto /etc
+ doins script/bootchartd.conf
+
+ if use java ; then
+ java-pkg_dojar "${PN}.jar"
+ use doc && java-pkg_dojavadoc javadoc/api
+ use source && java-pkg_dosrc src/org
+ java-pkg_dolauncher ${PN} \
+ --main org.bootchart.Main \
+ --java_args "-Djava.awt.headless=true"
+ fi
+}
+
+pkg_postinst() {
+ einfo "To generate the chart, set RC_USE_BOOTCHART=\"yes\""
+ einfo "in /etc/conf.d/rc and reboot"
+ einfo
+
+ if use java; then
+ einfo "The chart will be saved as /var/log/bootchart.png"
+ else
+ einfo "Post the file /var/log/bootchart.tgz here:"
+ einfo " http://www.bootchart.org/download.html"
+ einfo "to render the chart"
+ fi
+
+ einfo
+ einfo "For best results: "
+ einfo " Enable BSD process accounting v3 in the kernel"
+ einfo " This will produce more accurate process trees"
+ einfo " Set AUTO_RENDER_FORMAT to svg in /etc/bootchartd.conf"
+ einfo " and view /var/log/bootchart.svgz with batik or"
+ einfo " Adobe SVG viewer. This will give you additional"
+ einfo " information about the processes in tooltips"
+}
diff --git a/app-benchmarks/bootchart/files/digest-bootchart-0.9-r1 b/app-benchmarks/bootchart/files/digest-bootchart-0.9-r1
new file mode 100644
index 000000000000..8488ebb31c32
--- /dev/null
+++ b/app-benchmarks/bootchart/files/digest-bootchart-0.9-r1
@@ -0,0 +1,3 @@
+MD5 4be91177d19069e21beeb106f2f77dff bootchart-0.9.tar.bz2 222558
+RMD160 c271bf634117c9bcd530055927abffead134b73a bootchart-0.9.tar.bz2 222558
+SHA256 7738399ecfcfb2242e9f99a316b13a5f59e89052de05074dbf705ccf4edc327d bootchart-0.9.tar.bz2 222558
diff --git a/app-benchmarks/bootchart/metadata.xml b/app-benchmarks/bootchart/metadata.xml
index fcdef538fc1e..4713e4f1667a 100644
--- a/app-benchmarks/bootchart/metadata.xml
+++ b/app-benchmarks/bootchart/metadata.xml
@@ -1,6 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+<herd>java</herd>
<maintainer>
<email>uberlord@gentoo.org</email>
<name>Roy Marples</name>