summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-04-03 20:58:19 +0000
committerMike Frysinger <vapier@gentoo.org>2014-04-03 20:58:19 +0000
commit1729b634eeccb4bf8047e7ec6e87252cb5336da9 (patch)
tree4c4fbf9daab9164db1ea3a997c0185478adf8b09 /app-benchmarks
parentVersion bump. Cleanup (diff)
downloadgentoo-2-1729b634eeccb4bf8047e7ec6e87252cb5336da9.tar.gz
gentoo-2-1729b634eeccb4bf8047e7ec6e87252cb5336da9.tar.bz2
gentoo-2-1729b634eeccb4bf8047e7ec6e87252cb5336da9.zip
Update HOMEPAGE and fix CC/CPPFLAGS handling.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/libc-bench/ChangeLog8
-rw-r--r--app-benchmarks/libc-bench/libc-bench-20110206.ebuild19
2 files changed, 15 insertions, 12 deletions
diff --git a/app-benchmarks/libc-bench/ChangeLog b/app-benchmarks/libc-bench/ChangeLog
index e4586fdb95b2..86e27ffa1ad3 100644
--- a/app-benchmarks/libc-bench/ChangeLog
+++ b/app-benchmarks/libc-bench/ChangeLog
@@ -1,10 +1,12 @@
# ChangeLog for app-benchmarks/libc-bench
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/libc-bench/ChangeLog,v 1.1 2013/06/21 14:19:16 blueness Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/libc-bench/ChangeLog,v 1.2 2014/04/03 20:58:19 vapier Exp $
+
+ 03 Apr 2014; Mike Frysinger <vapier@gentoo.org> libc-bench-20110206.ebuild:
+ Update HOMEPAGE and fix CC/CPPFLAGS handling.
*libc-bench-20110206 (21 Jun 2013)
21 Jun 2013; Anthony G. Basile <blueness@gentoo.org>
+libc-bench-20110206.ebuild, +files/respect-flags.patch, +metadata.xml:
Initial commit
-
diff --git a/app-benchmarks/libc-bench/libc-bench-20110206.ebuild b/app-benchmarks/libc-bench/libc-bench-20110206.ebuild
index ce84adc97005..d46794b4fd25 100644
--- a/app-benchmarks/libc-bench/libc-bench-20110206.ebuild
+++ b/app-benchmarks/libc-bench/libc-bench-20110206.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/libc-bench/libc-bench-20110206.ebuild,v 1.1 2013/06/21 14:19:16 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/libc-bench/libc-bench-20110206.ebuild,v 1.2 2014/04/03 20:58:19 vapier Exp $
EAPI="5"
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Time and memory-efficiency tests of various C/POSIX standard library functions"
-HOMEPAGE="http://www.etalabs.net/libc-bench.html"
+HOMEPAGE="http://www.etalabs.net/libc-bench.html http://git.musl-libc.org/cgit/libc-bench/"
SRC_URI="http://www.etalabs.net/releases/${P}.tar.gz"
LICENSE="MIT"
@@ -15,14 +15,15 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
-
src_prepare() {
epatch "${FILESDIR}"/respect-flags.patch
}
+src_configure() {
+ tc-export CC
+ CFLAGS+=" ${CPPFLAGS}"
+}
+
src_install() {
- exeinto /usr/bin
- doexe libc-bench
+ dobin libc-bench
}