summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-06-16 06:10:02 +0000
committerJustin Lecher <jlec@gentoo.org>2014-06-16 06:10:02 +0000
commit3b05a57e99b6c9e210c2d135d82af462208a6530 (patch)
tree1987ffbe88d2671cedeaf85bed941a5c2450cd89 /app-benchmarks
parentAdd pypy compatibility (diff)
downloadgentoo-2-3b05a57e99b6c9e210c2d135d82af462208a6530.tar.gz
gentoo-2-3b05a57e99b6c9e210c2d135d82af462208a6530.tar.bz2
gentoo-2-3b05a57e99b6c9e210c2d135d82af462208a6530.zip
app-benchmarks/cpuburn: Drop old; drop unnecessary emul-linux dep, #492962; add patch from debian fixing variable declaration
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/cpuburn/ChangeLog12
-rw-r--r--app-benchmarks/cpuburn/cpuburn-1.4.ebuild37
-rw-r--r--app-benchmarks/cpuburn/cpuburn-1.4a-r1.ebuild32
-rw-r--r--app-benchmarks/cpuburn/cpuburn-1.4a.ebuild8
-rw-r--r--app-benchmarks/cpuburn/files/01-variables.patch40
-rw-r--r--app-benchmarks/cpuburn/metadata.xml4
6 files changed, 86 insertions, 47 deletions
diff --git a/app-benchmarks/cpuburn/ChangeLog b/app-benchmarks/cpuburn/ChangeLog
index b74f66ec4dce..729693ebb633 100644
--- a/app-benchmarks/cpuburn/ChangeLog
+++ b/app-benchmarks/cpuburn/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-benchmarks/cpuburn
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/cpuburn/ChangeLog,v 1.19 2012/02/15 18:38:53 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/cpuburn/ChangeLog,v 1.20 2014/06/16 06:10:02 jlec Exp $
+
+*cpuburn-1.4a-r1 (16 Jun 2014)
+
+ 16 Jun 2014; Justin Lecher <jlec@gentoo.org> -cpuburn-1.4.ebuild,
+ cpuburn-1.4a.ebuild, +cpuburn-1.4a-r1.ebuild, +files/01-variables.patch,
+ metadata.xml:
+ Drop old; drop unnecessary emul-linux dep, #492962; add patch from debian
+ fixing variable declaration
15 Feb 2012; Justin Lecher <jlec@gentoo.org> cpuburn-1.4a.ebuild:
Mirror the src tarball as upstream is dead, move to EAPI=4
diff --git a/app-benchmarks/cpuburn/cpuburn-1.4.ebuild b/app-benchmarks/cpuburn/cpuburn-1.4.ebuild
deleted file mode 100644
index 8fa7c27770ec..000000000000
--- a/app-benchmarks/cpuburn/cpuburn-1.4.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/cpuburn/cpuburn-1.4.ebuild,v 1.15 2009/10/12 19:02:05 halcy0n Exp $
-
-MY_P="${PV/./_}"
-DESCRIPTION="designed to heavily load CPU chips [testing purposes]"
-HOMEPAGE="http://pages.sbcglobal.net/redelm/"
-SRC_URI="http://pages.sbcglobal.net/redelm/cpuburn_${MY_P}_tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* amd64 x86"
-IUSE=""
-RESTRICT="strip"
-
-DEPEND="sys-devel/gcc"
-RDEPEND="amd64? ( >=app-emulation/emul-linux-x86-baselibs-1.0 )"
-
-src_unpack() {
- # for some reason he has it _tar instead of .tar ...
- unpack ${A}
- tar -xf cpuburn_${MY_P}_tar || die
-
- if use amd64 ; then #65719
- cd "${S}"
- sed -i 's:gcc -s:gcc -m32 -s:' Makefile || die "sed failed"
- fi
-}
-
-src_compile() {
- emake || die
-}
-
-src_install() {
- dodoc Design README
- dobin burn{BX,K6,K7,MMX,P5,P6} || die
-}
diff --git a/app-benchmarks/cpuburn/cpuburn-1.4a-r1.ebuild b/app-benchmarks/cpuburn/cpuburn-1.4a-r1.ebuild
new file mode 100644
index 000000000000..2d6a3b31493d
--- /dev/null
+++ b/app-benchmarks/cpuburn/cpuburn-1.4a-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/cpuburn/cpuburn-1.4a-r1.ebuild,v 1.1 2014/06/16 06:10:02 jlec Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_P="${PV/./_}"
+
+DESCRIPTION="Designed to heavily load CPU chips [testing purposes]"
+HOMEPAGE="http://pages.sbcglobal.net/redelm/"
+#SRC_URI="http://pages.sbcglobal.net/redelm/cpuburn_${MY_P}_tar.gz -> ${P}.tar.gz"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-flags.patch \
+ "${FILESDIR}"/01-variables.patch
+ use amd64 && append-flags -m32 #65719
+ tc-export CC
+}
+
+src_install() {
+ dodoc Design README
+ dobin burn{BX,K6,K7,MMX,P5,P6}
+}
diff --git a/app-benchmarks/cpuburn/cpuburn-1.4a.ebuild b/app-benchmarks/cpuburn/cpuburn-1.4a.ebuild
index 6cae7326decf..ceb0cc4af411 100644
--- a/app-benchmarks/cpuburn/cpuburn-1.4a.ebuild
+++ b/app-benchmarks/cpuburn/cpuburn-1.4a.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/cpuburn/cpuburn-1.4a.ebuild,v 1.4 2012/02/15 18:38:53 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/cpuburn/cpuburn-1.4a.ebuild,v 1.5 2014/06/16 06:10:02 jlec Exp $
EAPI=4
@@ -18,11 +18,7 @@ SLOT="0"
KEYWORDS="-* amd64 x86"
IUSE=""
-RDEPEND="amd64? ( >=app-emulation/emul-linux-x86-baselibs-1.0 )"
-DEPEND=""
-
src_prepare() {
- cp -av Makefile{,.orig}
epatch "${FILESDIR}"/${P}-flags.patch
use amd64 && append-flags -m32 #65719
tc-export CC
diff --git a/app-benchmarks/cpuburn/files/01-variables.patch b/app-benchmarks/cpuburn/files/01-variables.patch
new file mode 100644
index 000000000000..3e8b666c29ec
--- /dev/null
+++ b/app-benchmarks/cpuburn/files/01-variables.patch
@@ -0,0 +1,40 @@
+--- cpuburn-1.4a.orig/burnK7.S
++++ cpuburn-1.4a/burnK7.S
+@@ -74,6 +74,7 @@ int_exit:
+ push %eax
+ int $0x80
+ #endif
++.data # Data allocation
+ .align 32,0
+ .fill 64
+ half: .long 0x7fffffff,0
+--- cpuburn-1.4a.orig/burnP5.S
++++ cpuburn-1.4a/burnP5.S
+@@ -77,6 +77,7 @@ crunch:
+ #else
+ int $0x80
+ #endif
++.data # Data allocation
+ .align 32,0
+ half: .long 0xffffffff,0x3fdfffff
+ one: .long 0xffffffff,0x3fefffff
+--- cpuburn-1.4a.orig/burnP6.S
++++ cpuburn-1.4a/burnP6.S
+@@ -69,6 +69,7 @@ int_exit: # error abort
+ push %eax # *BSD syscall
+ int $0x80
+ #endif
++.data # Data allocation
+ .align 32,0
+ half: .long 0x7fffffff,0
+ e: .long 0xffffffff,0x3fdfffff
+--- cpuburn-1.4a.orig/burnK6.S
++++ cpuburn-1.4a/burnK6.S
+@@ -68,6 +68,7 @@ int_exit:
+ push %eax
+ int $0x80
+ #endif
++.data # Data allocation
+ .align 32,0
+ half: .long 0x7fffffff,0
+ e: .long 0xffffffff,0x3fdfffff
diff --git a/app-benchmarks/cpuburn/metadata.xml b/app-benchmarks/cpuburn/metadata.xml
index a45e31d61182..afc8cb4d2030 100644
--- a/app-benchmarks/cpuburn/metadata.xml
+++ b/app-benchmarks/cpuburn/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>benchmarks</herd>
- <longdescription>
+ <herd>benchmarks</herd>
+ <longdescription>
CPUBurn is the ultimate stability testing tool for overclockers. The
program heats up any x86 CPU to the maximum possible operating
temperature that is achievable by using ordinary software.