summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2003-10-20 23:17:54 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2003-10-20 23:17:54 +0000
commit3d793480482b8020310067c87383149fc1ab7cbc (patch)
treefe06455231c0735ce59dc66312dc0ef218225303 /app-benchmarks
parentforgot an arg to find (diff)
downloadgentoo-2-3d793480482b8020310067c87383149fc1ab7cbc.tar.gz
gentoo-2-3d793480482b8020310067c87383149fc1ab7cbc.tar.bz2
gentoo-2-3d793480482b8020310067c87383149fc1ab7cbc.zip
Another openssl fix.
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/siege/ChangeLog5
-rw-r--r--app-benchmarks/siege/siege-2.55.ebuild5
2 files changed, 7 insertions, 3 deletions
diff --git a/app-benchmarks/siege/ChangeLog b/app-benchmarks/siege/ChangeLog
index 2ecfdd249f2b..33c5fddd893f 100644
--- a/app-benchmarks/siege/ChangeLog
+++ b/app-benchmarks/siege/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-benchmarks/siege
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.4 2003/10/16 21:04:02 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.5 2003/10/20 23:17:54 pyrania Exp $
+
+ 21 Oct 2003; Markus Nigbur <pyrania@gentoo.org> siege-2.55.ebuild:
+ Another openssl fix.
16 Oct 2003; Markus Nigbur <pyrania@gentoo.org> siege-2.55.ebuild:
Added patch to support openssl >=0.9.7. Thanks to kloeri for tracking it down
diff --git a/app-benchmarks/siege/siege-2.55.ebuild b/app-benchmarks/siege/siege-2.55.ebuild
index 1af690c4d49d..d9dc1fb9d974 100644
--- a/app-benchmarks/siege/siege-2.55.ebuild
+++ b/app-benchmarks/siege/siege-2.55.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.55.ebuild,v 1.8 2003/10/16 21:04:02 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.55.ebuild,v 1.9 2003/10/20 23:17:54 pyrania Exp $
DESCRIPTION="An http regression testing and benchmarking utility"
SRC_URI="ftp://ftp.armstrong.com/pub/siege/${P}.tar.gz"
@@ -14,7 +14,8 @@ IUSE="ssl"
DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )"
src_compile() {
- epatch ${FILESDIR}/siege-gentoo_openssl.patch
+ has_version '=dev-libs/openssl-0.9.7*' \
+ && sed -i -e "s:^# include <openssl/e_os.h>::" src/ssl.h
local myconf
use ssl && myconf="--with-ssl" || myconf="--with-ssl=off"
econf ${myconf}