summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-05-06 07:36:00 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-05-06 07:36:00 +0000
commit93f07b97e29f1c39b80a4a22e191c1ecb8fdb482 (patch)
tree5142268e2a016f8f5c6d037f66a5087ceb72105c /app-benchmarks
parentVersion bump hgsubversion to 1.6.1 (diff)
downloadgentoo-2-93f07b97e29f1c39b80a4a22e191c1ecb8fdb482.tar.gz
gentoo-2-93f07b97e29f1c39b80a4a22e191c1ecb8fdb482.tar.bz2
gentoo-2-93f07b97e29f1c39b80a4a22e191c1ecb8fdb482.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/ioping/ChangeLog10
-rw-r--r--app-benchmarks/ioping/ioping-0.8.ebuild35
2 files changed, 42 insertions, 3 deletions
diff --git a/app-benchmarks/ioping/ChangeLog b/app-benchmarks/ioping/ChangeLog
index 072871055b76..3cf9bf1a86c4 100644
--- a/app-benchmarks/ioping/ChangeLog
+++ b/app-benchmarks/ioping/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/ioping
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ioping/ChangeLog,v 1.3 2013/07/16 13:39:50 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ioping/ChangeLog,v 1.4 2014/05/06 07:36:00 patrick Exp $
+
+*ioping-0.8 (06 May 2014)
+
+ 06 May 2014; Patrick Lauer <patrick@gentoo.org> +ioping-0.8.ebuild:
+ Bump
*ioping-0.7 (16 Jul 2013)
@@ -19,4 +24,3 @@
13 Jan 2012; Justin Lecher <jlec@gentoo.org> +ioping-0.6.ebuild,
+files/ioping-0.6-makefile.patch, +metadata.xml:
New inclusion, #398735; thanks Vladimir Berezhnoy for the initial ebuild
-
diff --git a/app-benchmarks/ioping/ioping-0.8.ebuild b/app-benchmarks/ioping/ioping-0.8.ebuild
new file mode 100644
index 000000000000..8826318753eb
--- /dev/null
+++ b/app-benchmarks/ioping/ioping-0.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ioping/ioping-0.8.ebuild,v 1.1 2014/05/06 07:36:00 patrick Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Simple disk I/0 latency measuring tool"
+HOMEPAGE="http://code.google.com/p/ioping/"
+SRC_URI="http://ioping.googlecode.com/files/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+IUSE=""
+
+src_prepare() {
+ sed \
+ -e 's: -g : :g' \
+ -e 's: $(LDFLAGS) : :g' \
+ -e 's: -o : $(LDFLAGS) -o :g' \
+ -e 's:-s -m:-m:g' \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}