summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2006-02-28 23:52:19 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2006-02-28 23:52:19 +0000
commit0eb69b6ed555939f648aaab3c4866d0802cde130 (patch)
tree9109d176ff064fc8bb59b8f9ffda17f2cf228108 /app-cdr/cuecue/cuecue-0.2.2.ebuild
parentchange einstall to make DESTDIR= install (diff)
downloadgentoo-2-0eb69b6ed555939f648aaab3c4866d0802cde130.tar.gz
gentoo-2-0eb69b6ed555939f648aaab3c4866d0802cde130.tar.bz2
gentoo-2-0eb69b6ed555939f648aaab3c4866d0802cde130.zip
initial commit, solving bug #87000.
(Portage version: 2.1_pre5-r1)
Diffstat (limited to 'app-cdr/cuecue/cuecue-0.2.2.ebuild')
-rw-r--r--app-cdr/cuecue/cuecue-0.2.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-cdr/cuecue/cuecue-0.2.2.ebuild b/app-cdr/cuecue/cuecue-0.2.2.ebuild
new file mode 100644
index 000000000000..143dd7c1a7fb
--- /dev/null
+++ b/app-cdr/cuecue/cuecue-0.2.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cuecue/cuecue-0.2.2.ebuild,v 1.1 2006/02/28 23:52:19 sbriesen Exp $
+
+inherit eutils
+
+DESCRIPTION="Cuecue is a suite to convert .cue + [.ogg|.flac|.wav|.mp3] to .cue + .bin."
+HOMEPAGE="http://cuecue.berlios.de/"
+SRC_URI="http://download.berlios.de/cuecue/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mp3 flac vorbis"
+DEPEND=""
+RDEPEND="mp3? ( media-libs/libmad )
+ flac? ( media-libs/flac )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # remove obsolete CFLAGS
+ sed -i -e "s:-g -Os::g" configure*
+}
+
+src_compile() {
+ local myconf=""
+ myconf="${myconf} $(use_enable mp3)"
+ myconf="${myconf} $(use_enable flac)"
+ myconf="${myconf} $(use_enable vorbis ogg)"
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+ insinto /usr/include
+ doins src/libcuecue/cuecue.h
+ dodoc CHANGES README TODO
+}