summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2007-02-04 02:35:24 +0000
committerLars Weiler <pylon@gentoo.org>2007-02-04 02:35:24 +0000
commitf36ad0477bff29be3cbaa992283c5d1ca62bdffc (patch)
tree5c83dc2d04ed873277b889036732e22c549bab4e /app-cdr/isomaster/isomaster-0.7.ebuild
parentRemove old versions. (diff)
downloadgentoo-2-f36ad0477bff29be3cbaa992283c5d1ca62bdffc.tar.gz
gentoo-2-f36ad0477bff29be3cbaa992283c5d1ca62bdffc.tar.bz2
gentoo-2-f36ad0477bff29be3cbaa992283c5d1ca62bdffc.zip
Version bump; bug #157697; thanks to Wojciech Myrda for the ebuild.
(Portage version: 2.1.2-r5)
Diffstat (limited to 'app-cdr/isomaster/isomaster-0.7.ebuild')
-rw-r--r--app-cdr/isomaster/isomaster-0.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-cdr/isomaster/isomaster-0.7.ebuild b/app-cdr/isomaster/isomaster-0.7.ebuild
new file mode 100644
index 000000000000..17d45d2c4b8b
--- /dev/null
+++ b/app-cdr/isomaster/isomaster-0.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+inherit eutils
+
+DESCRIPTION="GTK2 (bootable) CD ISO Image editor."
+HOMEPAGE="http://littlesvr.ca/isomaster/"
+SRC_URI="http://littlesvr.ca/isomaster/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.0"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ # make flags useful
+ sed -i -e "s:-Wall:${CFLAGS}:" Makefile || die "sed failed"
+ sed -i -e "s:-Wall:${CFLAGS}:" */Makefile || die "sed failed"
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install || die "Install failed"
+ dodoc *.TXT bk/TODO.TXT
+
+ doicon icons/${PN}.png
+ make_desktop_entry ${PN} "Isomaster" ${PN}.png "Application;AudioVideo;"
+}
+