summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-05-13 10:16:36 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-05-13 10:16:36 +0000
commit09ac193f000e58a5126c7ef8d7eb00c884ac25ea (patch)
tree312fb52e463b04fdc0ae1d3c6eb15767318edbe8 /app-cdr/uif2iso/uif2iso-0.1.7c.ebuild
parentstable x86, security bug 269605 (diff)
downloadgentoo-2-09ac193f000e58a5126c7ef8d7eb00c884ac25ea.tar.gz
gentoo-2-09ac193f000e58a5126c7ef8d7eb00c884ac25ea.tar.bz2
gentoo-2-09ac193f000e58a5126c7ef8d7eb00c884ac25ea.zip
Version bump and cleanup.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-cdr/uif2iso/uif2iso-0.1.7c.ebuild')
-rw-r--r--app-cdr/uif2iso/uif2iso-0.1.7c.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-cdr/uif2iso/uif2iso-0.1.7c.ebuild b/app-cdr/uif2iso/uif2iso-0.1.7c.ebuild
new file mode 100644
index 000000000000..b27cbed5bac9
--- /dev/null
+++ b/app-cdr/uif2iso/uif2iso-0.1.7c.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/uif2iso/uif2iso-0.1.7c.ebuild,v 1.1 2009/05/13 10:16:36 flameeyes Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Converts MagicISO CD-images to iso"
+HOMEPAGE="http://aluigi.org/mytoolz.htm#uif2iso"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/src"
+
+src_compile() {
+ # Yes we use our own makefile, I'll try to explain this to
+ # upstream _again_.
+ emake CC="$(tc-getCC)" -f "${FILESDIR}/0.1.7-Makefile" || die "emake failed"
+}
+
+src_install() {
+ dobin ${PN} || die "failed to install"
+
+ dodoc "${WORKDIR}"/${PN}.txt "${WORKDIR}"/README
+}