summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-01-12 00:10:53 +0000
committerJohannes Huber <johu@gentoo.org>2012-01-12 00:10:53 +0000
commit907f7fc563fd6b5b5bdabaf3387852c73ef28e73 (patch)
tree65c39966c740e068d9a63214447c54a25ac3a7e4 /app-cdr
parentRemove old. (diff)
downloadgentoo-2-907f7fc563fd6b5b5bdabaf3387852c73ef28e73.tar.gz
gentoo-2-907f7fc563fd6b5b5bdabaf3387852c73ef28e73.tar.bz2
gentoo-2-907f7fc563fd6b5b5bdabaf3387852c73ef28e73.zip
Revision bump. Add patch to fix compatibility with >=app-cdr/cdemud-1.4.0. Thanks Alexandre Rostovtsev <tetromino@gentoo.org> for the patch. Fixes bug #393121.
(Portage version: 2.2.0_alpha84/cvs/Linux i686)
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/kcdemu/ChangeLog13
-rw-r--r--app-cdr/kcdemu/files/kcdemu-0.3.1-start-cdemud.patch68
-rw-r--r--app-cdr/kcdemu/kcdemu-0.3.1-r1.ebuild (renamed from app-cdr/kcdemu/kcdemu-0.3.1.ebuild)10
3 files changed, 86 insertions, 5 deletions
diff --git a/app-cdr/kcdemu/ChangeLog b/app-cdr/kcdemu/ChangeLog
index b176291dd21a..831b303991ed 100644
--- a/app-cdr/kcdemu/ChangeLog
+++ b/app-cdr/kcdemu/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-cdr/kcdemu
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/kcdemu/ChangeLog,v 1.4 2010/10/09 19:15:52 fauli Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/kcdemu/ChangeLog,v 1.5 2012/01/12 00:10:53 johu Exp $
+
+*kcdemu-0.3.1-r1 (12 Jan 2012)
+
+ 12 Jan 2012; Johannes Huber <johu@gentoo.org>
+ +files/kcdemu-0.3.1-start-cdemud.patch, +kcdemu-0.3.1-r1.ebuild,
+ -kcdemu-0.3.1.ebuild:
+ Revision bump. Add patch to fix compatibility with >=app-cdr/cdemud-1.4.0.
+ Thanks Alexandre Rostovtsev <tetromino@gentoo.org> for the patch. Fixes bug
+ #393121.
09 Oct 2010; Christian Faulhammer <fauli@gentoo.org> kcdemu-0.3.ebuild:
stable x86, bug 328699
diff --git a/app-cdr/kcdemu/files/kcdemu-0.3.1-start-cdemud.patch b/app-cdr/kcdemu/files/kcdemu-0.3.1-start-cdemud.patch
new file mode 100644
index 000000000000..d6edfae54470
--- /dev/null
+++ b/app-cdr/kcdemu/files/kcdemu-0.3.1-start-cdemud.patch
@@ -0,0 +1,68 @@
+From 9486c351315373e7f3be0ca8ab3c84e3295eccfb Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Tue, 10 Jan 2012 23:29:23 -0500
+Subject: [PATCH] Try to start the daemon if it's not already running
+
+Fixes compatibility with cdemud-1.4.0, see
+https://bugs.gentoo.org/show_bug.cgi?id=393121
+---
+ src/cdemu.cpp | 9 ++++++++-
+ src/cdemu.h | 2 +-
+ 2 files changed, 9 insertions(+), 2 deletions(-)
+
+diff --git a/src/cdemu.cpp b/src/cdemu.cpp
+index 3fe18c2..75f91dc 100644
+--- a/src/cdemu.cpp
++++ b/src/cdemu.cpp
+@@ -32,6 +32,9 @@ CDEmu::CDEmu()
+ m_currentBus(0)
+ {
+ this->findCurrentBus();
++ // If the daemon has not been started, try to start it
++ if (!m_currentBus)
++ this->findCurrentBus(true);
+
+ this->connectSlots(&m_sessionBus);
+ this->connectSlots(&m_systemBus);
+@@ -181,7 +184,7 @@ void CDEmu::connectSlots(QDBusConnection *connection)
+ }
+
+
+-void CDEmu::findCurrentBus()
++void CDEmu::findCurrentBus(bool start_daemon)
+ {
+ // We don't want to get signals from the wrong bus in case we
+ // switch from the session bus to the system bus or vice versa
+@@ -194,12 +197,16 @@ void CDEmu::findCurrentBus()
+
+ // Try session bus first
+ QDBusConnectionInterface *interface = m_sessionBus.interface();
++ if (start_daemon)
++ interface->startService("net.sf.cdemu.CDEMUD_Daemon");
+ if (interface->isServiceRegistered("net.sf.cdemu.CDEMUD_Daemon"))
+ m_currentBus = &m_sessionBus;
+ else
+ {
+ // Try system bus then
+ interface = m_systemBus.interface();
++ if (start_daemon)
++ interface->startService("net.sf.cdemu.CDEMUD_Daemon");
+ if (interface->isServiceRegistered("net.sf.cdemu.CDEMUD_Daemon"))
+ m_currentBus = &m_systemBus;
+ else
+diff --git a/src/cdemu.h b/src/cdemu.h
+index c7b0655..8381c2f 100644
+--- a/src/cdemu.h
++++ b/src/cdemu.h
+@@ -56,7 +56,7 @@ private:
+ ~CDEmu();
+
+ void connectSlots(QDBusConnection *connection);
+- void findCurrentBus();
++ void findCurrentBus(bool start_daemon = false);
+ int nextFreeSlot();
+
+ QDBusConnection m_sessionBus;
+--
+1.7.8.3
+
diff --git a/app-cdr/kcdemu/kcdemu-0.3.1.ebuild b/app-cdr/kcdemu/kcdemu-0.3.1-r1.ebuild
index bc3c595f6ccf..266fdd9950ea 100644
--- a/app-cdr/kcdemu/kcdemu-0.3.1.ebuild
+++ b/app-cdr/kcdemu/kcdemu-0.3.1-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/kcdemu/kcdemu-0.3.1.ebuild,v 1.1 2010/10/06 20:02:40 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/kcdemu/kcdemu-0.3.1-r1.ebuild,v 1.1 2012/01/12 00:10:53 johu Exp $
-EAPI=3
+EAPI=4
KDE_LINGUAS="de es pl ro"
inherit kde4-base
@@ -19,6 +19,10 @@ IUSE="debug"
RDEPEND=">=app-cdr/cdemu-1.2.0"
+PATCHES=(
+ "${FILESDIR}/${P}-start-cdemud.patch"
+)
+
S=${WORKDIR}/${MY_PN}
DOCS=( ChangeLog )