summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2013-10-12 08:46:59 +0000
committerDaniel Pielmeier <billie@gentoo.org>2013-10-12 08:46:59 +0000
commitfd7903c2d0f470304e054f6bdd29c350d06869b8 (patch)
treea7c292cc04e3c5437da2e0d8817d59d6d389207f /app-cdr
parentversion bump (diff)
downloadgentoo-2-fd7903c2d0f470304e054f6bdd29c350d06869b8.tar.gz
gentoo-2-fd7903c2d0f470304e054f6bdd29c350d06869b8.tar.bz2
gentoo-2-fd7903c2d0f470304e054f6bdd29c350d06869b8.zip
Revision bump. Adding a patch by me and Joerg Schilling to fix bug #480666. Thanks to Thomas Maguin for the report and Joerg Schilling for debugging this issue.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 215AD14D)
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/cdrtools/ChangeLog11
-rw-r--r--app-cdr/cdrtools/cdrtools-3.01_alpha17-r1.ebuild159
-rw-r--r--app-cdr/cdrtools/files/cdrtools-3.01_alpha17-capabilities.patch88
3 files changed, 257 insertions, 1 deletions
diff --git a/app-cdr/cdrtools/ChangeLog b/app-cdr/cdrtools/ChangeLog
index 3946eec83020..c5b24b649d21 100644
--- a/app-cdr/cdrtools/ChangeLog
+++ b/app-cdr/cdrtools/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-cdr/cdrtools
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrtools/ChangeLog,v 1.313 2013/10/09 13:43:22 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrtools/ChangeLog,v 1.314 2013/10/12 08:46:59 billie Exp $
+
+*cdrtools-3.01_alpha17-r1 (12 Oct 2013)
+
+ 12 Oct 2013; Daniel Pielmeier <billie@gentoo.org>
+ +cdrtools-3.01_alpha17-r1.ebuild,
+ +files/cdrtools-3.01_alpha17-capabilities.patch:
+ Revision bump. Adding a patch by me and Jörg Schilling to fix bug #480666.
+ Thanks to Thomas Maguin for the report and Jörg Schilling for debugging this
+ issue.
09 Oct 2013; Jeroen Roovers <jer@gentoo.org> cdrtools-3.01_alpha17.ebuild:
Stable for HPPA (bug #486318).
diff --git a/app-cdr/cdrtools/cdrtools-3.01_alpha17-r1.ebuild b/app-cdr/cdrtools/cdrtools-3.01_alpha17-r1.ebuild
new file mode 100644
index 000000000000..b72020655020
--- /dev/null
+++ b/app-cdr/cdrtools/cdrtools-3.01_alpha17-r1.ebuild
@@ -0,0 +1,159 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrtools/cdrtools-3.01_alpha17-r1.ebuild,v 1.1 2013/10/12 08:46:59 billie Exp $
+
+EAPI=5
+
+inherit fcaps multilib eutils toolchain-funcs flag-o-matic
+
+MY_P="${P/_alpha/a}"
+
+DESCRIPTION="A set of tools for CD/DVD reading and recording, including cdrecord"
+HOMEPAGE="http://cdrecord.berlios.de/private/cdrecord.html"
+SRC_URI="ftp://ftp.berlios.de/pub/cdrecord/$([[ -z ${PV/*_alpha*} ]] && echo 'alpha/')/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1 CDDL-Schily"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="acl nls unicode"
+
+RDEPEND="acl? ( virtual/acl )
+ nls? ( virtual/libintl )
+ !app-cdr/cdrkit"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.18.1.1 )"
+
+S=${WORKDIR}/${P/_alpha[0-9][0-9]}
+
+FILECAPS=(
+ cap_sys_resource,cap_dac_override,cap_sys_admin,cap_sys_nice,cap_net_bind_service,cap_ipc_lock,cap_sys_rawio+ep usr/bin/cdrecord --
+ cap_dac_override,cap_sys_admin,cap_sys_nice,cap_net_bind_service,cap_sys_rawio+ep usr/bin/cdda2wav --
+ cap_dac_override,cap_sys_admin,cap_net_bind_service,cap_sys_rawio+ep usr/bin/readcd
+)
+
+src_prepare() {
+ # Remove profiled make files.
+ rm -f $(find . -name '*_p.mk') || die "rm profiled"
+
+ # Adjusting hardcoded paths.
+ sed -i -e 's:opt/schily:usr:' \
+ $(find ./ -type f -name \*.[0-9ch] -exec grep -l 'opt/schily' '{}' '+') \
+ || die "sed opt/schily"
+
+ sed -i -e "s:\(^INSDIR=\t\tshare/doc/\):\1${PF}/:" \
+ $(find ./ -type f -exec grep -l 'INSDIR.\+doc' '{}' '+') \
+ || die "sed doc"
+
+ # Respect libdir.
+ sed -i -e "s:\(^INSDIR=\t\t\)lib:\1$(get_libdir):" \
+ $(find ./ -type f -exec grep -l '^INSDIR.\+lib\(/siconv\)\?$' '{}' '+') \
+ || die "sed multilib"
+
+ # Do not install static libraries.
+ sed -i -e 's:include\t\t.*rules.lib::' \
+ $(find ./ -type f -exec grep -l '^include.\+rules\.lib' '{}' '+') \
+ || die "sed rules"
+
+ # Respect CC/CXX variables.
+ cd "${S}"/RULES
+ local tcCC=$(tc-getCC)
+ local tcCXX=$(tc-getCXX)
+ sed -i -e "/cc-config.sh/s|\$(C_ARCH:%64=%) \$(CCOM_DEF)|${tcCC} ${tcCC}|" \
+ rules1.top || die "sed rules1.top"
+ sed -i -e "/^\(CC\|DYNLD\|LDCC\|MKDEP\)/s|gcc|${tcCC}|" \
+ -e "/^\(CC++\|DYNLDC++\|LDCC++\|MKC++DEP\)/s|g++|${tcCXX}|" \
+ -e "/COPTOPT=/s/-O//" \
+ -e 's/$(GCCOPTOPT)//' \
+ cc-gcc.rul || die "sed cc-gcc.rul"
+ sed -i -e "s|^#CONFFLAGS +=\t-cc=\$(XCC_COM)$|CONFFLAGS +=\t-cc=${tcCC}|g" \
+ rules.cnf || die "sed rules.cnf"
+
+ # Create additional symlinks needed for some archs (armv4l already created)
+ local t
+ for t in armv4tl armv5tel armv7l ppc64 s390x; do
+ ln -s i586-linux-cc.rul ${t}-linux-cc.rul || die
+ ln -s i586-linux-gcc.rul ${t}-linux-gcc.rul || die
+ done
+
+ # Schily make setup.
+ cd "${S}"/DEFAULTS
+ local os="linux"
+ [[ ${CHOST} == *-darwin* ]] && os="mac-os10"
+
+ sed -i \
+ -e "s:/opt/schily:/usr:g" \
+ -e "s:/usr/src/linux/include::g" \
+ -e "s:bin:root:g" \
+ Defaults.${os} || die "sed Schily make setup"
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-capabilities.patch"
+}
+
+# skip obsolete configure script
+src_configure() { : ; }
+
+src_compile() {
+ if use unicode; then
+ local flags="$(test-flags -finput-charset=ISO-8859-1 -fexec-charset=UTF-8)"
+ if [[ -n ${flags} ]]; then
+ append-flags ${flags}
+ else
+ ewarn "Your compiler does not support the options required to build"
+ ewarn "cdrtools with unicode in USE. unicode flag will be ignored."
+ fi
+ fi
+
+ if ! use filecaps; then
+ CFLAGS="${CFLAGS} -DNO_LINUX_CAPS"
+ fi
+
+ if ! use acl; then
+ CFLAGS="${CFLAGS} -DNO_ACL"
+ fi
+
+ # If not built with -j1, "sometimes" cdda2wav will not be built.
+ emake -j1 CC="$(tc-getCC)" CPPOPTX="${CPPFLAGS}" COPTX="${CFLAGS}" \
+ LDOPTX="${LDFLAGS}" \
+ INS_BASE="${ED}/usr" INS_RBASE="${ED}" LINKMODE="dynamic" \
+ RUNPATH="" GMAKE_NOWARN="true"
+}
+
+src_install() {
+ # If not built with -j1, "sometimes" manpages are not installed.
+ emake -j1 CC="$(tc-getCC)" CPPOPTX="${CPPFLAGS}" COPTX="${CFLAGS}" \
+ LDOPTX="${LDFLAGS}" \
+ INS_BASE="${ED}/usr" INS_RBASE="${ED}" LINKMODE="dynamic" \
+ RUNPATH="" GMAKE_NOWARN="true" install
+
+ # These symlinks are for compat with cdrkit.
+ dosym schily /usr/include/scsilib
+ dosym ../scg /usr/include/schily/scg
+
+ dodoc ABOUT Changelog* CONTRIBUTING PORTING README.linux-shm READMEs/README.linux
+
+ cd "${S}"/cdda2wav
+ docinto cdda2wav
+ dodoc Changelog FAQ Frontends HOWTOUSE NEEDED README THANKS TODO
+
+ cd "${S}"/mkisofs
+ docinto mkisofs
+ dodoc ChangeLog* TODO
+
+ # Remove man pages related to the build system
+ rm -rvf "${ED}"/usr/share/man/man5
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ einfo
+ einfo "Darwin/OS X use the following device names:"
+ einfo
+ einfo "CD burners: (probably) ./cdrecord dev=IOCompactDiscServices"
+ einfo
+ einfo "DVD burners: (probably) ./cdrecord dev=IODVDServices"
+ einfo
+ fi
+}
diff --git a/app-cdr/cdrtools/files/cdrtools-3.01_alpha17-capabilities.patch b/app-cdr/cdrtools/files/cdrtools-3.01_alpha17-capabilities.patch
new file mode 100644
index 000000000000..83c61994445e
--- /dev/null
+++ b/app-cdr/cdrtools/files/cdrtools-3.01_alpha17-capabilities.patch
@@ -0,0 +1,88 @@
+--- cdrecord/priv.c 2013-10-12 09:51:46.385760482 +0200
++++ cdrecord/priv.c 2013-10-12 09:53:16.545766912 +0200
+@@ -111,14 +111,13 @@
+ /*
+ * Give up privs we do not need anymore.
+ * We no longer need:
+- * cap_dac_override,cap_net_bind_service,cap_sys_nice,cap_sys_resource
++ * cap_dac_override,cap_net_bind_service,cap_sys_nice
+ */
+ cap_t cset;
+ cap_value_t caplist[] = {
+ CAP_DAC_OVERRIDE,
+ CAP_NET_BIND_SERVICE,
+ CAP_SYS_NICE,
+- CAP_SYS_RESOURCE,
+ CAP_SYS_RAWIO, /* Keep as CAP_EFFECTIVE */
+ CAP_SYS_ADMIN /* Keep as CAP_EFFECTIVE */
+ };
+@@ -128,7 +127,7 @@
+ cap_set_flag(cset, CAP_EFFECTIVE, NCAPS-2, caplist, CAP_CLEAR);
+ cap_set_flag(cset, CAP_INHERITABLE, NCAPS, caplist, CAP_CLEAR);
+ if (cap_set_proc(cset) < 0)
+- errmsg("Cannot set process capabilities.\n");
++ errmsg("Cannot set initial process capabilities.\n");
+ #endif /* HAVE_LINUX_CAPS */
+ #endif /* HAVE_PRIV_SET */
+ }
+@@ -153,14 +152,13 @@
+ /*
+ * Get back privs we may need now.
+ * We need:
+- * cap_dac_override,cap_net_bind_service,cap_sys_nice,cap_sys_resource
++ * cap_dac_override,cap_net_bind_service,cap_sys_nice
+ */
+ cap_t cset;
+ cap_value_t caplist[] = {
+ CAP_DAC_OVERRIDE,
+ CAP_NET_BIND_SERVICE,
+- CAP_SYS_NICE,
+- CAP_SYS_RESOURCE
++ CAP_SYS_NICE
+ };
+
+ cset = cap_get_proc();
+@@ -168,7 +166,7 @@
+ cap_set_flag(cset, CAP_EFFECTIVE, NCAPS, caplist, CAP_SET);
+ cap_set_flag(cset, CAP_INHERITABLE, NCAPS, caplist, CAP_SET);
+ if (cap_set_proc(cset) < 0)
+- errmsg("Cannot set process capabilities.\n");
++ errmsg("Cannot regain process capabilities.\n");
+ #endif /* HAVE_LINUX_CAPS */
+ #endif /* HAVE_PRIV_SET */
+ }
+@@ -193,14 +191,13 @@
+ /*
+ * Give up privs we do not need anymore.
+ * We no longer need:
+- * cap_dac_override,cap_net_bind_service,cap_sys_nice,cap_sys_resource
++ * cap_dac_override,cap_net_bind_service,cap_sys_nice
+ */
+ cap_t cset;
+ cap_value_t caplist[] = {
+ CAP_DAC_OVERRIDE,
+ CAP_NET_BIND_SERVICE,
+- CAP_SYS_NICE,
+- CAP_SYS_RESOURCE
++ CAP_SYS_NICE
+ };
+
+ cset = cap_get_proc();
+@@ -208,7 +205,7 @@
+ cap_set_flag(cset, CAP_EFFECTIVE, NCAPS, caplist, CAP_CLEAR);
+ cap_set_flag(cset, CAP_INHERITABLE, NCAPS, caplist, CAP_CLEAR);
+ if (cap_set_proc(cset) < 0)
+- errmsg("Cannot set process capabilities.\n");
++ errmsg("Cannot deactivate process capabilities.\n");
+ #endif /* HAVE_LINUX_CAPS */
+ #endif /* HAVE_PRIV_SET */
+ }
+@@ -265,7 +262,7 @@
+ cap_set_flag(cset, CAP_INHERITABLE, NCAPS, caplist, CAP_CLEAR);
+ cap_set_flag(cset, CAP_PERMITTED, NCAPS, caplist, CAP_CLEAR);
+ if (cap_set_proc(cset) < 0)
+- errmsg("Cannot set process capabilities.\n");
++ errmsg("Cannot drop process capabilities.\n");
+ #endif /* HAVE_LINUX_CAPS */
+ #endif /* HAVE_PRIV_SET */
+ }